当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]修改一些参数后无法正常进入桌面
帖子发表于 : 2008-07-07 22:49 
头像

注册: 2008-07-02 13:47
帖子: 10
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
各位好:
我安装Ubuntu8.04 Desktop,在WindowsXP下安装的爽操作系统,安装完后一切正常,能顺利运行系统
在我做了以下操作后,重启系统发现使用用户名登陆后,屏幕无显示,过几秒钟屏幕左上方会出现一个“四分之一屏幕”大小的白色框,无任何内容。
使用Ctrl+backspace可以回到登陆界面;使用Ctrl+F4可以进入CLI,但始终无法正常进入桌面
烦请各位解答。

以下是我更改的动作
1.为了使用root直接登陆,我做了以下操作:
更改了/etc/gdm/gdm.conf文件,将其中的AllowRoot中“false”参数更改为“true”
2.设置网络参数
/etc/network/interfaces
auto eth0
iface eth0 inet static
address x.x.x.x
netmask x.x.x.x
gateway x.x.x.x

3.设置DNS参数
/etc/resolv.conf
nameserver x.x.x.x

请各位赐教


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-07 23:35 
头像

注册: 2008-07-02 13:47
帖子: 10
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
各位,我发现问题所在了,但还不知道确切解决办法
如下:
问题出在第2步:设置网络参数
也就是interfaces文件
原先的interfaces文件内容是这样的:
auto lo
iface lo inet loopback

我如果更改回原有配置,问题得以解决
但是我必须使用我的物理网卡eth0来上网
那么我应该怎么写配置呢?
请各位赐教


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-08 9:42 
头像

注册: 2008-07-02 13:47
帖子: 10
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
找出问题所在了

/etc/network/interfaces文件中,必须包含loopback接口
否则无法正常启动,以下是我现在文件中的配置内容:

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address x.x.x.x
netmask x.x.x.x
gateway x.x.x.x


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-08 11:36 
头像

注册: 2007-06-13 15:57
帖子: 12565
地址: 在他乡
送出感谢: 50
接收感谢: 87
标记


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译