当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决][问题]在线等!!!很急,安装NVIDIA显卡驱动时候出问题了。
帖子发表于 : 2008-07-10 17:02 

注册: 2008-06-18 20:31
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我新装的是UBUNTUSTUDIO 8.04.1。在安装一个软件后发现软件工作报错于是我就在官网下载了最新的驱动NVIDIA-Linux-x86_64-173.14.09-pkg2.run,并且按照网上下载的步骤安装出错了.
我安装的步骤是:
1、下载驱动
从http://www.nvidia.com/page/home.html这里寻找你所需要的驱动
我下载的就是NVIDIA-Linux-x86_64-173.14.09-pkg2.run

2、删除原驱动包
sudo apt-get --purge remove nvidia-glx nvidia-glx-new
然后删除 /lib/linux-restricted-modules/2.6.24-14-generic/文件夹下面带有nvidia字样的内容,这里是内核自带的驱动
再检查一下这两个文件是否存在,
/etc/init.d/nvidia-glx
/etc/init.d/nvidia-kernel
假如存在,删除掉。

3、安装要用到的软体
sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`
安装编译包。

4、备份
sudo cp /etc/default/linux-restricted-modules-common \ etc/default/linux-restricted-modules-common.backup

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

5、禁止系统使用默认的驱动
sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号中添加nv nvidia_new,即把文件中的“”,改成“nv nvidia_new”
假如前面第二步删除完整了其实也可以不用执行这一步。

6、停止GDM进程
sudo /etc/init.d/gdm stop
按Ctrl Alt F1,登录后进入第7步。

7、进入下好的驱动所在目录(用ls命令确认文件在不在)
sudo sh NVIDIA-Linux-x86-173.08-pkg1.run
安装过程中,假如提示有旧驱动,询问是否删除旧驱动,选Yes;
假如提示缺少某某模块(modules),询问是否上网下载,选no;
假如提示编译模块,询问是否进行编译,选ok;
假如提示将要修改Xorg.conf,询问是否答应,选Yes;
接下来就是等待安装完成。

8、安装完成就回到终端,重启GDM
sudo /etc/init.d/gdm restart
好了,当看到NV的logo后,安装成功。

查看显卡是否装好
运行glxinfo | grep rendering
假如显示"direct rendering: Yes",则已安装

9、如果实在不想看NVIDIA的LOGO,可以修改 /etc/X11/xorg.conf
在Section "Device"中添加Option "NoLogo" "True"

如:
Section "Device"
Identifier "通用显示卡"
Driver "nvidia"
Option "NoLogo" "True"
EndSection


===============
在做到第7部的时候我SUDO SH NVIDIA-Linux-x86_64-173.14.09-pkg2.run后,提示缺少某某模块(modules),询问是否上网下载,选no;假如提示编译模块,询问是否进行编译,选ok; 进度条读一半就报错了错误信息是:
ERROR:unable to build the NVIDIA kernel module
现在怎么搞也不能装新驱动,也回不去图形界面了。我是不是还缺什么步骤没做??请各位大虾指导下我这个初学者
显卡是Quadro FX 3500


最后由 huangling2000 编辑于 2008-07-11 0:54,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-10 20:44 
头像

注册: 2005-10-25 13:54
帖子: 272
送出感谢: 0 次
接收感谢: 0 次
很明显错误是Nvidia驱动模块无法被内核支持。请查一下与你内核版本对应的linux-header是否安装上。可能你原有的驱动模块并没有删除。如果系统没有安装过任何驱动或者驱动已安全卸载运行下面的命令可以还原配置

代码:
sudo dpkg-reconfigure xserver-xorg


你的显卡已被Ubuntu支持,我推荐你安装系统自带的驱动。如果出现分辨率的问题请参考wiki上的快速设置之热门设置里的内容加以修改。

下面似乎是你的操作错误:
你操作的第四步和第五步看起来是有问题的。这步操作是要让系统禁用原有的nvidia驱动。

第四步备份的命令行是错误的应是这样
代码:
sudo cp /etc/default/linux-restricted-modules-common \
/etc/default/linux-restricted-modules-common.backup
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup


第五步中补充一下
/etc/default/linux-restricted-modules或者/etc/default/linux-restricted-modules-common这两个文件是linux-restricted-modules和linux-restricted-modules-common的配置文件,如果你的系统中linux-restricted-modules和linux-restricted-modules-common没有卸掉的话,你可以试着改下他们两个的配置文件加入下面这行

代码:
DISABLED_MODULES="nv nvidia_new"


如果你压根就没有装过驱动,这步是不需要操作的。这两步是针对装过Ubuntu源里提供驱动而准备的。如果你不想改配置,直接卸载linux-restricted-modules和linux-restricted-modules-common这两个包就行了。改配置的操作是有留有余地的。

另外,如果你发现这个文件存在,请干掉他
/lib/linux-restricted-modules/.nvidia_new_installed


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-11 0:54 

注册: 2008-06-18 20:31
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
问题已经解决了,看了一个帖子安装了一个小软件http://b2d.phc.edu.tw/modules/tadbook2/view.php?bdsn=1155
感谢楼上细心讲解


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-11 6:40 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
lyp069 写道:
很明显错误是Nvidia驱动模块无法被内核支持。请查一下与你内核版本对应的linux-header是否安装上。可能你原有的驱动模块并没有删除。如果系统没有安装过任何驱动或者驱动已安全卸载运行下面的命令可以还原配置

代码:
sudo dpkg-reconfigure xserver-xorg


你的显卡已被Ubuntu支持,我推荐你安装系统自带的驱动。如果出现分辨率的问题请参考wiki上的快速设置之热门设置里的内容加以修改。

下面似乎是你的操作错误:
你操作的第四步和第五步看起来是有问题的。这步操作是要让系统禁用原有的nvidia驱动。

第四步备份的命令行是错误的应是这样
代码:
sudo cp /etc/default/linux-restricted-modules-common \
/etc/default/linux-restricted-modules-common.backup
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup


第五步中补充一下
/etc/default/linux-restricted-modules或者/etc/default/linux-restricted-modules-common这两个文件是linux-restricted-modules和linux-restricted-modules-common的配置文件,如果你的系统中linux-restricted-modules和linux-restricted-modules-common没有卸掉的话,你可以试着改下他们两个的配置文件加入下面这行

代码:
DISABLED_MODULES="nv nvidia_new"


如果你压根就没有装过驱动,这步是不需要操作的。这两步是针对装过Ubuntu源里提供驱动而准备的。如果你不想改配置,直接卸载linux-restricted-modules和linux-restricted-modules-common这两个包就行了。改配置的操作是有留有余地的。

另外,如果你发现这个文件存在,请干掉他
/lib/linux-restricted-modules/.nvidia_new_installed


推荐新手直接安装系统的受限驱动

至少不会像我自己搞了一个晚上还是不行

后来发下显卡驱动太新了 :shock: 竟然无法安装 :evil:

那个郁闷啊

又换了一个老板本的,就好了 :lol:


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-22 15:18 
头像

注册: 2007-05-06 8:19
帖子: 7433
送出感谢: 0 次
接收感谢: 4
第5,直接给改这文件不好么,为什么在第2步删文件呢,
第6不无效;


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-22 18:05 

注册: 2007-11-03 16:37
帖子: 263
送出感谢: 0 次
接收感谢: 0 次
怎么我找不到NVIDIA-Linux-x86_64-173.14.09-pkg2.run

最新的不是NVIDIA-Linux-x86-173.14.05-pkg1.run吗?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-22 18:07 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
kingpin 写道:
怎么我找不到NVIDIA-Linux-x86_64-173.14.09-pkg2.run

最新的不是NVIDIA-Linux-x86-173.14.05-pkg1.run吗?


一个是32位, 一个是64位


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译