[问题]ubuntu真实终端显示乱码

系统安装、升级讨论
Zhy
帖子: 96
注册时间: 2008-03-16 12:09
送出感谢: 0
接收感谢: 0
联系:

[问题]ubuntu真实终端显示乱码

#1

帖子 Zhy » 2008-07-16 20:19

如题,这里的终端,不是附件->终端的终端,而是Ctrl+Alt+F1~F6的真实终端
这是一个汉字的编码问题,我不知道怎么样修改,我试过
export LANG="Zh_cn,GB18030,GB2812"
结果,原先中文显示的菱形变成了问号。
不想把系统的默认编码改成GB18030,否则关机时,就会显示乱码,最好是能让终端自动识别汉字编码的
有办法吗?

那个gnome-terminal,可能的话,也想让它自动识别汉字编码
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 solcomo » 2008-07-16 20:21

framebuffer
zhcon
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
Zhy
帖子: 96
注册时间: 2008-03-16 12:09
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Zhy » 2008-07-16 20:28

乖,我四级还没过呢,是否考虑用大家都听的懂得语言,详细些,否则不知我的系统会出什么乱子
Zhy
帖子: 96
注册时间: 2008-03-16 12:09
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 Zhy » 2008-08-13 3:09

是不是这个问题很傻很天真? 都不屑回答的样子
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 想入非非 » 2008-08-13 4:25

LZ你的中文编码是不是写错了,还是笔误?应该是GB2312,而不是GB2812
Ubuntu User
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

#6

帖子 yjcong » 2008-08-13 7:04

Zhy 写了:乖,我四级还没过呢,是否考虑用大家都听的懂得语言,详细些,否则不知我的系统会出什么乱子


如果你确定在论坛里搜索了, 但没有找到结果请注明。 这个东西至少在前不久被讨论过一次。
一梦三年,
松风依旧,
萝月何曾老.


灵幽听微, 谁观玉颜?
灼灼春华, 绿叶含丹.
JiangHui
论坛版主
帖子: 21303
注册时间: 2007-08-02 20:29
系统: 窓辺とうこ
送出感谢: 0
接收感谢: 13 次

#7

帖子 JiangHui » 2008-08-13 7:44

sudo apt-get install zhcon
zhcon --uft8 --drv=vga
如果开了framebuffer,可以
zhcon --utf8 --drv=fb
Zhy
帖子: 96
注册时间: 2008-03-16 12:09
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 Zhy » 2008-09-01 13:05

谢谢大家的热心帮助
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#9

帖子 eexpress » 2008-09-01 13:58

enconv就是。
● 鸣学
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 BigSnake.NET » 2008-09-01 13:59

那个终端本身就不支持显示中文的,你设什么都没用
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 想入非非 » 2008-09-01 15:01

代码: 全选

zhcon --uft8 --drv=vga 

这个代码在我的笔电上执行之后必然出现花屏。。。
不知道是什么原因 :lol:
PS:系统稳定运行了很长时间
Ubuntu User
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 想入非非 » 2008-09-01 19:38

BigSnake.NET 写了:那个终端本身就不支持显示中文的,你设什么都没用

这个失望了。。。。
Ubuntu User
marble
帖子: 2
注册时间: 2008-08-08 10:35
送出感谢: 0
接收感谢: 0

Re:

#13

帖子 marble » 2009-02-06 15:08

JiangHui 写了:sudo apt-get install zhcon
zhcon --uft8 --drv=vga
如果开了framebuffer,可以
zhcon --utf8 --drv=fb

如果我用用zhcon --utf8 --drv=fb,就会提示Can not open FrameBuffer device on this device,然后下面是
============== I'm really sorry, but... ================
I can not open graphical device on this machine, this can happen when:
1. your kernel does not have framebuffer device enabled, check the output from `dmesg|grep vesa`
2. you are running on a non-i386 machine so no VGA support
3. you are running under X-Window but libggi is not compiled in (required for running zhcon under X-Window)
……
如果我用zhcon --utf8 --drv=vga,就直接I'm sorry了,这事咋回事呢?
难道是我的AMD64和宽屏的问题?
dai519210
帖子: 5
注册时间: 2010-08-12 22:16
送出感谢: 0
接收感谢: 0

Re: Re:

#14

帖子 dai519210 » 2010-10-27 22:38

marble 写了:
JiangHui 写了:sudo apt-get install zhcon
zhcon --uft8 --drv=vga
如果开了framebuffer,可以
zhcon --utf8 --drv=fb
如果我用用zhcon --utf8 --drv=fb,就会提示Can not open FrameBuffer device on this device,然后下面是
============== I'm really sorry, but... ================
I can not open graphical device on this machine, this can happen when:
1. your kernel does not have framebuffer device enabled, check the output from `dmesg|grep vesa`
2. you are running on a non-i386 machine so no VGA support
3. you are running under X-Window but libggi is not compiled in (required for running zhcon under X-Window)
……
如果我用zhcon --utf8 --drv=vga,就直接I'm sorry了,这事咋回事呢?
难道是我的AMD64和宽屏的问题?


我的也这样
用zhcon --utf8 --drv=fb也是一样乱码
等待解决中
爱情,就是眼与眼的对视,肉体与肉体的摩擦,体液与体液的交换!
头像
pityonline
帖子: 3864
注册时间: 2008-12-09 12:44
来自: 北京
送出感谢: 0
接收感谢: 2 次
联系:

Re: [问题]ubuntu真实终端显示乱码

#15

帖子 pityonline » 2010-10-27 22:51

Pity is the bomp!
活着就是折腾!生命不息,折腾不止!
看这帮家伙在干什么?@pityonline/u
Dropbox+Vps+PC 跑起来了!这是邀请链接
回复

回到 “系统安装和升级”