当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]升级升过头了
帖子发表于 : 2008-07-17 7:14 
头像

注册: 2008-02-25 21:20
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
把重要安全更新升级之后系统还可以,什么问题都没得,然后继续安装建议更新,安装之后就有功能不正常了,比如说awn一启动就卡死,现在有没得办法恢复到没有安装建议更新的时候啊,麻烦各位了


图片


_________________
http://www.twxie.cn

个人站点,不好意思

只要你要,只要我有


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-17 8:46 

注册: 2007-12-06 23:52
帖子: 85
送出感谢: 0 次
接收感谢: 0 次
请教楼主,屏幕下方那行是什么啊?怎样搞出来的?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-17 8:51 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
awn


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-17 9:07 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
昏,这个要解释怎么搞的话又是超长的。

简单的说:
sudo apt-get install apt-file
sudo apt-file update
apt-file list awn|grep changelog.Debian.gz|awk '{print $2}'
zless [上一部的话修改的包]
以firefox为例

代码:
firefox-3.0 (3.0+nobinonly-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * New upstream release: 3.0 (LP: #237690)

  [ Alexander Sack <asac@ubuntu.com> ]
  * include fix for LP: #236266 - "Build Failure on HPPA architecture" by
    applying patch from bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=43
6133
    but keep it disabled for stable release updates.
    - add debian/patches/bz436133_att322801.patch
    - update debian/patches/series
  * drop left-over patch that disabled parts of safe-browsing by default.
    - delete debian/patches/force_safebrowsing_off.patch
    - update debian/firefox.js
    - update debian/patches/series

从旧版本取回这些文件即可

其实这些这我的电脑中原选就设置的服务来通知我。
或是


代码:
sudo aptitude  purge  libawn0
然后重装得了
我记得这种包依赖被破坏
在Debian手册中是apt-listchanges,然后把关心的变更发到你的邮箱。

重装比较简单


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-17 9:47 
头像

注册: 2008-02-25 21:20
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
kofshower 写道:
昏,这个要解释怎么搞的话又是超长的。

简单的说:
sudo apt-get install apt-file
sudo apt-file update
apt-file list awn|grep changelog.Debian.gz|awk '{print $2}'
zless [上一部的话修改的包]
以firefox为例

代码:
firefox-3.0 (3.0+nobinonly-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * New upstream release: 3.0 (LP: #237690)

  [ Alexander Sack <asac@ubuntu.com> ]
  * include fix for LP: #236266 - "Build Failure on HPPA architecture" by
    applying patch from bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=43
6133
    but keep it disabled for stable release updates.
    - add debian/patches/bz436133_att322801.patch
    - update debian/patches/series
  * drop left-over patch that disabled parts of safe-browsing by default.
    - delete debian/patches/force_safebrowsing_off.patch
    - update debian/firefox.js
    - update debian/patches/series

从旧版本取回这些文件即可

其实这些这我的电脑中原选就设置的服务来通知我。
或是


代码:
sudo aptitude  purge  libawn0
然后重装得了
我记得这种包依赖被破坏
在Debian手册中是apt-listchanges,然后把关心的变更发到你的邮箱。

重装比较简单
LS的老大是强人,我看了大半天没看懂你这个是什么意思,能不能具体的解释一下也,我现在是根本不能上网的情况下要恢复回去怎么办呢,电脑在家里的,但是家里不能上网,发帖子都是我到了公司在发的


_________________
http://www.twxie.cn

个人站点,不好意思

只要你要,只要我有


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-17 10:58 

注册: 2006-08-28 9:08
帖子: 749
地址: 安徽/安庆
送出感谢: 0 次
接收感谢: 0 次
只用将有问题的软件降级就可以了,
在新立得里,
选中有问题的软件,(搜索"awn",选取所有与awn有关的,)
然后,软件-->强制版本,
选升级以前的版就可以了.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-17 11:23 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
twxie 写道:
kofshower 写道:
昏,这个要解释怎么搞的话又是超长的。

简单的说:
sudo apt-get install apt-file
sudo apt-file update
apt-file list awn|grep changelog.Debian.gz|awk '{print $2}'
zless [上一部的话修改的包]
以firefox为例

代码:
firefox-3.0 (3.0+nobinonly-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * New upstream release: 3.0 (LP: #237690)

  [ Alexander Sack <asac@ubuntu.com> ]
  * include fix for LP: #236266 - "Build Failure on HPPA architecture" by
    applying patch from bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=43
6133
    but keep it disabled for stable release updates.
    - add debian/patches/bz436133_att322801.patch
    - update debian/patches/series
  * drop left-over patch that disabled parts of safe-browsing by default.
    - delete debian/patches/force_safebrowsing_off.patch
    - update debian/firefox.js
    - update debian/patches/series

从旧版本取回这些文件即可

其实这些这我的电脑中原选就设置的服务来通知我。
或是


代码:
sudo aptitude  purge  libawn0
然后重装得了
我记得这种包依赖被破坏
在Debian手册中是apt-listchanges,然后把关心的变更发到你的邮箱。

重装比较简单
LS的老大是强人,我看了大半天没看懂你这个是什么意思,能不能具体的解释一下也,我现在是根本不能上网的情况下要恢复回去怎么办呢,电脑在家里的,但是家里不能上网,发帖子都是我到了公司在发的


喔喔,不能上网的话比较麻烦,因为你的依赖关系要去网上取。
而且上面的是刚接触是不好掌握,总之怀疑是libawn0出了问题吧,不能上网的话就从这儿下deb回家安装吧。

http://ppa.launchpad.net/awn-testing/ub ... ol/main/a/
的avant-window-navigator-trunk 和 awn-extras-applets-trunk
先卸载 sudo apt-get --purge remove XX
然后安装 sudo dpkg -i XX


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-17 11:48 
头像

注册: 2008-02-25 21:20
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
kofshower 写道:
twxie 写道:
kofshower 写道:
昏,这个要解释怎么搞的话又是超长的。

简单的说:
sudo apt-get install apt-file
sudo apt-file update
apt-file list awn|grep changelog.Debian.gz|awk '{print $2}'
zless [上一部的话修改的包]
以firefox为例

代码:
firefox-3.0 (3.0+nobinonly-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * New upstream release: 3.0 (LP: #237690)

  [ Alexander Sack <asac@ubuntu.com> ]
  * include fix for LP: #236266 - "Build Failure on HPPA architecture" by
    applying patch from bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=43
6133
    but keep it disabled for stable release updates.
    - add debian/patches/bz436133_att322801.patch
    - update debian/patches/series
  * drop left-over patch that disabled parts of safe-browsing by default.
    - delete debian/patches/force_safebrowsing_off.patch
    - update debian/firefox.js
    - update debian/patches/series

从旧版本取回这些文件即可

其实这些这我的电脑中原选就设置的服务来通知我。
或是


代码:
sudo aptitude  purge  libawn0
然后重装得了
我记得这种包依赖被破坏
在Debian手册中是apt-listchanges,然后把关心的变更发到你的邮箱。

重装比较简单
LS的老大是强人,我看了大半天没看懂你这个是什么意思,能不能具体的解释一下也,我现在是根本不能上网的情况下要恢复回去怎么办呢,电脑在家里的,但是家里不能上网,发帖子都是我到了公司在发的


喔喔,不能上网的话比较麻烦,因为你的依赖关系要去网上取。
而且上面的是刚接触是不好掌握,总之怀疑是libawn0出了问题吧,不能上网的话就从这儿下deb回家安装吧。

http://ppa.launchpad.net/awn-testing/ub ... ol/main/a/
的avant-window-navigator-trunk 和 awn-extras-applets-trunk
先卸载 sudo apt-get --purge remove XX
然后安装 sudo dpkg -i XX
恩 那么多包,我下哪个回家去啊,我不知道我家里的是哪个了也,我只知道我搞到最新的了,cn99的源提示都没得任何更新老


_________________
http://www.twxie.cn

个人站点,不好意思

只要你要,只要我有


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-17 12:42 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
这个简单呀,trunk下面一般都是最新的编译。
比如avant-window-navigator-data-trunk_0.3.1~bzr359-gutsy1-1_all.deb 08-Jul-2008 19:01 282K
后面有日期包名有系统版本,bzr359多半是表明svn上的branch版本号
这个的意思就是08-Jul-2008上传的avant-window-navigator-data-trunk包,版本好为0.3.1,是从代码的bzr359上checkout编译出来的
这个包就是ubuntu gusty的最新的数据安装包
如果你的系统是8.04,且是i386的话就是这些:
代码:
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/avant-window-navigator-data-trunk_0.3.1~bzr410-hardy1-1_all.deb
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/avant-window-navigator-trunk_0.3.1~bzr410-hardy1-1_i386.deb
wget -i http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/awn-manager-trunk_0.3.1~bzr410-hardy1-1_all.deb
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/libawn0-trunk_0.3.1~bzr410-hardy1-1_i386.deb
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/awn-extras-applets-trunk/awn-extras-applets-trunk_0.3.1~bzr740-hardy1-1_i386.deb

关键是这个libawn0-trunk_0.3.1,下面那些python的估计是二次开发的接口。我想不要下载咯


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-07-17 16:22 
头像

注册: 2008-02-25 21:20
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
kofshower 写道:
这个简单呀,trunk下面一般都是最新的编译。
比如avant-window-navigator-data-trunk_0.3.1~bzr359-gutsy1-1_all.deb 08-Jul-2008 19:01 282K
后面有日期包名有系统版本,bzr359多半是表明svn上的branch版本号
这个的意思就是08-Jul-2008上传的avant-window-navigator-data-trunk包,版本好为0.3.1,是从代码的bzr359上checkout编译出来的
这个包就是ubuntu gusty的最新的数据安装包
如果你的系统是8.04,且是i386的话就是这些:
代码:
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/avant-window-navigator-data-trunk_0.3.1~bzr410-hardy1-1_all.deb
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/avant-window-navigator-trunk_0.3.1~bzr410-hardy1-1_i386.deb
wget -i http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/awn-manager-trunk_0.3.1~bzr410-hardy1-1_all.deb
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/avant-window-navigator-trunk/libawn0-trunk_0.3.1~bzr410-hardy1-1_i386.deb
wget -c http://ppa.launchpad.net/awn-testing/ubuntu/pool/main/a/awn-extras-applets-trunk/awn-extras-applets-trunk_0.3.1~bzr740-hardy1-1_i386.deb

关键是这个libawn0-trunk_0.3.1,下面那些python的估计是二次开发的接口。我想不要下载咯
好人啊,谢了


_________________
http://www.twxie.cn

个人站点,不好意思

只要你要,只要我有


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-07-17 19:43 

注册: 2006-12-31 10:48
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
请看这里,我和你同样的问题,照这样搞好了.
http://forum.ubuntu.org.cn/viewtopic.ph ... 205#843205


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-07-18 7:20 
头像

注册: 2008-02-25 21:20
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
manu2 写道:
请看这里,我和你同样的问题,照这样搞好了.
http://forum.ubuntu.org.cn/viewtopic.ph ... 205#843205

我的已经可以了
直接锁定版本,把版本降下去就可以了的,其实就是那个lib..的问题


_________________
http://www.twxie.cn

个人站点,不好意思

只要你要,只要我有


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-07-18 9:22 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
twxie 写道:
manu2 写道:
请看这里,我和你同样的问题,照这样搞好了.
http://forum.ubuntu.org.cn/viewtopic.ph ... 205#843205

我的已经可以了
直接锁定版本,把版本降下去就可以了的,其实就是那个lib..的问题

你的标题起的太强悍的了, :P 。开始就让我很好奇,那会是什么样


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-07-18 9:32 
头像

注册: 2008-02-25 21:20
帖子: 76
送出感谢: 0 次
接收感谢: 0 次
kofshower 写道:
twxie 写道:
manu2 写道:
请看这里,我和你同样的问题,照这样搞好了.
http://forum.ubuntu.org.cn/viewtopic.ph ... 205#843205

我的已经可以了
直接锁定版本,把版本降下去就可以了的,其实就是那个lib..的问题

你的标题起的太强悍的了, :P 。开始就让我很好奇,那会是什么样
呵呵,标题党飘过


_________________
http://www.twxie.cn

个人站点,不好意思

只要你要,只要我有


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-07-18 16:54 

注册: 2008-07-06 15:27
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
为什么你们的UBUNTU那么多问题?我用到现在也没出什么问题。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译