[问题] lilo 引导问题,加了RAID0盘 不能引导linux 了。

系统安装、升级讨论
回复
头像
yuandingrj
帖子: 12
注册时间: 2008-07-01 19:35
送出感谢: 0
接收感谢: 0

[问题] lilo 引导问题,加了RAID0盘 不能引导linux 了。

#1

帖子 yuandingrj » 2008-07-18 4:34

安装的时间把 fake raid(装了windowsxp) 两个盘给拆了,直接将ubuntu-server 版装到pata 硬盘上,自己分区,结果系统提示装了lilo 引导系统。当然如果不加两个raid 盘,linux 正常启动和运行。用 find -l 看到 系统把这个pata 设置为 /dev/sda(为什么现在系统把pata硬盘认识为sda 而不是hda,可能是现在主板硬件问题)。
问题来了,如果把两个组raid 的sata硬盘装上就无法引导了,出现了“waiting for root file system" 就死在那里。从引导显示信息来看是把加的两个raid 盘,系统设置成sda和sdb 了,把这个pata盘设置成 sdc,我单独进入linux系统(不带raid盘) ,改lilo.conf 文件,将以前的boot =dev/sdc ,等相关的都改了sdc,但还是提示“waiting for root file system" ,进了linux系统(带raid盘),现在还没考虑如何引导两个系统。

请那位大侠帮我解决一下这个问题。
上次由 yuandingrj 在 2008-07-18 13:20,总共编辑 1 次。
N78V 昂达主板 NF5 AMD CPU 5000+
8G内存 一个pata 250G硬盘,2个SATA组fake raid0
头像
冲浪板
论坛版主
帖子: 7466
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

#2

帖子 冲浪板 » 2008-07-18 6:46

装raid的驱动?
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#3

帖子 dogfox » 2008-07-18 7:05

貌似lilo属于早期淘汰的引导,现在普遍使用的是grub
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
yuandingrj
帖子: 12
注册时间: 2008-07-01 19:35
送出感谢: 0
接收感谢: 0

#4

帖子 yuandingrj » 2008-07-18 13:19

dogfox 写了:貌似lilo属于早期淘汰的引导,现在普遍使用的是grub
系统强制装,lilo,也装过grub但真的无法启动。主要是启动在挂载点‘/'在sda1.
N78V 昂达主板 NF5 AMD CPU 5000+
8G内存 一个pata 250G硬盘,2个SATA组fake raid0
头像
yuandingrj
帖子: 12
注册时间: 2008-07-01 19:35
送出感谢: 0
接收感谢: 0

#5

帖子 yuandingrj » 2008-07-21 23:09

这个问题还没人解决啊,可能有3个硬盘的人不多。主要是为什么现在把pata的硬盘ubuntu也识别成sda(新主板),而不是hda!引导程序中是那段把自己的硬盘将单盘sda,在加了raid0(两个硬盘)后变成sdc了?
头像
yuandingrj
帖子: 12
注册时间: 2008-07-01 19:35
送出感谢: 0
接收感谢: 0

#6

帖子 yuandingrj » 2008-07-24 14:31

没高人帮忙来解决这个问题,我现在只能在虚拟环境下玩linux ,难道内核记住系统指向sda,为什么新加进的盘有被设置成sda??
N78V 昂达主板 NF5 AMD CPU 5000+
8G内存 一个pata 250G硬盘,2个SATA组fake raid0
回复

回到 “系统安装和升级”