当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题] 在线等待 删除了 /lib/ ld-linux.so.2 如何解决啊????
帖子发表于 : 2008-07-31 21:56 

注册: 2006-07-18 16:15
帖子: 67
送出感谢: 0 次
接收感谢: 0 次
如题。。
使用ubuntu 6.06

想升级 glibc 用腾讯的原装qq,


自己把/lib/ ld-linux.so.2 删除了。。。如何恢复??

现在控制台除了 cd 以外其他指令都无效了

不能新建控制台了

字符模式的控制台无法登录。。。。。

估计重启后就挂了。。。。。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-31 21:57 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
用个 livecd 复制一份回去


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-31 22:03 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
直接后果是所有用动态链接库的程序不能用


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-31 22:03 
头像

注册: 2006-09-02 14:18
帖子: 5308
地址: 汉桑城
送出感谢: 1
接收感谢: 1
代码:
sudo ln -s /lib/ld-2.7.so /lib/ld-linux.so.2


_________________
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-31 22:16 

注册: 2006-07-18 16:15
帖子: 67
送出感谢: 0 次
接收感谢: 0 次
感谢各位大大。。

已经用一个gentoo的mini 安装光盘修复,真是一身冷汗啊

。。我保留gentoo的mini 安装光盘是为了使用memtest检测内存,至于ubuntu 我都是硬盘安装alternative光盘镜像。。



有哪位可以提供glibc升级的资料?在控制台中把编译的glibc-2.7加入LD_LIBRARY_PATH后所有指令都回复“段错误”。。。。。。。。。


最后由 zzsczz 编辑于 2008-07-31 22:20,总共编辑了 1 次

页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-31 22:17 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
zzsczz 写道:
感谢各位大大。。

已经用一个gentoo的mini 安装光盘修复,真是一身冷汗啊

。。我保留gentoo的mini 安装光盘是为了使用memtest检测内存,至于ubuntu 我都是硬盘安装alternative光盘。。



有哪位可以提供glibc升级的资料?在控制台中把编译的glibc-2.7加入LD_LIBRARY_PATH后所有指令都回复“段错误”。。。。。。。。。


很难了, 你升级系统吧


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-01 5:36 
头像

注册: 2007-03-13 11:23
帖子: 1343
送出感谢: 0 次
接收感谢: 0 次
去ubuntu source pool取一个来编译:
glibc-source: /usr/src/glibc/glibc-2.7.tar.bz2
glibc-source: /usr/src/glibc/glibc-libidn-2.7.tar.bz2
glibc-source: /usr/src/glibc/glibc-ports-2.7.tar.bz2
先apt-get source XX
然后dpkg-buildpackage -rfakeroot -uc -b


_________________
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-01 16:08 

注册: 2006-07-18 16:15
帖子: 67
送出感谢: 0 次
接收感谢: 0 次
kofshower 写道:
去ubuntu source pool取一个来编译:
glibc-source: /usr/src/glibc/glibc-2.7.tar.bz2
glibc-source: /usr/src/glibc/glibc-libidn-2.7.tar.bz2
glibc-source: /usr/src/glibc/glibc-ports-2.7.tar.bz2
先apt-get source XX
然后dpkg-buildpackage -rfakeroot -uc -b



不够详细哟。。。会高挂系统的。。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-06 17:03 

注册: 2006-07-18 16:15
帖子: 67
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
zzsczz 写道:
感谢各位大大。。

已经用一个gentoo的mini 安装光盘修复,真是一身冷汗啊

。。我保留gentoo的mini 安装光盘是为了使用memtest检测内存,至于ubuntu 我都是硬盘安装alternative光盘。。



有哪位可以提供glibc升级的资料?在控制台中把编译的glibc-2.7加入LD_LIBRARY_PATH后所有指令都回复“段错误”。。。。。。。。。


很难了, 你升级系统吧


不行,var 分区小了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译