damn it! locales errors, help! I can not apt-get

系统安装、升级讨论
回复
fks1945
帖子: 82
注册时间: 2007-08-18 6:00
送出感谢: 0
接收感谢: 0

damn it! locales errors, help! I can not apt-get

#1

帖子 fks1945 » 2008-08-03 5:23

fallow as my operation step(sorry, I can not type Chinese):

hen I upgrade 7.10, there is error stop on:

代码: 全选

Generating locales...
  en_AU.UTF-8... dpkg: error processing locales (--configure):
and I found some of code to fix this:

代码: 全选

sudo apt-get -f install

代码: 全选

dpkg --configure -a

代码: 全选

sudo apt-get install locales
But! If I can not apt-get, and also can not dpkg, what can i do now?

please, can you get it?
fks1945
帖子: 82
注册时间: 2007-08-18 6:00
送出感谢: 0
接收感谢: 0

#2

帖子 fks1945 » 2008-08-03 5:26

how to remove en_AU.UTF-8... ?
fks1945
帖子: 82
注册时间: 2007-08-18 6:00
送出感谢: 0
接收感谢: 0

#3

帖子 fks1945 » 2008-08-03 5:33

fan@fan-desktop:~$ sudo dpkg --configure -a
[sudo] password for fan:
Setting up locales (2.7.9-4) ...
Generating locales...
en_AU.UTF-8...
fks1945
帖子: 82
注册时间: 2007-08-18 6:00
送出感谢: 0
接收感谢: 0

#4

帖子 fks1945 » 2008-08-03 5:34

fan@fan-desktop:~$ sudo apt-get remove locales
[sudo] password for fan:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
fan@fan-desktop:~$
fks1945
帖子: 82
注册时间: 2007-08-18 6:00
送出感谢: 0
接收感谢: 0

#5

帖子 fks1945 » 2008-08-03 5:35

分辨率无法修改,窗口按钮丢失
回复

回到 “系统安装和升级”