[问]8.04 安装好升级后不能正常启动图形界面

系统安装、升级讨论
回复
头像
linuxier
帖子: 317
注册时间: 2008-05-27 10:45
送出感谢: 0
接收感谢: 0
联系:

[问]8.04 安装好升级后不能正常启动图形界面

#1

帖子 linuxier » 2008-08-05 15:44

我从硬盘安装好ubuntu 8.04 amd64后, 用wiki上的速配指南配置后,大多应用都可以正常使用了.但在上次给它全面升级后,系统就不能能启动图形界面了, 开机时滚动条后出现下面的东西,
loading,please wait...
kinit:name_to_dev_t(/dev/disk/by-uuid/ef80ed-bd2e-49b5-8ed9-b06001d58311)=sda(8,9)
kinit:trying to resume from /dev/disk/by-uuid/ef80ed-bd2e-49b5-8ed9-b06001d58311
kinit:no resume image,doing normal boot...
ubuntu 8.04.1 user-desktop tty1
user-desktop login:
登录后,输入startx,则出现如下信息
/etc/X11/X is not executable
giving up
xinit:No such file or directory(errno 2):unable to connect to X server
xinit:No such process(errno 3):server error.
若输入sudo apt-get -f install,有下面的信息,
正在读取软件包列表...
正在分析软件包的依赖关系树...
读取状态信息...
正在更正依赖关系... 完成
已经不需要下列自动安装的软件包:
libwxbase2.8-0 libcrypto++7 amule-common libwxgtk2.8-0 libupnp2 libgeoip1
使用 'apt-get autoremove' 来删除它们。
将会安装下列额外的软件包:
...

建议安装的软件包:
libgtk2-perl-doc libgtkhtml3.14-dbg tk8.4 samba tclreadline cscope vim-doc
推荐安装的软件包:
libpurple-bin
下列软件包将被【卸载】:
libgail-common libgail18 libperl5.8 nvidia-glx-new
下列【新】软件包将被安装:
libgnome-desktop-2-7 libperl5.10 libsilc-1.1-2 tcl8.4
下列的软件包将被升级:
...

共升级了 34 个软件包,新安装了 4 个软件包,要卸载 4 个软件包,有 777 个软件未被升级。
有 77 个软件包没有被完全安装或卸载。
需要下载 0B/25.9MB 的软件包。
操作完成后,会释放 22.9MB 的磁盘空间。
您希望继续执行吗?[Y/n]正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 121954 个文件和目录。)
正在删除 nvidia-glx-new ...
dpkg-divert: 处理 “/usr/lib32/libGL.so.1” 时发生错误:没有该文件或目录
dpkg:处理 nvidia-glx-new (--remove)时出错:
子进程 post-removal script 返回了错误号 2
在处理时有错误发生:
nvidia-glx-new
因为我装的是amd64版,没有/lib32文件夹,我也尝试建了一个指向/lib的/lib32链接,但也没用.

后来不知道怎么搞了下,变成了下面的样子
...
您希望继续执行吗?[Y/n]正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 121950 个文件和目录。)
正在删除 nvidia-glx-new ...
dpkg-divert: 处理 “/usr/lib/xorg/modules/libGLcore.so” 时发生错误:没有该文件或目录
dpkg:处理 nvidia-glx-new (--remove)时出错:
子进程 post-removal script 返回了错误号 2
在处理时有错误发生:
nvidia-glx-new
但根本没有上面的目录

请问高手,以上的问题怎么解决,谢谢!

顺便问下,如果要使怎么的系统能长期稳定地运行,有哪些个注意事项,有什么重要的东西要备份.
回复

回到 “系统安装和升级”