[问题]系统更新报错~怎么解决!!!

系统安装、升级讨论
回复
madstones
帖子: 19
注册时间: 2008-08-03 22:40
送出感谢: 0
接收感谢: 0

[问题]系统更新报错~怎么解决!!!

#1

帖子 madstones » 2008-08-05 22:27

系统更新报错~怎么解决!!!

错误!!
E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.36_i386.deb: 无法在安装新的版本前,为“./boot/ vmlinuz-2.6.24-19-generic”做一个符号链接备份
头像
jialeadmin
帖子: 724
注册时间: 2008-06-17 23:17
来自: 灾区
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 jialeadmin » 2008-08-05 22:30

终端里运行
如果你是19的内核 就用下面的 如果是20的就杷19改成20

sudo rm -fv /boot/initrd.img-2.6.24*.bak
sudo rm -fv /boot/vmlinuz-2.6.24-19-generic
sudo rm -fv /boot/initrd.img-2.6.24-19-generic
sudo rm -fv /boot/config-2.6.24-19-generic
sudo rm -fv /boot//abi-2.6.24-19-generic
sudo rm -fv /boot/System.map-2.6.24-19-generic
◆WINDOWS系统已彻底删除
◆正在安装UBUNTU 9.04
◆系统正在复制文件,请稍等...
┌────────────┐
│ ■■■■■■■□□□ 70% │
└────────────┘
madstones
帖子: 19
注册时间: 2008-08-03 22:40
送出感谢: 0
接收感谢: 0

#3

帖子 madstones » 2008-08-05 23:16

jialeadmin 写了:终端里运行
如果你是19的内核 就用下面的 如果是20的就杷19改成20

sudo rm -fv /boot/initrd.img-2.6.24*.bak
sudo rm -fv /boot/vmlinuz-2.6.24-19-generic
sudo rm -fv /boot/initrd.img-2.6.24-19-generic
sudo rm -fv /boot/config-2.6.24-19-generic
sudo rm -fv /boot//abi-2.6.24-19-generic
sudo rm -fv /boot/System.map-2.6.24-19-generic
LS 运行完成 更新后 提示:
E: linux-image-2.6.24-19-generic: 子进程 post-installation script 返回了错误号 17
回复

回到 “系统安装和升级”