当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu装在移动硬盘上后插到笔记本上启动没反应?
帖子发表于 : 2008-08-31 18:25 
头像

注册: 2006-10-10 9:40
帖子: 1122
送出感谢: 1
接收感谢: 0 次
试过一个七喜的本子和一个think的 都没反应 但笔记本插上装有puppylinux系统的u盘就可以 不知道论坛上有遇到这样情况的没有
该如何解决呢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-31 18:26 
头像

注册: 2006-09-10 22:36
帖子: 10663
地址: 北京
送出感谢: 1
接收感谢: 16
grub装哪里了?


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-31 19:03 
头像

注册: 2006-10-10 9:40
帖子: 1122
送出感谢: 1
接收感谢: 0 次
当然是移动硬盘
我觉得和主板类型可能有关系


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-31 19:21 
头像

注册: 2006-09-10 22:36
帖子: 10663
地址: 北京
送出感谢: 1
接收感谢: 16
peakgg 写道:
当然是移动硬盘
我觉得和主板类型可能有关系


那也太巧了吧?两个本子都不行?!


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-01 5:00 
头像

注册: 2008-08-23 23:05
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
你尝试在BIOS里面修改一下第一引导的顺序,把USB-HDD改为第一驱动试试看。这个问题在我的EPC上面同样存在,我用的是U盘量产出来的USB-CDROM安装的,同时我的U盘里面还有一个量产出来的USB-HDD,格式化成NTFS。我发现安装好了后默认下(不修改引导)就必须插U盘才能引导。其实还有一个可能就是安装的时候磁盘的启动顺序随着U盘拔下改变了,所以你再尝试改BIOS引导,如果还是不行并且提示引导文件丢失或者没有引导文件的话就说明你没有教案gurB装到主引导分区的MBR……这个我就暂时不知道怎么解决了……正在学习中!


_________________
自从认识GOS,从此爱上UBUNTU……


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-01 9:03 

注册: 2008-08-24 9:53
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
几个建议,呵呵,自己的理解,可以参考一下而已
1、查看问题的现象,是引导不起来还是从其他盘引导了。如果从其他盘引导了的话,首先检查你的盘是不是被正确识别,以及你的主板是否支持从USB硬盘启动,然后检查引导盘的顺序,这些都可以在BIOS的设置里面可以找到,一般在高级设置或者启动设置,确认第一启动设备(而不是启动硬盘)是你的USB硬盘。如果是引导过程中出现错误,可以描述下错误的现象或者返回信息等,高手们都可以解决。
2、确认GRUB安装到你的USB硬盘中了,我自己会考虑用VMWare做测试,插拔盘比较好控制。把整个磁盘加载进去就可以了。
3、使用其他引导工具软件比如GRUB-DOS,尝试引导或者设置是手动GRUB命令。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-01 12:16 

注册: 2008-05-03 23:42
帖子: 3681
送出感谢: 4
接收感谢: 6
stwdl 写道:
这个问题在我的EPC上面同样存在,我用的是U盘量产出来的USB-CDROM安装的,同时我的U盘里面还有一个量产出来的USB-HDD,格式化成NTFS。我发现安装好了后默认下(不修改引导)就必须插U盘才能引导。

你这个多半是把 grub 误装到 u 盘的 mbr 去了.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-09-03 21:02 
头像

注册: 2006-10-10 9:40
帖子: 1122
送出感谢: 1
接收感谢: 0 次
谢谢大家的关注
可能我没有说清楚
第一 我的移动硬盘系统在很多电脑上都是可以启动的 并不是只在某个特定的电脑上好使 说明系统本身的引导是没有错误的
第二 我的笔记本用u盘的系统是可以启动的 也就是本子的启动顺序是以usb口为先的 我查bios的设置启动顺序的第一位也是移动设备 但移动硬盘插上后却直接进本子的系统


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-09-05 20:01 
头像

注册: 2006-10-10 9:40
帖子: 1122
送出感谢: 1
接收感谢: 0 次
把移动硬盘换到本子上一切正常 应该是笔记本设置的问题 可是portable device确实是第一启动项啊


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译