当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题[已解决]]8.04换了语言后黑屏。
帖子发表于 : 2008-09-21 8:53 

注册: 2008-03-15 15:13
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
其实于语言没有关系,我是这样做的。
我在安好了显卡驱动后,立刻要装上compize,因为系统并没有安装compize。我想就是因为没有compize的问题,所以重启后就黑屏了。



这是我第4次问这个问题了,可是一直没人理我。我都觉得我可怜了, :( :(

那天看完cctv关于windows和番茄的视频后我痛下决心格掉windows,

换成Ubuntu,没想到现在电脑废了,

什么都做不了。有人愿意帮帮我么? 我再描述下我的问题:

我在惠普(显卡是集显的,nvidia 7150和nForce 630M)的机子

上安装Ubuntu8.04,每次我装好了后,装了显卡驱动,分辨率调

好了,能使用3D,换了语言,换成中文,重启后进入系统就黑屏了,有时还

是黄屏。 :( 但是此时还能使用super+e看到3D模式, :lol: 不过是2块黑屏

。问题的关键是我不能进入系统做任何事,只能在登陆的时候按F10选终端模式去做点东西。 :!:


我发现我在没换语言前怎么重启都不会有事,一旦换了语言就出

事了。与这个有关系么?我查了下,都说是显卡的原因。后来我

又在联想N440(这个机子是独显的nvidia7300)上装了哈,同样是本本。还是出

现同样问题。 :?:

能帮我找下原因么?我实在是没办法了。

刚开始我用的32位的碟安装,后来有人提醒我用64的,因为我的cpu是64位的。但是没任何乐观的变化。。


最后由 delux10 编辑于 2008-09-23 8:53,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-21 9:35 

注册: 2005-10-04 19:38
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
网上找的,我就是这么操作的,实验证明可以成功 :)

sony sz 42c是双显卡,除了intel 的集成显卡之外,还有就是我3d桌面赖以生存的nvidia geforce 7400。之前下载的驱动太久了(其实也就不到一年),于是去nvidia的官网下载了最新的www.nvidia.com

下完之后保存到/home/edison下,也是我的主目录,文件名为NVIDIA-Linux-x86_64-173.14.12-pkg2.run

根据自己的需求,安装好必备的环境~`下面就开始安装驱动了

在Ubuntu 8.04中查看显卡是否装好
运行glxinfo | grep rendering
如果显示”direct rendering: Yes”,则已安装

1、下载驱动

我下载的就是NVIDIA-Linux-x86_64-173.14.12-pkg2.run这个文件,下载后放到home目录下吧。



2、删除原驱动包
sudo apt-get –purge remove nvidia-glx nvidia-glx-new
然后删除 /lib/linux-restricted-modules/2.6.22-14-generic/文件夹下面带有nvidia字样的内容,注意里面有一个隐藏文件.nvidia-new-installer也要删掉

这里是内核自带的驱动

再检查一下这两个文件是否存在,/etc/init.d/nvidia-glx /etc/init.d/nvidia-kernel 如果存在,删除掉。

3、安装要用到的软件
sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`

安装编译包。

我在安装的时候提示说没有lib,驱动安装时候要安装Kernel Interface,如果采用自己编译的方式则要求系统中有libc的源码。我想一般人都是没有的,呵呵。这个时候我们可以在安装驱动之前先自己把这个源码给安装好,问题就解决了。如何安装?呵呵,更简单,强大的 apt install阿, 运行:
sudo apt-get install libc6-dev
一行命令搞定。

4、备份
备份文件是一个好习惯。
sudo cp /etc/default/linux-restricted-modules-common ~/linux-restricted-modules-common.backup
sudo cp /etc/X11/xorg.conf ~/xorg.conf.backup

5、禁止系统使用默认的驱动
sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号中添加nv nvidia_new,即把文件中的“”,改成“nv nvidia_new”
如果前面第二步删除完整了其实也可以不用执行这一步。

6、将后面的操作记录在纸上,因为后面会完全在终端字符界面下操作。

7、停止GDM进程
sudo /etc/init.d/gdm stop
按Ctrl+Alt+F1,登录后进入第7步。

8、安装驱动
进入下好的驱动所在目录
执行:sudo sh ./NVIDIA-Linux-x86_64-173.14.12-pkg2.run

安装过程中

如果提示有旧驱动,询问是否删除旧驱动,选Yes;
如果提示缺少某某模块(modules),询问是否上网下载,选no;
如果提示编译模块,询问是否进行编译,选ok;
如果提示将要修改Xorg.conf,询问是否允许,选Yes;

接下来就是等待安装完成。

9、安装完成就回到终端,重启GDM
sudo /etc/init.d/gdm restart

如果失败,就重启机子:sudo shutdown -r now

好了,当看到NV的logo后,才表示安装成功。

如果不想看NVIDIA的LOGO,可以修改 /etc/X11/xorg.conf
在Section “Device”中添加Option “NoLogo” “True”

如:
Section “Device”
Identifier “通用显示卡”
Driver “nvidia”
Option “NoLogo” “True”
EndSection

10.显示高级设置
如果想进行显示方面的高级设置,在终端下输入:nvidia-settings命令。

左边第二项是设置分辨率(server display configuration),从右边的resolution中选择分辨率,再点击apply,

预览一下,不好取消就行了。

至此,安装完毕。

如果御载的话就用这个命令

sh NVIDIA-Linux-x86_64-173.14.12-pkg2.run –uninstall

安装成功,就这么简单,一般nvidia 会自动配置好所有~`

重新配置x server:
sudo apt-get install pkg-config xserver-xorg-dev3
sudo dpkg-reconfigure xserver-xorg


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [问题]8.04换了语言后黑屏。
帖子发表于 : 2008-09-21 20:03 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
难道是显卡驱动的问题。。。但是一般N卡是没什么问题的,我的N卡一直很正常,和语言没有什么问题吧 :o


_________________
Ubuntu User


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [问题[已解决]]8.04换了语言后黑屏。
帖子发表于 : 2009-06-22 17:02 

注册: 2009-06-22 16:59
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的就有这个问题。我的是asus主板集成GF6100显卡。更新语言后。重启后黄屏。正在解决中。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:sogouwz 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译