未探测到磁盘驱动器--系统无法安装

系统安装、升级讨论
回复
sygb
帖子: 35
注册时间: 2006-12-20 10:59
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

未探测到磁盘驱动器--系统无法安装

#1

帖子 sygb » 2008-09-25 7:49

未探测到磁盘驱动器--系统无法安装
我下载的是ubuntu-8.04.1-alternate-amd64.iso
刻录了盘,从光盘安装,但是到了某个步骤,估计是找硬盘要分区的 时候,提示我 未探测到磁盘驱动器 。
不知道是怎么回事。
还有我还下载了 ubuntu-8.04.1-desktop-i386.iso 这个,但是安装到了分区的时候也没有让我配置分区表,根本就没有检测到硬盘的样子。

我的硬件配置是 最近配置的 。2008年9月1号左右。
CPU:英特尔® 45纳米酷睿™2 双核处理器 E7200盒装
主板:微星(MSI)P43主板
显卡:影驰 9500GT
硬盘:希捷320G 7200转16M SATAII盒装台式机硬盘
内存:金士顿DDR2 800 2G台式机内存

望高手指点
头像
thefour
帖子: 429
注册时间: 2008-03-05 12:31
来自: 示爱须唱山歌
送出感谢: 0
接收感谢: 0

Re: 未探测到磁盘驱动器--系统无法安装

#2

帖子 thefour » 2008-09-26 0:13

alternate版的是用来硬盘安装的干嘛拿来刻盘?
desktop那个是用了光盘体验功能?
六十学裁缝,晚否......
sygb
帖子: 35
注册时间: 2006-12-20 10:59
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

Re: 未探测到磁盘驱动器--系统无法安装

#3

帖子 sygb » 2008-09-26 8:19

:em25
不是这个解释的吧。只不过 安装方式是用文本方式的。还有没有 live cd 功能。

和是光盘还是硬盘没什么关系的
humanity
帖子: 106
注册时间: 2008-08-08 14:37
送出感谢: 0
接收感谢: 0

Re: 未探测到磁盘驱动器--系统无法安装

#4

帖子 humanity » 2008-09-26 8:29

Intel 4系列主板是新出的,Ubuntu对新出的硬件都可能不支持,而硬件厂商不太会为Linux编写新硬件的驱动程序,要等Ubuntu开发团队和社区为新硬件编写出驱动程序。

现在只能在BIOS菜单里试试硬盘的不同设置方式。
sygb
帖子: 35
注册时间: 2006-12-20 10:59
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

Re: 未探测到磁盘驱动器--系统无法安装

#5

帖子 sygb » 2008-09-26 8:36

通过 在光盘启动。然后按 F6 修改安装的命令行 在后面加 all_generic_idefloppy=all irqpoll
然后安装。这样是可以的 。但是安装好了,感觉速度很慢。不知道是什么原因。装好了还没声音了。还有就是 驱动的问题。我的是 9500 GT ,显示器是 三星 943nwx ,装了驱动居然无法自动识别。要自己手动设置。设置好了可以显示正常了。但是速度还是不行。打个命令要等老半天
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 未探测到磁盘驱动器--系统无法安装

#6

帖子 ptptptptptpt » 2008-09-26 11:07

又是 p43,见过好几个说 p43主板认不到硬盘的了

参考这里 viewtopic.php?f=77&t=149848

或者试试 ghost 版 ubuntu : viewtopic.php?f=103&t=145989
头像
cmodel
帖子: 15
注册时间: 2008-09-12 12:07
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

Re: 未探测到磁盘驱动器--系统无法安装

#7

帖子 cmodel » 2008-09-26 11:13

不光是 P43, 我的 AMD 780G 也不行。

估计是 硬盘 SATA2 或者 AHCI 的问题。
Learn as much as we can,
Then use, improve and optimize them !
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 未探测到磁盘驱动器--系统无法安装

#8

帖子 ptptptptptpt » 2008-09-26 11:59

可以试试 ghost 版 ubuntu : viewtopic.php?f=103&t=145989
xry2002
帖子: 9
注册时间: 2008-09-18 13:00
送出感谢: 0
接收感谢: 0

Re: 未探测到磁盘驱动器--系统无法安装

#9

帖子 xry2002 » 2008-09-28 12:00

这个问题是p43主板 sata硬盘装UBUNTU的公共问题,p43主板必须进bios设置把sata模式改为AHCI,改成AHCI下是可以安装UBUNTU的,但是在AHCI下进去windows就会蓝屏,后来查了很多资料发现原来是我安装的xp sp2 不带AHCI驱动,所以无法识别硬盘。

建议遇到同样问题的战友们先改回“IDE”模式进入windows然后安装sp3的补丁,重启后AHCI就可以识别硬盘了,进UBUNTU和xp就不用在bios里面改来该去了,或者干脆下载一个集成AHCI驱动的sp3 xp在AHCI模式下重装系统。

下面是在emule上搜索到的
windows_xp_with_sp3_vol_x86_(wmp11.ie7.dps.Intel.SATA.AHCId).iso
[资源介绍]:官方XP SP3原版整合wmp11.ie7,dps包,整合Intel SATA AHCI驱动,解决了硬盘开启AHCI模式后无法找到硬盘的问题

终极解决办法:安装AHCI-NCQ驱动 具体可以参照http://itbbs.pconline.com.cn/diy/8761344.html

楼主的显卡9500GT估计在UBUNTU下安装驱动也会遇到问题,我的是9600GT现在正在折腾...
月满西楼
帖子: 31
注册时间: 2007-02-13 18:52
送出感谢: 0
接收感谢: 0
联系:

Re: 未探测到磁盘驱动器--系统无法安装

#10

帖子 月满西楼 » 2008-09-29 21:10

楼上9500GT是不是会花屏???
xry2002
帖子: 9
注册时间: 2008-09-18 13:00
送出感谢: 0
接收感谢: 0

Re: 未探测到磁盘驱动器--系统无法安装

#11

帖子 xry2002 » 2008-09-29 22:27

我的是9600GT现在安装好了177.78的驱动,一切正常。
回复

回到 “系统安装和升级”