当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-10-22 13:26 
头像

注册: 2008-08-21 17:15
帖子: 112
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
我用的是64位8.04ubuntu,本来安装的flash 9一直能正常播放flash. 近来听说出了flash 10,就试着安装。
从adobe官方那下载了deb包,双击安装提示是i386的,就用
代码:
 sudo dpkg --force-architecture -i install_flash_player_10_linux.deb
这个命令强制安装了flash10,安装前有警告此软件与本系统的架构不合,结果无警报.但打开土豆网页还是提示安张flash插件.单击提示,插件搜索的结果如图
附件:
文件注释: 单击下载插件包的提示.
screenshot3.png
screenshot3.png [ 14.33 KiB | 被浏览 2306 次 ]


点手动安装,在新页面里找到了adobe flash,于是点链接却回到了我下载deb包的地方,绕了个大圈,怎么回事?

也用了下面的方法,只是把falsh9换成10.但还是不行.firefox依旧提示下载插件.
代码:
2。 网页不能显示flash问题
按以下方法操作就能解决:
sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2
sudo apt-get install nspluginwrapper gsfonts-x11 (如不能下载,请到::URL::http://www.janvitus.netsons.org/repository/找)
下载两个rpm包:
::URL::http://gwenole.beauchesne.info/proje...2-1.x86_64.rpm
::URL::http://gwenole.beauchesne.info/proje...2-1.x86_64.rpm

sudo apt-get install alien (安装rpm—>deb工具alien)
sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
sudo alien nspluginwrapper-i386-0.9.91.2-1.x86_64.rpm

sudo dpkg -i nspluginwrapper-0.9.91.2-1.x86_64.deb
sudo dpkg -i nspluginwrapper-i386-0.9.91.2-1.x86_64.deb

然后到adobe主页下载flash9播放器:::URL::http://fpdownload.macromedia.com/get...9_linux.tar.gz
把它解压后,把里面的libflashplayer.so,复制到/usr/lib/mozilla/plugins或/usr/lib/swiftfox/plugins
nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
安装完成!这样打开网页就可以看到flash了


最后一步输入
代码:
nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
后,结果提示:
引用:
*** NSPlugin Viewer *** ERROR: libnss3.so: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/mozilla/plugins/libflashplayer.so

提示无libflashplayer.so文件,可查看了一下,该文件确实在 /usr/lib/mozilla/plugins/里面阿.


_________________
图片


最后由 rroamor 编辑于 2008-10-22 13:46,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-10-22 13:30 
头像

注册: 2008-08-21 17:15
帖子: 112
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
好像发错了地方,怎么移动到其他区? 只能重新发帖?


_________________
图片


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-10-22 13:35 

注册: 2006-12-20 2:06
帖子: 304
送出感谢: 0 次
接收感谢: 0 次
要nspluginwrapper 1.1.2才支持flash 10的吧


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-10-22 13:49 
头像

注册: 2008-08-21 17:15
帖子: 112
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
meto 写道:
要nspluginwrapper 1.1.2才支持flash 10的吧

:ema8 哦,原来这样,我去试试.谢谢.


_________________
图片


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-10-22 14:31 
头像

注册: 2008-08-21 17:15
帖子: 112
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
:em18 受不了了,下了个nspluginwrapper 1.1.2,结果只有tar.bz2包,要自己编译,缺很多编译环境,搞不定.上次已经弄到夜里2点,下次再弄.


_________________
图片


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-10-23 1:05 

注册: 2007-07-06 0:11
帖子: 413
送出感谢: 0 次
接收感谢: 0 次
给你这个东东
#!/bin/bash
# Script created by
# Romeo-Adrian Cioaba romeo.cioaba@spotonearth.com
# Super minor updates by jason.melton[at]gmail[dot]com
# Updates by Alejandro Cuervo 3[at]cuervo[dot]net
# Released under GPL

echo "Closing Firefox"
sudo killall -9 firefox

echo "Downloading and instaling Getlibs for required libraries"
wget http://www.boundlesssupremacy.com/Cappy ... bs-all.deb
sudo dpkg -i getlibs-all.deb

echo "Removing previous installs of flash:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper

echo "Installing ia32-libs and nspluginwrapper"
sudo apt-get install ia32-libs nspluginwrapper

echo "Getting libs"
sudo getlibs -p libcurl3
sudo getlibs -p libnss3-1d
sudo getlibs -p libnspr4-0d

echo "Installing Flash Player 10"
cd ~
wget http://fpdownload.macromedia.com/get/fl ... nux.tar.gz
tar zxvf install_flash_player_10_linux.tar.gz
sudo cp install_flash_player_10_linux/libflashplayer.so /usr/lib/mozilla/plugins/
rm -rf ~/install_flash_player_10_linux/
sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

echo "Linking the libraries so that firefox can see them."
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/firefox-addons/plugins/

echo "Done :-)"
echo "You may re-start Firefox now"


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助:flash 10怎么也安装不起来。。。
帖子发表于 : 2008-11-01 0:05 
头像

注册: 2008-08-21 17:15
帖子: 112
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
还是不成。不管是一条条输入命令,还是全部粘贴都不行。下面是输入后的结果:

tabacco@tabacco-laptop:~$ echo "You may re-start Firefox now"
You may re-start Firefox now
tabacco@tabacco-laptop:~$ echo "Closing Firefox"
Closing Firefox
tabacco@tabacco-laptop:~$ sudo killall -9 firefox
tabacco@tabacco-laptop:~$
tabacco@tabacco-laptop:~$ echo "Downloading and instaling Getlibs for required libraries"
Downloading and instaling Getlibs for required libraries
tabacco@tabacco-laptop:~$ wget http://www.boundlesssupremacy.com/Cappy ... bs-all.deb
--23:59:06-- http://www.boundlesssupremacy.com/Cappy
=> `Cappy'
正在解析主机 www.boundlesssupremacy.com... 209.123.149.151
正在连接 www.boundlesssupremacy.com|209.123.149.151|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 301 Moved Permanently
位置:http://www.boundlesssupremacy.com/Cappy/ [跟随至新的 URL]
--23:59:07-- http://www.boundlesssupremacy.com/Cappy/
=> `index.html.7'
正在连接 www.boundlesssupremacy.com|209.123.149.151|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度: 未指定 [text/html]

[ <=> ] 1,491 --.--K/s

23:59:07 (87.33 MB/s) - `index.html.7' 被保存 [1491]

--23:59:07-- http://.../
=> `index.html.8'
正在解析主机 ...... 失败:未知的名字或服务。
--23:59:07-- http://bs-all.deb/
=> `index.html.8'
正在解析主机 bs-all.deb... 60.191.124.236
正在连接 bs-all.deb|60.191.124.236|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度: 873 [text/html]

100%[====================================>] 873 --.--K/s

23:59:07 (39.71 MB/s) - `index.html.8' 已经保存 [873/873]


下载完毕 --23:59:07--
下载了:2,364 字节,共 2 个文件
tabacco@tabacco-laptop:~$ sudo dpkg -i getlibs-all.deb
dpkg:处理 getlibs-all.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
在处理时有错误发生:
getlibs-all.deb
tabacco@tabacco-laptop:~$
tabacco@tabacco-laptop:~$ echo "Removing previous installs of flash:"
Removing previous installs of flash:
tabacco@tabacco-laptop:~$ sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
软件包 flashplugin-nonfree 还未安装,因而不会被卸载
软件包 gnash 还未安装,因而不会被卸载
软件包 gnash-common 还未安装,因而不会被卸载
软件包 mozilla-plugin-gnash 还未安装,因而不会被卸载
软件包 swfdec-mozilla 还未安装,因而不会被卸载
软件包 libflashsupport 还未安装,因而不会被卸载
软件包 nspluginwrapper 还未安装,因而不会被卸载
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
tabacco@tabacco-laptop:~$ sudo rm -f /usr/lib/mozilla/plugins/*flash*
tabacco@tabacco-laptop:~$ sudo rm -f ~/.mozilla/plugins/*flash*
tabacco@tabacco-laptop:~$ sudo rm -f /usr/lib/firefox/plugins/*flash*
tabacco@tabacco-laptop:~$ sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
tabacco@tabacco-laptop:~$ sudo rm -rfd /usr/lib/nspluginwrapper
tabacco@tabacco-laptop:~$
tabacco@tabacco-laptop:~$ echo "Installing ia32-libs and nspluginwrapper"
Installing ia32-libs and nspluginwrapper
tabacco@tabacco-laptop:~$ sudo apt-get install ia32-libs nspluginwrapper
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
ia32-libs 已经是最新的版本了。
下列【新】软件包将被安装:
nspluginwrapper
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/113kB 的软件包。
操作完成后,会消耗掉 381kB 的额外磁盘空间。
(正在读取数据库 ... 系统当前总共安装有 117911 个文件和目录。)
正在解压缩 nspluginwrapper (从 .../nspluginwrapper_0.9.91.5-2ubuntu2_amd64.deb) ...
dpkg:处理 /var/cache/apt/archives/nspluginwrapper_0.9.91.5-2ubuntu2_amd64.deb (--unpack)时出错:
正试图覆盖“/usr/lib/nspluginwrapper/i386/linux/npviewer.bin”,它属于软件包 nspluginwrapper-i386
在处理时有错误发生:
/var/cache/apt/archives/nspluginwrapper_0.9.91.5-2ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
tabacco@tabacco-laptop:~$


_________________
图片


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译