当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 8.04升级8.10之旅(搞定低分辨率)
帖子发表于 : 2008-10-22 19:46 
头像

注册: 2008-10-16 20:18
帖子: 21
地址: 四川
送出感谢: 0 次
接收感谢: 0 次
机器:惠普V3239AU 显卡是6150
参照论坛上的帖子开始升级 升级过程中提示某个字体文件的错(其实就是解决网页中FLASH乱码那个文件),没管他 继续 ,中途有几次提示配置文件不同 询问如何处理 全部替换了 有几次英文提示好像是是否保持本地版本的 我默认的 没管他。完成后重启 ,问题就来了。
首先是引导菜单并没有新升级的内核(2.6.27-7) 不管它 继续启动 然后进入了低分辨率桌面 心想肯定显卡驱动需要重装。在应用程序-> 系统工具中寻找俺曾经装的envyng 居然没有菜单 在硬件驱动里提示安装177版的驱动 选了激活 满心欢喜得等待重启后 结果发现还是白忙活。于是进终端里启动envyng 接着按照提示安装驱动 提示出错 。 然后上NV官网下载177版驱动 关闭GTK 安装驱动 还是出错。 这下傻眼了 上论坛 找其他有类似经历的 在反复近10次开关机电脑后。俺终于大测大悟了。原来是俺的内核版本原因 。

解决过程:
首先 确认你启动的内核版本 我装有Sysinfo 所以就不终端了 看到了我启动的内核版本是2.6.24-21 而8.10的内核版本应该是2.6.27-7
接下来先看看2.6.27-7的内核是否安装
代码:
dpkg --get-selections|grep linux

看到只要有2.6.27-7后面的状态是install那就OK了
下一步修改引导菜单
代码:
sudo gedit /boot/grub/menu.lst

将其中的2.6.24-21修改为2.6.27-7 然后保存
重新启动电脑 系统还是工作在低分辨率下
打开 系统->系统管理->软件源 将下载自里面的 中国的服务器 更改为主服务器
然后关闭
执行
代码:
sudo apt-get update

完成后系统会提示有新的更新可用 选上所有更新 安装 由于是主服务器 所以网速偏慢 更新安装完成以后重新启动电脑。
接着在NV官方下载for LINUX的驱动到本地 然后关闭GTK:
代码:
sudo /etc/init.d/gdm stop

进入驱动所在目录安装驱动
代码:
sudo sh NVIDIA-Linux-x86-177.80-pkg1.run

安装完成以后
代码:
sudo reboot

最后 久违的1280*800回来啦 哈哈 狂喜 继续打开扩展效果 这里就略过了

希望有类似经历的朋友可以参考下


_________________
可以上XXX站点的加密连接代理


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 8.04升级8.10之旅(搞定低分辨率)
帖子发表于 : 2008-10-27 1:08 

注册: 2008-10-26 16:13
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
libselinux1 install
linux-generic install
linux-headers-2.6.24-19 install
linux-headers-2.6.24-19-generic install
linux-headers-generic install
linux-image-2.6.24-19-generic install
linux-image-generic install
linux-restricted-modules-2.6.24-19-generic install
linux-restricted-modules-common install
linux-restricted-modules-generic install
linux-sound-base install
linux-ubuntu-modules-2.6.24-19-generic install
util-linux install
util-linux-locales install


我这个是不是内核没有升级啊?
我也是自动升级以后分辨率降了,真郁闷阿!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译