新安装后Grub里没有了以前的U和XP项了

系统安装、升级讨论
回复
头像
momova
帖子: 3382
注册时间: 2007-07-11 21:43
系统: archlinux
来自: 东江边
送出感谢: 15 次
接收感谢: 7 次

新安装后Grub里没有了以前的U和XP项了

#1

帖子 momova » 2008-11-03 10:26

原本系统里有个XP和从8.04升级来的8.10,因升级来的8.10启动速度非常慢,而且还是个I386的,想想新装个64位的,所以就新安装到了SDA7了,安装成功后,重启才发现,只能引导到SDA8的升级来的8.10了。
现在我要怎么才能把XP和新安装进来的系统给加进引导菜单去呢?
我来了,我看见了,我征服了!
求勾搭,不管饭。
yuancongwei
帖子: 282
注册时间: 2007-11-18 15:52
来自: 江苏盛泽医院普外科
送出感谢: 0
接收感谢: 0

Re: 新安装后Grub里没有了以前的U和XP项了

#2

帖子 yuancongwei » 2008-11-03 10:39

到804的boot里找到menu.lst 把里面的启动项目复制出来贴到810的boot里面的menu.lst里面 这个是土办法……
liaaxiaa
帖子: 14
注册时间: 2008-05-02 15:42
送出感谢: 0
接收感谢: 0

Re: 新安装后Grub里没有了以前的U和XP项了

#3

帖子 liaaxiaa » 2008-11-03 10:41

在/boot/grub/menu.lst里添加:
title find and load NTLDR of Windows XP
fallback 1
find --set-root /ntldr
chainloader /ntldr
savedefault --wait=2
就能找到xp了
头像
momova
帖子: 3382
注册时间: 2007-07-11 21:43
系统: archlinux
来自: 东江边
送出感谢: 15 次
接收感谢: 7 次

Re: 新安装后Grub里没有了以前的U和XP项了

#4

帖子 momova » 2008-11-03 11:13

谢谢楼上两位。


我现在找到SDA7的UUID,然后把把menu.lst修改了一下:
#sda7 ubuntu
title Ubuntu 8.10, kernel 2.6.27-7-generic (on /dev/sda7)
root (hd0,6)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=e1650e1e-77a5-4325-86c1-71270f5fcd24 ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
savedefault
boot

(但是我在/BOOT下没有发现vmlinuz-2.6.27-7-generic,难道AMD64的不一样吗?/boot下面有abi-2.6.27-7-generic,config-2.6.27-7-generic,System.map-2.6.27-7-generic,vmcoreinfo-2.6.27-7-generic这样几个文件,哪个是呢:
# linux installation on /dev/sda7.
title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode) (on /dev/sda7)
root (hd0,6)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=e1650e1e-77a5-4325-86c1-71270f5fcd24 ro single
initrd /boot/initrd.img-2.6.27-7-generic
savedefault
boot



# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda8.
title Ubuntu 8.10, kernel 2.6.27-7-generic (on /dev/sda8)
root (hd0,7)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=9db6daa9-9f67-4daf-a67c-3b7893001840 ro quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda8.
title Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode) (on /dev/sda8)
root (hd0,7)
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=9db6daa9-9f67-4daf-a67c-3b7893001840 ro single
initrd /boot/initrd.img-2.6.27-7-generic
savedefault
boot


# This entry automatically added by the Debian installer for an existing
# linux installation on /dev/sda8.
title Ubuntu 8.10, memtest86+ (on /dev/sda8)
root (hd0,7)
kernel /boot/memtest86+.bin
savedefault
boot


# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Windows NT/2000/XP (loader)
root (hd0,0)
savedefault
makeactive
chainloader +1
我来了,我看见了,我征服了!
求勾搭,不管饭。
头像
momova
帖子: 3382
注册时间: 2007-07-11 21:43
系统: archlinux
来自: 东江边
送出感谢: 15 次
接收感谢: 7 次

Re: 新安装后Grub里没有了以前的U和XP项了

#5

帖子 momova » 2008-11-03 12:18

复制了一个kernel 2.6.27-7-generic 到/boot下,谁知道启动的时候出现了request-module:runaway loop modprobe binfmt-464c的字样后停止在那不动了。
我来了,我看见了,我征服了!
求勾搭,不管饭。
grdxyxy
帖子: 229
注册时间: 2007-07-14 22:39
送出感谢: 0
接收感谢: 0

Re: 新安装后Grub里没有了以前的U和XP项了

#6

帖子 grdxyxy » 2008-11-03 12:32

复制菜单啊,谁叫你复制kernel了?
头像
momova
帖子: 3382
注册时间: 2007-07-11 21:43
系统: archlinux
来自: 东江边
送出感谢: 15 次
接收感谢: 7 次

Re: 新安装后Grub里没有了以前的U和XP项了

#7

帖子 momova » 2008-11-03 13:29

grdxyxy 写了:复制菜单啊,谁叫你复制kernel了?
菜单不用复制,我已经把里面的东西改了。
很明显的是把原U里面的菜单内容复制过来并不适用,而且在/boot下并没有kernel 2.6.27-7-generic ,复制过来也会出现file not found!!
我来了,我看见了,我征服了!
求勾搭,不管饭。
1234qw
帖子: 389
注册时间: 2007-12-31 11:40
送出感谢: 0
接收感谢: 0

Re: 新安装后Grub里没有了以前的U和XP项了

#8

帖子 1234qw » 2008-11-03 14:14

用新装的引导其他的
头像
momova
帖子: 3382
注册时间: 2007-07-11 21:43
系统: archlinux
来自: 东江边
送出感谢: 15 次
接收感谢: 7 次

Re: 新安装后Grub里没有了以前的U和XP项了

#9

帖子 momova » 2008-11-04 7:41

其它的一切都榀以引导了,就是引导不了新安装的AMD64位的。
我来了,我看见了,我征服了!
求勾搭,不管饭。
1234qw
帖子: 389
注册时间: 2007-12-31 11:40
送出感谢: 0
接收感谢: 0

Re: 新安装后Grub里没有了以前的U和XP项了

#10

帖子 1234qw » 2008-11-04 9:51

sudo grub
grub>root (hd0,6)
grub>setup (hd0)
liaaxiaa
帖子: 14
注册时间: 2008-05-02 15:42
送出感谢: 0
接收感谢: 0

Re: 新安装后Grub里没有了以前的U和XP项了

#11

帖子 liaaxiaa » 2008-11-04 11:55

momova 写了:原本系统里有个XP和从8.04升级来的8.10,因升级来的8.10启动速度非常慢,而且还是个I386的,想想新装个64位的,所以就新安装到了SDA7了,安装成功后,重启才发现,只能引导到SDA8的升级来的8.10了。
现在我要怎么才能把XP和新安装进来的系统给加进引导菜单去呢?
要重装8.10,你在安装启动程序是不是默认在hd0上.
头像
momova
帖子: 3382
注册时间: 2007-07-11 21:43
系统: archlinux
来自: 东江边
送出感谢: 15 次
接收感谢: 7 次

Re: 新安装后Grub里没有了以前的U和XP项了

#12

帖子 momova » 2008-11-04 22:21

所有的问题都不在这。我想,我已经找到了方法,晚点去试试。
我来了,我看见了,我征服了!
求勾搭,不管饭。
回复

回到 “系统安装和升级”