[求助]安装完Ubuntu后黑屏!

系统安装、升级讨论
回复
marco_hwt
帖子: 8
注册时间: 2007-10-25 8:15
送出感谢: 0
接收感谢: 0

[求助]安装完Ubuntu后黑屏!

#1

帖子 marco_hwt » 2008-11-03 10:33

用alternative CD安装ubuntu 8.10后,说找不到显卡,黑屏进不了图形界面。我的显卡是集成的ProSavage DDR,以前安装ubuntu 7.10都没有问题,LiveCD同样也是启动不了。在网上找了很久都没有这个显卡的驱动,请问是不是用不了ubuntu了?
上次由 marco_hwt 在 2008-11-03 10:36,总共编辑 1 次。
头像
ggghai
帖子: 247
注册时间: 2008-09-07 22:50
送出感谢: 0
接收感谢: 0

Re: 安装完Ubuntu后黑屏!

#2

帖子 ggghai » 2008-11-03 10:36

选recovery mode模式进入试试看
头像
john.wu
帖子: 1006
注册时间: 2007-10-18 17:40
送出感谢: 0
接收感谢: 0

Re: [求助]安装完Ubuntu后黑屏!

#3

帖子 john.wu » 2008-11-03 10:43


千帖户,享有论坛特权!
marco_hwt
帖子: 8
注册时间: 2007-10-25 8:15
送出感谢: 0
接收感谢: 0

Re: [求助]安装完Ubuntu后黑屏!

#4

帖子 marco_hwt » 2008-11-03 10:59

显示的错误是:
(EE)SAVAGE(0): No vaid modes foumd.
(EE)Screen(s) found,but none have a usable configuartion
头像
ggghai
帖子: 247
注册时间: 2008-09-07 22:50
送出感谢: 0
接收感谢: 0

Re: [求助]安装完Ubuntu后黑屏!

#5

帖子 ggghai » 2008-11-03 11:04

重新配置X。运行 X --config
(可能是这个参数,运行前先执行 man X或X --help看一下)
marco_hwt
帖子: 8
注册时间: 2007-10-25 8:15
送出感谢: 0
接收感谢: 0

Re: [求助]安装完Ubuntu后黑屏!

#6

帖子 marco_hwt » 2008-11-03 16:04

还是不行。是不是Ubuntu不支持我的这个显卡了
tttomato
帖子: 85
注册时间: 2008-05-27 12:55
送出感谢: 0
接收感谢: 1 次

Re: [求助]安装完Ubuntu后黑屏!

#7

帖子 tttomato » 2008-11-03 16:58

修改menu.lst,增加一条启动选项,并在后面加上ro quiet xforcevesa,比如:

代码: 全选

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic (xforcevesa)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=806b4557-a71e-40ce-a67c-38113ca26209 ro quiet xforcevesa
initrd		/boot/initrd.img-2.6.24-21-generic
quiet
这是安全图形模式,能进系统的话自己设置一下Screens and Graphs(中文忘了)

代码: 全选

alt+F2

代码: 全选

gksu displayconfig-gtk
marco_hwt
帖子: 8
注册时间: 2007-10-25 8:15
送出感谢: 0
接收感谢: 0

Re: [求助]安装完Ubuntu后黑屏!

#8

帖子 marco_hwt » 2008-11-04 8:08

我在xorg.conf中加入Driver "vesa"后,系统就能以低分辨率进入图形界面,但是改为Driver "savage"后就进不了系统了。上ubuntu的网站下了savage的驱动deb包,发现系统里已经安装好了,重新安装驱动一次还是不行,很怀疑是不是ubuntu的驱动有问题。
marco_hwt
帖子: 8
注册时间: 2007-10-25 8:15
送出感谢: 0
接收感谢: 0

Re: [求助]安装完Ubuntu后黑屏!

#9

帖子 marco_hwt » 2008-11-04 17:10

我这个问题终于勉强解决了。xorg.conf里面要为Driver "vesa",如果是savage的就不行,然后参考一下显示器的刷新率设置,加到xorg.conf里面,下面是我修改后的配置,可以上1024-768@85HZ
Section "Device"
Identifier "Configured Video Device"
VendorName "S3 Inc."
Boardname "S3 Grphic ProSavageDDR Video Card"
Driver "savage"
Option "DPMS"

EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Generic"
ModelName "1024x768 @ 85 Hz"
HorizSync 30-71
VertRefresh 50-160


EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 32
Modes "1024x768" "832x624" "800x600" "640x480"
EndSubsection
EndSection
回复

回到 “系统安装和升级”