更新出现问题,求助啊。。

系统安装、升级讨论
回复
小志
帖子: 43
注册时间: 2006-10-18 10:31
送出感谢: 0
接收感谢: 0
联系:

更新出现问题,求助啊。。

#1

帖子 小志 » 2008-11-08 17:49

在更新管理员里更新的时候突然死机,重启后更新时就出现:
sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在筹划升级... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 system-tools-backends (2.6.0-1ubuntu1.1) ...
* Starting System Tools Backends system-tools-backends invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg:处理 system-tools-backends (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
正在设置 system-tools-backends (2.6.0-1ubuntu1.1) ...
* Starting System Tools Backends system-tools-backends invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg:处理 system-tools-backends (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
system-tools-backends
E: Sub-process /usr/bin/dpkg returned an error code (1)

请问如何解决啊??谢谢。。
小志
帖子: 43
注册时间: 2006-10-18 10:31
送出感谢: 0
接收感谢: 0
联系:

Re: 更新出现问题,求助啊。。

#2

帖子 小志 » 2008-11-09 9:41

:em20 :em20 没人帮忙?
huangshaoer
帖子: 140
注册时间: 2008-08-31 23:29
来自: 广西百色田林
送出感谢: 0
接收感谢: 0
联系:

Re: 更新出现问题,求助啊。。

#3

帖子 huangshaoer » 2008-11-09 10:45

我用8.10 AMD64的没有什么问题,可是由于64位的应用软件太少了,连QQ呀,FLASH播放器都不支持,只支持32位的。所以网上看电影什么的都不行。所以现在换了32位的,可是更新也出现了问题,不知道怎么解决了。
E: 安装源配置文件“/etc/apt/sources.list”第 9 行有错误 (URI parse)
E: 无法锁定列表目录

E: 安装源配置文件“/etc/apt/sources.list”第 9 行有错误 (URI parse)
E: 无法读取源列表。
请转到软件库对话框以解决该问题。
E: _cache->open() failed, please report.
附件
05.png
小志
帖子: 43
注册时间: 2006-10-18 10:31
送出感谢: 0
接收感谢: 0
联系:

Re: 更新出现问题,求助啊。。

#4

帖子 小志 » 2008-11-13 22:40

唉。。。怎么没人帮忙啊。。。
fskr_sb
帖子: 177
注册时间: 2008-01-20 21:39
送出感谢: 0
接收感谢: 0

Re: 更新出现问题,求助啊。。

#5

帖子 fskr_sb » 2008-11-18 22:11

我的也是这个问题。。。。。
搞不定。。。。。
feiy
帖子: 108
注册时间: 2006-03-27 17:16
送出感谢: 0
接收感谢: 0

Re: 更新出现问题,求助啊。。

#6

帖子 feiy » 2008-11-24 8:34

1) sudo invoke-rc.d system-tools-backends stop
2) sudo dpkg --configure -a
tony988
帖子: 102
注册时间: 2006-04-16 15:48
送出感谢: 1 次
接收感谢: 0

Re: 更新出现问题,求助啊。。

#7

帖子 tony988 » 2008-11-25 23:19


嗯,6楼的方法正确,不再报错了,谢谢。

zzy011
帖子: 19
注册时间: 2008-10-05 12:03
送出感谢: 0
接收感谢: 0

Re: 更新出现问题,求助啊。。

#8

帖子 zzy011 » 2009-01-23 16:08

谢谢啦~~~
xyq164288
帖子: 79
注册时间: 2009-01-25 15:13
送出感谢: 2 次
接收感谢: 1 次

Re: 更新出现问题,求助啊。。

#9

帖子 xyq164288 » 2009-01-25 15:16

6楼什么意思可以解释一下么?很感谢了~
回复

回到 “系统安装和升级”