当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 在ubuntu7.04升级到7.10时候,遇到问题
帖子发表于 : 2008-11-22 1:13 

注册: 2008-11-21 20:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我是ubuntu7.04,打算升级到7.10,然后再打算升级到8.04LTS。
我在gnome图形界面下选择升级管理器,下载文件,提示有1058个文件,下载了20多个小时,到最后第1056个文件的时候,始终下载不下来了,最后提示:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb 大小不符
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb 大小不符
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... .1_all.deb 大小不符
反复尝试了几次,都是这个结果。
后来我就自己去手工下载了这三个文件,然后把他们放到/var/cache/apt/archives目录下,然后再进行升级管理器,结果还是一模一样,它还是试着去下载这三个文件,结果还是失败。
不知哪位有没有碰到这样的问题?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 在ubuntu7.04升级到7.10时候,遇到问题
帖子发表于 : 2008-11-22 2:10 

注册: 2007-02-06 16:21
帖子: 419
送出感谢: 0 次
接收感谢: 0 次
换个源试试


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 在ubuntu7.04升级到7.10时候,遇到问题
帖子发表于 : 2008-11-22 10:13 

注册: 2008-11-21 20:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
换了源也还是不行。
我查了一下,好像这是ubuntu的一个bug,难道到现在还没有解决这个bug?
那我现在就不知道还有什么办法升级了。
bug:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... .1_all.deb Size mismatch
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb Size mismatch
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb Size mismatch


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 在ubuntu7.04升级到7.10时候,遇到问题
帖子发表于 : 2008-11-22 11:13 

注册: 2008-11-21 20:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
问题解决了。
我不通过gnome图形界面升级了,因为我已经手工下载了这三个deb文件,我就直接在终端执行
$sudo apt-get upgrade
这样就可以了,最后电脑重启,发现已经升级到了7.10版本。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 在ubuntu7.04升级到7.10时候,遇到问题
帖子发表于 : 2008-11-22 11:21 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
ccontrol 写道:
换了源也还是不行。
我查了一下,好像这是ubuntu的一个bug,难道到现在还没有解决这个bug?
那我现在就不知道还有什么办法升级了。
bug:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... .1_all.deb Size mismatch
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb Size mismatch
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb Size mismatch


这应该不是 bug,ubuntu官方已经声明7.04的支持在2008年10月19日结束,此后许多官方源会把7.04相关的包清除掉,所以你缺包应该是正常的。在planet ubuntu上面都有相关的新闻报导。

我赶在 2008年10月17日升级7.04到7.10,一切正常。至于你的问题我估计主动先删除 hplip 相关的包就会好的。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 在ubuntu7.04升级到7.10时候,遇到问题
帖子发表于 : 2008-11-22 12:15 

注册: 2008-11-21 20:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
ccontrol 写道:
问题解决了。
我不通过gnome图形界面升级了,因为我已经手工下载了这三个deb文件,我就直接在终端执行
$sudo apt-get upgrade
这样就可以了,最后电脑重启,发现已经升级到了7.10版本。


执行upgrade升级还有很多库和相关包没有升级,我又执行dist-upgrade,结果还是报告刚才那个错误:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... .1_all.deb Size mismatch
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb Size mismatch
Failed to fetch http://security.ubuntu.com/ubuntu/pool/ ... 1_i386.deb Size mismatch
接着我就执行:
$sudo apt-get upgrade --fix-missing
这样就完全ok了,大概经过30多分钟,升级完成。
重启后,桌面也更新了,查看system-关于ubuntu,也显示正常了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider], sogouwz 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译