vista xp 双系统安装ubuntu后xp不能启动的解决经历

系统安装、升级讨论
回复
loyalguy
帖子: 2
注册时间: 2008-11-27 16:43
送出感谢: 0
接收感谢: 0

vista xp 双系统安装ubuntu后xp不能启动的解决经历

#1

帖子 loyalguy » 2008-12-04 10:59

装ubuntu之前硬盘分区为c,d,e,f。其中c为vista系统,d,e为资料,f安装xp系统。由于vista为机器自带系统。因此双系统为在vista下安装xp。为装ubunt,将e盘删除。用ubuntu desktop 8.10安装了ubuntu系统。将原来的e盘分了/,swap,/boot, /home等四个区。系统安装顺利。多系统引导为ubuntu引导vista,vista再引导xp。不幸的是xp已经不能启动。显示为hal.dll丢失。进vista后查看xp盘中hal.dll竟然存在。

上网看了许多帖子,基本认为应该重新拷贝hal.dll文件,但我的文件并没有丢失。有人认为是硬盘分区发生了变化,改动boot.ini文件就能解决问题。我便采用了这个方法。在vista的磁盘管理中查看,原来的e盘被分成了四个区,那么,装xp系统的盘应该变成了硬盘的第7个分区,因此,将boot.ini中的
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(4)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
改成了
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(7)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(7)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
怀着激动的心情重启

失败,还是提示hal.dll丢失。我郁闷! :em20
后来又考虑是不是应该按照linux的分区来设置。试了很多数字都不行。
昨晚想了想,也行windows不识别linux的分区呢。那么xp盘的分区位置岂不是提前了,于是就改成了
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
没想到今天竟奇迹般地启动了。至于具体什么原因,真是不得而知了。

由此,我得出一个教训,以后再装linux,最好装在硬盘的最后分区,那么估计就不会有如此的问题了。
个中缘由,期待高手解决。
头像
drc1234
帖子: 630
注册时间: 2008-08-31 10:09
送出感谢: 3 次
接收感谢: 1 次

Re: vista xp 双系统安装ubuntu后xp不能启动的解决经历

#2

帖子 drc1234 » 2008-12-04 11:06

windows不识别linux的分区呢。那么xp盘的分区位置岂不是提前了,这分析是正确的.E盘不存在了,F盘就变成第3分区了
loyalguy
帖子: 2
注册时间: 2008-11-27 16:43
送出感谢: 0
接收感谢: 0

Re: vista xp 双系统安装ubuntu后xp不能启动的解决经历

#3

帖子 loyalguy » 2008-12-04 16:49

貌似如此 :em11
回复

回到 “系统安装和升级”