当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装软件发生的系统依赖关系问题!在线等。
帖子发表于 : 2008-12-06 13:21 

注册: 2007-08-18 6:00
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
代码:
fan@fan-desktop:~$ sudo apt-get install mplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  mplayer: 依赖: libasound2 (> 1.0.17) 但是 1.0.15-3ubuntu4 正要被安装
           依赖: libgtk2.0-0 (>= 2.14.1) 但是 2.12.9-3ubuntu5 正要被安装
           依赖: libjack0 (>= 0.109.2) 但是它将不会被安装
           依赖: libmad0 (>= 0.15.1b-3) 但是它将不会被安装
           依赖: libpango1.0-0 (>= 1.21.6) 但是 1.20.5-0ubuntu1 正要被安装
           依赖: libspeex1 (>= 1.2~beta3-1) 但是 1.1.12-3ubuntu0.8.04.1 正要被安装
E: 无法安装的软件包


sudo apt-get install - f:

代码:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
读取状态信息... 完成             
已经不需要下列自动安装的软件包:
  linux-headers-2.6.24-19-generic linux-headers-2.6.24-19
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 11 个软件未被升级。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装软件发生的系统依赖关系问题!在线等。
帖子发表于 : 2008-12-06 13:22 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
把你的 /etc/apt/sources.list 贴出来


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装软件发生的系统依赖关系问题!在线等。
帖子发表于 : 2008-12-09 1:11 

注册: 2007-08-18 6:00
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
换了源就好了,谢谢楼上的。
不好意思,忘记回贴。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译