当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu8.10安装不了build-essential
帖子发表于 : 2008-12-08 10:11 

注册: 2008-12-06 23:21
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
ubuntu8.10安装不了build-essential:我是把文件下到windowsXP里再cp到ubuntu8.10里的 (我的ubuntu8.10上不了网,要用Dr.COM上网的) \\ 所有相关的软件包我都下了………………
如下:
其它与 build-essential 有关的软件包

* 依赖 * 推荐 * 建议

* dep: dpkg-dev (>= 1.13.5) Debian package development tools
* dep: g++ (>= 4:4.3.1) GNU C++ 编译器
* dep: libc6-dev GNU C Library: Development Libraries and Header Files 或者libc- 本虚包由这些包填实: libc6-dev
* dep: make "make"工具的GNU版本



上面的只有dep:g++ (>= 4:4.3.1)不能装!!说要g++-4.3 (>= 4.3.1-1),于是我下了如下的软件包::

其它与 g++ 有关的软件包


* dep: cpp (>= 4:4.3.1-1ubuntu2) GNU C 预处理器 (cpp)
* dep: g++-4.3 (>= 4.3.1-1) GNU C++ 编译器
* dep: gcc (>= 4:4.3.1-1ubuntu2) GNU C 编译器
* dep: gcc-4.3 (>= 4.3.1-1) GNU C 编译器



* sug: g++-multilib The GNU C++ compiler (multilib files)

上面的只有g++-4.3 (>= 4.3.1-1)不能安装,说要libstdc++6-4.3-dev(= 4.3.2-1ubuntu11),于是我又下了如下 的软件包:::


其它与 g++-4.3 有关的软件包

* 依赖 * 推荐 * 建议

* dep: gcc-4.3 (= 4.3.2-1ubuntu11) GNU C 编译器
* dep: gcc-4.3-base (= 4.3.2-1ubuntu11) GNU 编译器套装 (基本包)
* dep: libc6 (>= 2.8~20080505) GNU C 语言运行库:共享库 同时作为一个虚包由这些包填实: libc6-udeb
* dep: libgmp3c2 Multiprecision arithmetic library
* dep: libmpfr1ldbl multiple precision floating-point computation
* dep: libstdc++6-4.3-dev (= 4.3.2-1ubuntu11) The GNU Standard C++ Library v3 (development files)



* sug: g++-4.3-multilib The GNU C++ compiler (multilib files)
* sug: gcc-4.3-doc (>= 4.3.2-1) Documentation for the GNU compilers (gcc, gobjc, g++)
* sug: libstdc++6-4.3-dbg The GNU Standard C++ Library v3 (debugging files)


上面的只有ibstdc++6-4.3-dev (= 4.3.2-1ubuntu11)不能安装,说是要g++-4.3(= 4.3.2-1ubuntu11),就这样………………


ibstdc++6-4.3-dev需要g++-4.3,,g++-4.3需要ibstdc++6-4.3-dev

像是死循环了的一样,安装不了,,各位能人 ,高手, 请指点指点一下……………………


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu8.10安装不了build-essential
帖子发表于 : 2009-11-21 20:37 
头像

注册: 2007-07-01 19:22
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
今天我也遇到了。不知道怎么解决


_________________
喜欢交流


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu8.10安装不了build-essential
帖子发表于 : 2009-11-21 20:59 
头像

注册: 2007-07-01 19:22
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
sudo dpkg -i libstdc++6-4.3-dev g++-4.3

sudo apt-get install -f 软件包装好了,但不能用。
这个整理依赖关系


_________________
喜欢交流


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译