当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如果关闭在关机时机箱里面发出的“滴”的声音
帖子发表于 : 2008-12-08 21:58 

注册: 2008-12-08 13:48
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
我安装好呢Ubuntu 8.1,驱动也安装正常,可以正常播放音乐,但是有些时候(比如:关机点下“Shut down”后,马上就会发出“滴”的一声,然后关机。或者在Suspend之后,在密码输入框里不停按Backspace也会发出这样的声音)会发出类似机箱里面发出的警报声音(显然不是通过声卡发出的声音)。

事实上,我的电脑是个笔记本,不带耳机时,这样的声音会非常大,有些时候会让我非常尴尬。

请问,如何让Ubuntu别下指令发出这样的声音。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 如果关闭在关机时机箱里面发出的“滴”的声音
帖子发表于 : 2008-12-09 19:02 

注册: 2007-07-22 4:48
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
如果是system beep的话可以在声音设置里关掉的说
比如我改成了屏幕闪动,酱紫


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 如果关闭在关机时机箱里面发出的“滴”的声音
帖子发表于 : 2008-12-09 23:20 

注册: 2008-12-03 10:05
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
如果是gnome桌面,那就系统--系统设置--音效--第二个标签--把两个对勾都关掉

btw: windows XP windows Vista可以在控制面板--设备管理器,选择显示隐藏的设备
然后把 beep 设备禁用


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 如果关闭在关机时机箱里面发出的“滴”的声音
帖子发表于 : 2008-12-12 11:06 

注册: 2008-12-08 13:48
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
非常感谢!问题已经解决。
我也找到另外的方法给大家看看
You can disable this by editing a file and entering two simple lines.

sudo gedit /etc/modprobe.d/blacklist

And then add:

#silly speaker beep
blacklist pcspkr

Save your file and the speaker beep will be gone when you reboot.
If you don’t want to wait until a reboot, simply type:

sudo rmmod pcspkr

参考资料:http://www.arsgeek.com/2006/08/23/how-to-turn-off-the-annoying-system-beep-in-linux-debianubuntu/


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 如果关闭在关机时机箱里面发出的“滴”的声音
帖子发表于 : 2008-12-13 16:57 

注册: 2008-12-03 10:05
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
我发现用我三楼的方法,只能关掉从用户切换器开始的重启命令的beep

不能关掉应用程序启动器面板--系统--关闭的beep

又是莫名其妙的事情

看来还是把beep服务完全禁用掉最好

楼主的方法不错


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译