当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 13:36 

注册: 2009-01-17 23:29
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
首先我是个新手,最初是因为想安装wine,在终端里面安装,但是失败了,因为显示的是
出现mars@ubuntu:~$ sudo aptitude install wine
E: 无法识别在安装源列表 /etc/apt/sources.list.d/winehq.list 里,第 3 行中的软件包类别“<!DOCTYPE”
E: 无法识别在安装源列表 /etc/apt/sources.list.d/winehq.list 里,第 3 行中的软件包类别“<!DOCTYPE”
E: 无法读取软件源列表。
E: 无法识别在安装源列表 /etc/apt/sources.list.d/winehq.list 里,第 3 行中的软件包类别“<!DOCTYPE”
E: 无法读取软件源列表。

而后,我就放弃了装wine的念头,可是更新也更新不起了,显示的是 出现错误“请右击菜单运行软件管理器或者在终端中运行 apt-get 查看错误内容。错误信息为:‘Error: Opening the cache (E:Type'<!DOCTYPE'is not line 3 in source list /ect/apt/sources.list.d/winehq.list. E:The list of sources could not bi read.)'一般情况下,这表示你安装的软件包有些需要的程序未被安装。

当我在终端输入 apt-get 时 出现
(当我输入就出现
mars@ubuntu:~$ apt-get
apt 0.7.14ubuntu6 for amd64 编译于 Aug 14 2008 16:55:52
用法: apt-get [选项] 命令
apt-get [选项] install|remove 软件包1 [软件包2 ...]
apt-get [选项] source 软件包1 [软件包2 ...]

apt-get 提供了一个用于下载和安装软件包的简易命令行界面。
最常用命令是 update 和 install。

命令:
update - 取回更新的软件包列表信息
upgrade - 进行一次升级
install - 安装新的软件包(注:包名是 libc6 而非 libc6.deb)
remove - 卸载软件包
autoremove - 卸载所有自动安装且不再使用的软件包
purge - 卸载并清除软件包的配置
source - 下载源码包文件
build-dep - 为源码包配置所需的构建依赖关系
dist-upgrade - 发布版升级,见 apt-get(8)
dselect-upgrade - 根据 dselect 的选择来进行升级
clean - 删除所有已下载的包文件
autoclean - 删除老版本的已下载的包文件
check - 核对以确认系统的依赖关系的完整性

选项:
-h 本帮助文档。
-q 让输出可作为日志 - 不显示进度
-qq 除了错误外,什么都不输出
-d 仅仅下载 - 【不】安装或解开包文件
-s 不作实际操作。只是依次模拟执行命令
-y 对所有询问都回答是(Yes),同时不作任何提示
-f 当出现破损的依赖关系时,程序将试图修正系统
-m 当有包文件无法找到时,程序仍试图继续执行
-u 显示已升级的软件包列表
-b 在下载完源码包后,编译生成相应的软件包
-V 显示详尽的版本号
-c=? 读取指定配置文件
-o=? 设置任意指定的配置选项,例如 -o dir::cache=/tmp
请查阅 apt-get(8)、sources.list(5) 和 apt.conf(5)的参考手册
以获取更多信息和选项。)

右击进入新的力软件包 显示E: 无法识别在安装源列表 /etc/apt/sources.list.d/winehq.list 里,第 3 行中的软件包类别“<!DOCTYPE”
E: 无法读取源列表。
请转到软件库对话框以解决该问题。
E: _cache->open() failed, please report.
牛人来帮帮我阿


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 13:38 

注册: 2009-01-17 23:29
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
附上我的 sources.list
deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release amd64 (20081029.2)]/ intrepid main restricted
deb-src http://archive.ubuntu.com/ubuntu/ intrepid main restricted #Added by software-properties
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://cn.archive.ubuntu.com/ubuntu/ intrepid main restricted multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu/ intrepid intrepid intrepid-updates intrepid-backports deb-src restricted intrepid-security http://archive.ubuntu.com/ubuntu/ universe intrepid-proposed deb main multiverse #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu/ intrepid-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.

# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu intrepid-security universe
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-security main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu/ intrepid-security restricted main multiverse universe #Added by software-properties
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-security multiverse
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid intrepid-updates restricted multiverse restricted multiverse deb http://archive.ubuntu.com/ubuntu/ intrepid-backports restricted multiverse http://archive.ubuntu.com/ubuntu/ intrepid restricted multiverse http://archive.ubuntu.com/ubuntu/ intrepid-security restricted multiverse deb-src http://archive.ubuntu.com/ubuntu/ intrepid-updates restricted multiverse deb-src http://archive.ubuntu.com/ubuntu/ intrepid-proposed main restricted universe multiverse deb-src http://archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-security restricted multiverse
deb http://cn.archive.ubuntu.com/ubuntu intrepid-security main restricted universe multiverse


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 13:50 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
引用:
/etc/apt/sources.list.d/winehq.list 里,第 3 行中

把这个文件第三行清理干净


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 14:43 

注册: 2009-01-17 23:29
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
lerosua 写道:
引用:
/etc/apt/sources.list.d/winehq.list 里,第 3 行中

把这个文件第三行清理干净

我把清理了 ``但是我要保存cources.list的时候 他说我无法保存文件 /etc/apt/sources.list~。您没有权限保存文件。请检查键入的位置是否正确,然后重试。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 14:50 
头像

注册: 2008-02-17 23:47
帖子: 22106
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 81
代码:
sudo gedit /etc/apt/sources.list.d/winehq.list


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 19:31 

注册: 2007-09-22 21:49
帖子: 296
送出感谢: 3
接收感谢: 0 次
LS正解!你不能保存是看看是没有sudo~


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 19:42 

注册: 2009-01-17 23:29
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
adagio 写道:
代码:
sudo gedit /etc/apt/sources.list.d/winehq.list


mars@ubuntu:~$ sudo gedit /etc/apt/sources.list.d/winehq.list
[sudo] password for mars:
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
GTK Panel of SCIM 1.4.7

GTK Panel of SCIM 1.4.7


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">



<html xmlns="http://www.w3.org/1999/xhtml" >

<head><title>

您输入的域名出错了!

</title></head>

<body>

<form name="form1" method="post" action="dns.aspx" id="form1">

<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="/wEPDwUJNzgzNDMwNTMzZGQeoi7Cc/FEDZOmxFEcbE/+KaaHjg==" />



</form>

</body>

</html>






看看吧


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 来帮帮我吧```快崩溃了
帖子发表于 : 2009-01-19 20:07 

注册: 2009-01-17 23:29
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
已经解决了 ``谢谢你们大家的帮助``谢谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译