当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-02-01 20:18 

注册: 2007-11-28 13:59
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
下了realplayer,卡的要飞起来了。

mplayer 尝试这找了论坛里好多贴,也参考了 wiki 里, 把 win32code 下下来,放在了 从贴里搜集来的 3个 目录里 (/usr/local/lib/codecs /usr/lib/codecs /usr/...win32/ ) 随手写的目录,大概是这三个,

还按照一个贴子 sudo ln 了些目录,这里不写了
还尝试着改 rmvb文件的名字
还尝试着改 mplayer 里的 属性设置,输出设置,,

这些更改都是按照论坛其他人分享的方法 设置的。
但是播放的时候都是有声音无图像。

唯独看到一个贴,说的很实在,并直接给了个 deb包下载地址,说直接鼠标双击安装就可以了,系统会自动更新code ,并能自动播放, 可惜,连接无效了。

我们新手,就是需要这样的 deb 包,,不需要什么麻烦的 代码,,我们学会了,一点附加价值都没,学习的这个时间,可以来作其他很多事。

希望哪个高手在帮忙看看。

我的系统 ubuntu8.04

目前系统装了 winxp 和 ubuntu , 是在 UBUNTU下用驴子和迅雷下载好电影,再用U盘复制出来,重新启动机器到WINXP下播放。再没时间折腾怎么共享二个系统下的文件了。
没办法,已经被UBUNTU折腾的训练出了很大的耐心。无所谓了。

希望UBUNTU越来越强大,越来越适合大众使用,我会永远支持你。
------一个非计算机学生的 UBUNTU 小小故事。

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

办法找到了,在第4楼,直接 deb 安装,不再被命令行代码折磨了。


最后由 largecat 编辑于 2009-02-01 20:50,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: mplayer无法播放RMVB
帖子发表于 : 2009-02-01 20:20 

注册: 2007-11-28 13:59
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
winxp 下已经不想再下载东西,因为经常附带下一些病毒,很烦,所以现在基本在 UBUNTU下 下载了,就算是病毒也无所谓。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: mplayer无法播放RMVB
帖子发表于 : 2009-02-01 20:43 
头像

注册: 2006-11-18 18:52
帖子: 450
送出感谢: 0 次
接收感谢: 0 次
实在找不到的话,看看这个吧...
https://help.ubuntu.com/community/Medibuntu
话说好几个源里都有
源里都是deb的...


页首
 用户资料  
 
4 楼 
 文章标题 : Re: mplayer无法播放RMVB
帖子发表于 : 2009-02-01 20:48 

注册: 2007-11-28 13:59
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
事实证明,我的耐心是非常的强了。

找到办法了。

对新手:

1、打开终端,输入: dpkg -l w32codecs (直接复制过去,粘贴,回车运行这句代码)
2、如果显示 “无” ,表示 win32code没安装。如果有,会显示版本号的。
3、下载 win32code 解码包,地址:http://www.debian-multimedia.org/pool/main/w/w32codecs/w32codecs_20071007-0.1_i386.deb
(如果这个地址失效,大家百度一下,直接找 deb 包)
4、下载完毕,直接鼠标双击运行,选择安装。
5、安装完毕。OK
6、打开你的 mplayer ,享受 mplayer 播放 rmvb 吧,很流畅。

另外 mplayer 的一些参数:

  vo=xv(选择默认的播放模式,xv模式是支持显卡硬加速功能的模式,对cpu的占用很小,推荐;更多的显示模式可以用命令mplayer -vo help看,其中的vesa模式可以在不启动xwin界面时播放,有点象当年DOS下的金山影霸)
  ao=oss(选择声音的播放模式,oss是兼容性最好的播放模式,推荐;你也可以试试sdl模式)
  fs=yes(全屏模式,yes的话默认以全屏播放,no或前面加#号注释掉这行的话则默认是1:1播放模式)
  zoom=yes(即时改变电影画面大小,yes的话则可以用鼠标随意将播放画面拉大拉小,no的话不能)
  gui = yes(默认是图形化操作界面,这需要你先前用./configure --enable-gui来编译,否则的话就算yes也没有gui操作界面)
  skin = default(设置默认的skin,将等号右边的值换成skin所放目录就可以设置想要的skin为默认了,这个参数在用gui操作界面才有效)
  cache = 8192(默认的播放缓存大小,如果机器内存够大,则将它加大一点,如果不是很大,譬如128以下,还是用默认的算了)
  framedrop = yes(允许跳帧,如果你的机器CPU速度非常非常慢的话请将这个yes,默认是no或前面加#号将这行禁止;对于366MHZ以上的机器,建议都设成no或前面加#号)其他设置用默认就行 。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-02-03 18:23 

注册: 2009-01-28 22:19
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
学习了,O(∩_∩)O谢谢


页首
 用户资料  
 
6 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-05-25 20:36 

注册: 2009-05-25 19:45
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
真是帮上大忙了,原来用自带的totem放720P的rmvb卡疯掉了,装了个Mplayer,只能放出声音,没图像。按上面的方法装上win32code后终于搞定了。非常感谢。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: mplayer无法播放RMVB
帖子发表于 : 2009-05-25 20:41 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
largecat 写道:
事实证明,我的耐心是非常的强了。

找到办法了。

对新手:

1、打开终端,输入: dpkg -l w32codecs (直接复制过去,粘贴,回车运行这句代码)
2、如果显示 “无” ,表示 win32code没安装。如果有,会显示版本号的。
3、下载 win32code 解码包,地址:http://www.debian-multimedia.org/pool/main/w/w32codecs/w32codecs_20071007-0.1_i386.deb
(如果这个地址失效,大家百度一下,直接找 deb 包)
4、下载完毕,直接鼠标双击运行,选择安装。
5、安装完毕。OK
6、打开你的 mplayer ,享受 mplayer 播放 rmvb 吧,很流畅。

另外 mplayer 的一些参数:

  vo=xv(选择默认的播放模式,xv模式是支持显卡硬加速功能的模式,对cpu的占用很小,推荐;更多的显示模式可以用命令mplayer -vo help看,其中的vesa模式可以在不启动xwin界面时播放,有点象当年DOS下的金山影霸)
  ao=oss(选择声音的播放模式,oss是兼容性最好的播放模式,推荐;你也可以试试sdl模式)
  fs=yes(全屏模式,yes的话默认以全屏播放,no或前面加#号注释掉这行的话则默认是1:1播放模式)
  zoom=yes(即时改变电影画面大小,yes的话则可以用鼠标随意将播放画面拉大拉小,no的话不能)
  gui = yes(默认是图形化操作界面,这需要你先前用./configure --enable-gui来编译,否则的话就算yes也没有gui操作界面)
  skin = default(设置默认的skin,将等号右边的值换成skin所放目录就可以设置想要的skin为默认了,这个参数在用gui操作界面才有效)
  cache = 8192(默认的播放缓存大小,如果机器内存够大,则将它加大一点,如果不是很大,譬如128以下,还是用默认的算了)
  framedrop = yes(允许跳帧,如果你的机器CPU速度非常非常慢的话请将这个yes,默认是no或前面加#号将这行禁止;对于366MHZ以上的机器,建议都设成no或前面加#号)其他设置用默认就行 。

恩mark掉


页首
 用户资料  
 
8 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-05-25 23:09 
头像

注册: 2008-12-16 14:01
帖子: 1081
地址: 漂在江湖
送出感谢: 12
接收感谢: 13
mark


页首
 用户资料  
 
9 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-05-28 23:27 

注册: 2008-10-17 12:30
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
关键是我用的是64位系统,你那个安装包,估计肯定装不了。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-09-07 19:20 

注册: 2008-07-15 13:01
帖子: 108
送出感谢: 0 次
接收感谢: 0 次
感谢LZ~~~~~~ :em11


页首
 用户资料  
 
11 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-11-04 9:48 
头像

注册: 2009-10-27 11:14
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
mark~ 我的也不能播放, 报错, 试试你这个方法管用不. :em11


_________________
我就是一个悲剧....


页首
 用户资料  
 
12 楼 
 文章标题 : Re: mplayer无法播放RMVB [已解决] 答案在4楼
帖子发表于 : 2009-11-04 11:05 

注册: 2007-11-12 11:20
帖子: 128
送出感谢: 0 次
接收感谢: 3
mark先,我的是64位的,不知道可行不。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译