系统升级出错

系统安装、升级讨论
回复
zongzihe
帖子: 20
注册时间: 2008-04-12 16:33
送出感谢: 0
接收感谢: 0

系统升级出错

#1

帖子 zongzihe » 2009-02-12 16:53

当进行升级时,系统提示:

正预备替换 linux-image-2.6.24-23-generic 2.6.24-23.46 (使用 .../linux-image-2.6.24-23-generic_2.6.24-23.49_i386.deb) ...
Done.
正在解压缩将用于更替的包文件 linux-image-2.6.24-23-generic ...
dpkg:处理 /var/cache/apt/archives/linux-image-2.6.24-23-generic_2.6.24-23.49_i386.deb (--unpack)时出错:
无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-23-generic”做一个符号链接备份: 操作不允许
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了


请问这是为甚么,怎么处理阿?谢谢!
头像
horadric
帖子: 17
注册时间: 2008-12-18 0:58
送出感谢: 0
接收感谢: 0

Re: 系统升级出错

#2

帖子 horadric » 2009-02-12 20:46

wubi安装的?
我也遇到过,wiki上有说明,好像是因为fat32的原因,不用理会,后来重装改成ntfs就没出这提示.具体可以到wiki上查一下.
zongzihe
帖子: 20
注册时间: 2008-04-12 16:33
送出感谢: 0
接收感谢: 0

Re: 系统升级出错

#3

帖子 zongzihe » 2009-02-13 12:03

是在fat32上用wubi安装的。谢谢啦!!!我来看看wiki
zongzihe
帖子: 20
注册时间: 2008-04-12 16:33
送出感谢: 0
接收感谢: 0

Re: 系统升级出错

#4

帖子 zongzihe » 2009-02-13 12:21

wiki上说:

无法...做一个符号链接备份

E: /var/cache/apt/archives/linux-image-2.6.27-7-generic_2.6.27-7.16_i386.deb:
无法在安装新的版本前,为“./boot/vmlinuz-2.6.27-7-generic”做一个符号链接备份

出现这个问题,是因为你用的wubi,且将系统安装在了fat32分区。

如果想彻底解决这个问题,请采用其他安装方式,或者用wubi安装在ntfs分区。

如果只想临时解决问题,锁定出问题的包,不让它升级就可以了。
头像
xgh3578
帖子: 166
注册时间: 2008-10-13 9:56
来自: 中国
送出感谢: 0
接收感谢: 0
联系:

Re: 系统升级出错

#5

帖子 xgh3578 » 2009-02-15 21:56

zongzihe 写了:wiki上说:

无法...做一个符号链接备份

E: /var/cache/apt/archives/linux-image-2.6.27-7-generic_2.6.27-7.16_i386.deb:
无法在安装新的版本前,为“./boot/vmlinuz-2.6.27-7-generic”做一个符号链接备份

出现这个问题,是因为你用的wubi,且将系统安装在了fat32分区。

如果想彻底解决这个问题,请采用其他安装方式,或者用wubi安装在ntfs分区。

如果只想临时解决问题,锁定出问题的包,不让它升级就可以了。
终于了解了,原来是分区的问题。我的也是这样。
wulonghao
帖子: 3
注册时间: 2009-02-10 20:32
送出感谢: 0
接收感谢: 0

Re: 系统升级出错

#6

帖子 wulonghao » 2009-02-17 22:24

把那个错误的 /var/cache/apt/archives/linux-image-2.6.27-7-generic_2.6.27-7.16_i386.deb删除,在升级。要删除和它一起的 好像是3个文件。
回复

回到 “系统安装和升级”