当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-13 12:45 

注册: 2009-02-12 23:52
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
机器配置:IBM P3 1G +512ECC +18.6Gsisc
系统 ubuntu 8.10
全新安装,提示成功, 重新启动以后提示
Gave up waiting for root device. Common problems:
-Boot args(cat /proc/cmdline)
-check rootdelay=(did the system wait long enough)
-check root=(did the system wait for the right device)
-Missing modules (cat /proc/modules;ls /dev)

Alert /dev/disk/by-uuid/******** doesn't exist Dropping to a shell




BusyBox v1.10.2 (Ubuntu 1:1.10.2-1ubuntu6) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)_


系统就在这个地方卡住了,但是如果我在initramfs下面输入 exit 系统就可以在一些提示下面正常启动,一切正常,
但是我有个疑问,经过我查看 /dev/disk/by-uuid/******** 这个文件是完全存在的,为什么会提示不存在呢?我试图通

过延长时间 timeout=60 仍然无法解决这个问题?

希望各位大虾指点一二;谢谢

附件:
menu.lst


title Ubuntu 8.10, kernel 2.6.27-7-server
uuid 596db294-4759-4f2c-991b-f8be2931a56a
kernel /boot/vmlinuz-2.6.27-7-server root=UUID=596db294-4759-4f2c-991b-f8be2931a56a ro quiet

splash noapic
initrd /boot/initrd.img-2.6.27-7-server
quiet

title Ubuntu 8.10, kernel 2.6.27-7-server (recovery mode)
uuid 596db294-4759-4f2c-991b-f8be2931a56a
kernel /boot/vmlinuz-2.6.27-7-server root=UUID=596db294-4759-4f2c-991b-f8be2931a56a ro single
initrd /boot/initrd.img-2.6.27-7-server

title Ubuntu 8.10, memtest86+
uuid 596db294-4759-4f2c-991b-f8be2931a56a
kernel /boot/memtest86+.bin
quiet


root@ubuntu:/dev/disk/by-uuid# ls
596db294-4759-4f2c-991b-f8be2931a56a 6d961915-7ed4-4f14-9f5d-4cc95ff77bbd


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-13 12:48 

注册: 2009-02-12 23:52
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
开始的时候提示 8254……错误,在menu.lst 加入了 noapic 问题解决,但是上面的这个问题一直无法搞定


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-15 17:32 

注册: 2009-02-12 23:52
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
解决办法:

是rootdelay设置的时间太短
导致系统还没有正常加载完设备驱动就已经开始寻找root分区,而导致找不到/root分区。

应该增加rootdelay 参数而不是 timeout


kernel /boot/vmlinuz-2.6.27-7-server rootdelay=90 root=UUID=596db294-4759-4f2c-991b-f8be2931a56a ro quiet


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-16 9:49 

注册: 2008-07-07 11:37
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
to flyingnie:

http://www.maycode.com/index.php/forum. ... 10&id=5079

恭喜你问题解决了。我昨天安装的时候也遇到这个错误,但解决的办法不是增加 rootdelay。

等回去翻一下当时的安装笔记,,,,,,,,,,,,,


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 4:25 

注册: 2009-02-28 4:19
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我也遇到了这个问题,我编译内核之后进新内核出现这个问题,rootdelay没有用,也不是uuid的问题.谁能告诉我原因,谢谢!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 9:53 

注册: 2008-07-07 11:37
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
我查了当天的笔记,当时情况是,我使用grub4dos,硬盘安装ubuntu,启动时出现这个错误。

网上有人加上rootdelay问题解决,我的却没有效果,后来下载新版本grub4dos问题解决,原来版本不支持uuid表示。

/dev/disk/by-uuid/******** 是关键~


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 13:35 

注册: 2009-02-28 4:19
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我在新内核initramfs看/dev/disk下面没有by-uuid这个目录,用老内核进去系统了又能看到,是不是这个原因?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 13:59 

注册: 2009-02-28 4:19
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我是VM安装的,按照网上的步骤,装完了就出现gave up...

menu.lst
title Ubuntu 8.10, kernel 2.6.27.7-custom
uuid 26d47642-69f6-46ec-89a4-44981fb3a048
kernel /boot/vmlinuz-2.6.27.7-custom root=UUID=26d47642-69f6-46ec-89a4-44981fb3a048 ro locale=zh_CN quiet splash
initrd /boot/initrd.img-2.6.27.7-custom
quiet

title Ubuntu 8.10, kernel 2.6.27-7-generic
uuid 26d47642-69f6-46ec-89a4-44981fb3a048
kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=26d47642-69f6-46ec-89a4-44981fb3a048 ro locale=zh_CN quiet splash
initrd /boot/initrd.img-2.6.27-7-generic
quiet
------------
blkid
/dev/ramzswap0: TYPE="swap"
/dev/sda1: UUID="26d47642-69f6-46ec-89a4-44981fb3a048" TYPE="ext3"
/dev/sda5: TYPE="swap" UUID="8baa3822-7f77-4a53-950b-e6da4bd7f288"
-----------
fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=26d47642-69f6-46ec-89a4-44981fb3a048 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda5
UUID=8baa3822-7f77-4a53-950b-e6da4bd7f288 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
网上很多方法都试过了,都没弄好.


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 17:10 

注册: 2008-07-07 11:37
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
cc5a1 写道:
我在新内核initramfs看/dev/disk下面没有by-uuid这个目录,用老内核进去系统了又能看到,是不是这个原因?


你内核怎么编译的,看你的menu.lst也没有升级kernel,就是重新 make menuconfig?

我猜一下,你编译内核的时候,Device Drivers——>SCSI device support,设备驱动方面没编译好~~


_________________
linux起点中文站:http://www.linuxorz.com


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 17:26 

注册: 2009-02-28 4:19
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我装的内核版本是2.6.27.7,我只是为了学习,所以下的内核源码还是2.6.27.7
Device Drivers我没改动,我只把ext3改为*了


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 17:47 

注册: 2009-02-28 4:19
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
请问是否我 只需要make menuconfig重新生成配置文件就可以了?
还需要再把内核编译一次吗?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 17:54 

注册: 2008-07-07 11:37
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
cc5a1 写道:
请问是否我 只需要make menuconfig重新生成配置文件就可以了?
还需要再把内核编译一次吗?


内核我就编译过一次,其中选项很多的,一定要仔细看,你如果只是按默认设置,这样重新编译内核是没有意义的。

相关文章,你可以网上搜搜看。爱莫能助~ :em06


_________________
linux起点中文站:http://www.linuxorz.com


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-02-28 18:31 

注册: 2009-02-28 4:19
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我肯定改啊,就是改完了生成的新config是不是要再把内核编译一次才会生效?
我机器编一次要几个小时 :em06


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-12-03 17:16 

注册: 2008-09-19 15:00
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
mark 下
livecd 装完 9.10更新 ,重启后出来了这个问题~~


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 全新安装8.10 出现Gave up ……提示,busyBox……输入exit 能进系统
帖子发表于 : 2009-12-03 18:01 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
cc5a1 写道:
我肯定改啊,就是改完了生成的新config是不是要再把内核编译一次才会生效?
我机器编一次要几个小时 :em06

坛子里有人编译一次只需要20 ~30分钟 你信不


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译