当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 为了弄GIMP2.6,把系统搞崩溃了...在线等修复办法
帖子发表于 : 2009-02-15 21:40 

注册: 2006-09-08 18:57
帖子: 115
送出感谢: 0 次
接收感谢: 2
我的系统是8.04,GIMP版本为2.4,想尝试一下2.6,于是就下载了下面几个包:
gimp_2.6.1-1ubuntu3_i386.deb libgimp2.0_2.6.1-1ubuntu3_i386.deb
gimp-data_2.6.1-1ubuntu3_all.deb libgtk2.0-0_2.14.4-0ubuntu1_i386.deb
libbabl-0.0-0_0.0.22-1_i386.deb libpango1.0-0_1.22.1-0ubuntu1_i386.deb
libgegl-0.0-0_0.0.18-1_i386.deb libpoppler-glib3_0.8.7-1_i386.deb

执行
代码:
sudo dpkg -i *
后出问题了,系统中原有的包被卸载,新的包装不上,也修复不了:
代码:
apt-get -f install


正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
已经不需要下列自动安装的软件包:
libfreebob0 libchewing3-data stardict-common lsb-languages debhelper
libbtctl4 libbeecrypt6 libsvga1 libjack0 lsb-graphics m4 ncurses-term
libchm1 python-chm libmono-cairo2.0-cil libchewing3 librpm4.4
python-compizconfig libggi2 libgii1 libupnp2 libcaptury0 libwxbase2.8-0
libcrypto++7 pax libgii1-target-x lsb-multimedia rpm libgeoip1 lsb-printing
filezilla-common libcapseo0 html2text amule-common lsb-core alien lsb-cxx
使用 'apt-get autoremove' 来删除它们。
下列软件包将被【卸载】:
adobereader-chs alacarte amule apport-gtk apturl at-spi bitstormlite
bluez-gnome brasero brltty-x11 bug-buddy chmsee compiz
compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-gnome
compiz-plugins compizconfig-settings-manager contact-lookup-applet
deskbar-applet displayconfig-gtk ekiga eog evince evolution
evolution-exchange evolution-plugins evolution-webcal f-spot
fast-user-switch-applet file-roller filezilla filezilla-locales firefox
firefox-3.0 firefox-3.0-gnome-support firefox-gnome-support
flashplugin-nonfree gcalctool gconf-editor gdebi gdm gedit gimp gksu
gnome-accessibility-themes gnome-app-install gnome-applets gnome-bluetooth
gnome-control-center gnome-games gnome-icon-theme gnome-keyring gnome-mag
gnome-media gnome-menus gnome-mount gnome-mplayer gnome-netstatus-applet
gnome-nettool gnome-orca gnome-panel gnome-pilot gnome-pilot-conduits
gnome-power-manager gnome-screensaver gnome-session gnome-settings-daemon
gnome-spell gnome-system-monitor gnome-system-tools gnome-terminal
gnome-themes gnome-user-guide gnome-utils gnome-volume-manager gpicview
gstreamer0.10-plugins-good gstreamer0.10-x gthumb gtk2-engines
gtk2-engines-murrine gtk2-engines-pixbuf gtk2-engines-ubuntulooks
gtkhtml3.14 gucharmap human-theme hwtest-gtk jockey-gtk kdebase-runtime
kdebase-runtime-bin-kde4 kompozer konsole-kde4 kwin-kde4 language-selector
language-support-input-zh language-support-translations-zh
language-support-zh libatspi1.0-0 libavahi-ui0 libbonoboui2-0
libdeskbar-tracker libedataserverui1.2-8 libeel2-2 libexchange-storage1.2-3
libgail-common libgail-gnome-module libgail18 libgegl-0.0-0 libgimp2.0
libgksu2-0 libglade2-0 libglade2.0-cil libgnome-desktop-2
libgnome-window-settings1 libgnome2-canvas-perl libgnome2-perl
libgnome2.0-cil libgnomebt0 libgnomecanvas2-0 libgnomekbd2 libgnomekbdui2
libgnomeprint2.2-0 libgnomeprintui2.2-0 libgnomeui-0 libgpod-common libgpod3
libgraphviz4 libgtk-vnc-1.0-0 libgtk2-perl libgtk2.0-0 libgtk2.0-bin
libgtk2.0-cil libgtkhtml2-0 libgtkhtml3.14-19 libgtkhtml3.16-cil
libgtkmm-2.4-1c2a libgtksourceview1.0-0 libgtksourceview2.0-0 libgtkspell0
libgucharmap6 libgweather1 liblaunchpad-integration1 liblpint-bonobo0
libmagick10 libmetacity0 libmono-addins-gui0.2-cil libnautilus-burn4
libnautilus-extension1 libnotify1 libpanel-applet2-0 libpango1.0-0
libpolkit-gnome0 libpoppler-glib2 libpoppler-glib3 librsvg2-2
librsvg2-common libsexy2 libtotem-plparser10 libtracker-gtk0 libvte9
libwmf0.2-7 libwnck22 libwxgtk2.8-0 libxine1 libxine1-misc-plugins
libxine1-plugins linuxqq lsb lsb-desktop metacity mousetweaks
mozilla-mplayer mplayer mplayer-fonts nautilus nautilus-cd-burner
nautilus-sendto nautilus-share network-manager-gnome notification-daemon
onboard openoffice.org-calc openoffice.org-common openoffice.org-core
openoffice.org-draw openoffice.org-gnome openoffice.org-gtk
openoffice.org-help-zh-cn openoffice.org-help-zh-tw openoffice.org-impress
openoffice.org-l10n-zh-cn openoffice.org-l10n-zh-tw
openoffice.org-style-human openoffice.org-writer pidgin pidgin-otr
policykit-gnome python-glade2 python-gmenu python-gnome2
python-gnome2-desktop python-gnomecanvas python-gtk2 python-gtkhtml2
python-gtksourceview2 python-launchpad-integration python-notify
python-pyatspi python-sexy python-uno python-virtkey python-vte realplay
rhythmbox rss-glx scim scim-bridge-agent scim-bridge-client-gtk scim-chewing
scim-gtk2-immodule scim-modules-table scim-pinyin scim-tables-zh
screensaver-default-images seahorse software-properties-gtk sound-juicer
ssh-askpass-gnome stardict stardict-gtk sun-java6-plugin synaptic
system-config-printer-gnome tangerine-icon-theme thunderbird
thunderbird-locale-zh-cn thunderbird-locale-zh-tw tomboy totem
totem-gstreamer totem-mozilla totem-plugins totem-xine tracker
tracker-search-tool transmission-gtk truecrypt tsclient ubufox
ubuntu-artwork ubuntu-desktop ubuntu-docs update-manager update-notifier
vinagre vino xdg-user-dirs-gtk xsane xscreensaver-data xscreensaver-gl
xulrunner-1.9 xulrunner-1.9-gnome-support yelp zenity
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 265 个软件包,有 0 个软件未被升级。
有 5 个软件包没有被完全安装或卸载。
操作完成后,会释放 1153MB 的磁盘空间。
您希望继续执行吗?[Y/n]

这岂不是要把我的整个系统都删了?瀑布汗......
不知道要怎么样修复
我在论坛中看到有人说可以把GIMP2.6相关的包下载下来用dpkg安装的,没想到出这么大乱子。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 为了弄GIMP2.6,把系统搞崩溃了...在线等修复办法
帖子发表于 : 2009-02-15 22:51 

注册: 2006-09-08 18:57
帖子: 115
送出感谢: 0 次
接收感谢: 2
没人回复?
幸亏自己搞定了,真是头都大了。
代码:
sudo dpkg -r --force-depends gimp gimp-data libbabl-0.0-0 libgegl-0.0-0 libgimp2.0 libpango1.0-0 libpoppler-glib3
sudo apt-get -f install


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译