apt-get dist-upgrade报错求救~~~

系统安装、升级讨论
回复
infocert
帖子: 3
注册时间: 2009-03-02 11:07
送出感谢: 0
接收感谢: 0

apt-get dist-upgrade报错求救~~~

#1

帖子 infocert » 2009-03-02 11:11

root@localhost:/var/cache/apt/archives# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
linux-ubuntu-modules-2.6.22-15-server: Depends: linux-image-2.6.22-15-server but it is not installed
E: Unmet dependencies. Try using -f.
请高手伸出援手,多谢!!!
头像
速腾1994
论坛版主
帖子: 17366
注册时间: 2008-11-01 20:43
系统: Arch+gnome
送出感谢: 23 次
接收感谢: 8 次

Re: apt-get dist-upgrade报错求救~~~

#2

帖子 速腾1994 » 2009-03-02 11:19

apt-get dist-upgrade -f :em11
infocert
帖子: 3
注册时间: 2009-03-02 11:07
送出感谢: 0
接收感谢: 0

Re: apt-get dist-upgrade报错求救~~~

#3

帖子 infocert » 2009-03-04 11:42

这样不行吧,我担心系统不稳定,再者我想装了这个2.6.22-15的内核,不知道用强制安装模式这个是不是可以装上?请高手再支招,谢谢~
头像
daf3707
论坛版主
帖子: 12671
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: apt-get dist-upgrade报错求救~~~

#4

帖子 daf3707 » 2009-03-04 11:43

apt-get dist-upgrade -f
xuco
帖子: 794
注册时间: 2008-01-30 19:19
送出感谢: 0
接收感谢: 0

Re: apt-get dist-upgrade报错求救~~~

#5

帖子 xuco » 2009-03-04 12:59

听听说,这 这个命令不支持了
infocert
帖子: 3
注册时间: 2009-03-02 11:07
送出感谢: 0
接收感谢: 0

Re: apt-get dist-upgrade报错求救~~~

#6

帖子 infocert » 2009-03-04 16:58

用过“apt-get dist-upgrade -f”后报错:
----------------------------------
Preparing to replace linux-ubuntu-modules-2.6.22-15-server 2.6.22-15.39 (using .../linux-ubuntu-modules-2.6.22-15-server_2.6.22-15.40_i386.deb) ...
Unpacking replacement linux-ubuntu-modules-2.6.22-15-server ...
Preparing to replace perl-modules 5.8.8-7ubuntu3.1 (using .../perl-modules_5.8.8-7ubuntu3.4_all.deb) ...
Unpacking replacement perl-modules ...
Preparing to replace perl 5.8.8-7ubuntu3.1 (using .../perl_5.8.8-7ubuntu3.4_i386.deb) ...
Unpacking replacement perl ...
Preparing to replace perl-base 5.8.8-7ubuntu3.1 (using .../perl-base_5.8.8-7ubuntu3.4_i386.deb) ...
Unpacking replacement perl-base ...
Errors were encountered while processing:
/var/cache/apt/archives/linux-image-2.6.22-14-server_2.6.22-14.52_i386.deb
/var/cache/apt/archives/linux-image-2.6.22-15-server_2.6.22-15.59_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
----------------------------------
感谢所有关注过此贴的朋友,请高手支招~多谢~~~
回复

回到 “系统安装和升级”