当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 15:27 

注册: 2009-02-12 10:57
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
显卡驱动的问题困扰了我大半个月了,尝试了各种方法都貌似一个结果,失败,总是在手动编译完弹出“You may need to update your configuration to solve this.(EE)Failed to load module "type 1"(module does not exist,0)”。即使是在无数次的重做系统的情况下还是这个样子,小弟不懂了,对linux研究不深,被这个显卡的驱动给档在了门外,不知道是个什么心情,你可能会说那装受限驱动呀,对了,装了过后还是这么一个效果,不知道是电脑问题还是自己的才疏学浅,望而却步了。希望有志之士帮忙小弟解决 这个问题,重塑加入UBUNTU信心,谢谢了!!!

PS:小弟的电脑配置为lenovo Y530.T8400,2G内存,NVIDIA 9500M G。

Thanks


页首
 用户资料  
 
2 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 15:44 

注册: 2009-02-12 10:57
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
每一个都是燕过无声


页首
 用户资料  
 
3 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 15:48 
头像

注册: 2007-09-26 17:34
帖子: 618
送出感谢: 0 次
接收感谢: 2
我ATI的显卡,装显卡驱动的经验就是
先下载linux内核头文件源代码,"linux-headers".
然后查看头文件和系统内核的版本是一致的.
就可以安装了
从来没遇到过问题


页首
 用户资料  
 
4 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 15:53 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
9500
安装这个吧。envyng-gtk


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 15:55 

注册: 2008-05-15 9:17
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
怎么都没有人发言。。。
我也是才用ubuntu不久。好多问题都没法解决。在这上面提问也得不到想要的答案。
不过我按照网上的流程已经解决了自己的nv显卡驱动,安装的官方驱动。
楼主的问题我没有遇到过,建议楼主确定自己的ubuntu内核已经为最新版本。另外自己下载的官方驱动确实没有问题。还有就是安装的系统是64位还是32位,对应的驱动包也是不一样的。如果是64位系统,最好安装上32位库。如果以上都弄清楚应该没有问题的吧。
我是按照这个步骤来装的:

1。在配置文件(/etc/default/linux-restricted-modules-common )中屏蔽这几个包(nv nvidia_new)
代码:
sudo gedit /etc/default/linux-restricted-modules-common

加入下面这行:
DISABLED_MODULES="nv nvidia_new"
然后保存,目的是禁止系统使用默认的驱动。
2。ctrl+alt+F1 进入字符界面。 登录之后 关闭xserver ( gdm )
代码:
sudo /etc/init.d/gdm stop

3。重新安装nvidia官方驱动。
代码:
sudo sh 你的驱动文件路径

安装过程中如果说你的x系统还没有关闭的话,那就直接重启之后再装。
装完后记得在字符界面的时候以root权限运行nvidia-xconfig,(之前重启后低分辨率运行系统-首选项-nv xserver setting出错弹出那个对话框的可能就是因为没有运行这个? )
代码:
sudo nvidia-xconfig

4。最后一步就是启动xserver(gdm )
代码:
sudo /etc/init.d/gdm start

之后就可以看到nvidia的logo了。
网上说如果不想要logo的话,可以手动配置下xorg.conf文件。
代码:
sudo gedit /etc/X11/xorg.conf

在Section "Device" 关于显卡配置的那一段里面添加Option "NoLogo" "True"这一行就行了。如:
Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce 7 Series"
BusID "PCI:6:0:0"
Screen 0
EndSection


页首
 用户资料  
 
6 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 16:27 

注册: 2009-02-12 10:57
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
完全是这个样子配置的,但是始终会出错提示然后会选择回到普通模式,真是气人~~~


页首
 用户资料  
 
7 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 16:50 

注册: 2008-12-09 15:21
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
看来楼主就此先放下UBUNTU吧,等过段时间再说咯,否则这样影响工作和学习哦


页首
 用户资料  
 
8 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-03 16:57 
头像

注册: 2009-02-26 21:50
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
我用winmount加载8.04 desktop i386镜像文件,居然可以硬盘安装!!中间只是手动输入用户名和密码,并且手动重启一次,安装完毕可以使用!! :em06


页首
 用户资料  
 
9 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 14:56 

注册: 2008-05-15 9:17
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
刚刚去网上搜索了一下。这个是原文:
引用:
nvidia-xconfig

nVidia users can also use

# nvidia-xconfig

when they have official nvidia drivers installed.

Comment the line

Load "type1"

in the Module section since recent versions of xorg-server do not include the type1 font module (completely replaced by freetype).

你自己看看你的xorg.conf文件。看里面Section "Module"那一段里是不是有 “ load "type1" 这一行,如果有的话就把这行注释(在行前面加“#“)掉后重启试试看。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 15:08 

注册: 2009-01-26 8:43
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
Ubuntu8.10显卡驱动安装和3D桌面启用方法 (1)硬件配置问题:
虽然说有的朋友用配置较低的机器在Linux下也能跑出3D桌面,
但如果有更高的配置的话,显然跑起来会更顺畅。
如果是打算新买显卡,建议选择比“最新最高配置”稍低一级的显卡;
本方法适用于主流Nvidia和ATI显卡,而对Intel显卡以及一些老旧显卡暂不支持,
我是AMD64双核3800+和Nforce 7600GT在1G内存下,3D效果开了大部分,很顺。
尽量安装Ubuntu的最新最完整的版本,
使用本教程在 Ubuntu 的 8.04,8.04.1,8.10 和 AMD64 DVD 版本下都成功地启用了3D桌面。
装了Ubuntu系统后,通常都可以启动图形界面登录使用,但这并不意味着显卡驱动已经装好了。

(2)最简单的ATI或Nvidia显卡最新官方驱动安装方法:
让envyng这个傻瓜软件帮助你吧!
用envyng安装驱动有个好处就是,有些需要卸载的冲突软件包它会自动帮你卸载,
有些3D桌面需要安装的支持软件包它会自动帮你安装。例如,Nvidia的glx相关软件包等。
这些软件之间的关联比较复杂,如果采用手工安装的方法很麻烦且容易出错。

首先,确保已经能连上网了,图形界面下,点击任务栏“系统”-“系统管理”-“软件源”
在弹出的窗口中“下载自”的下拉菜单里,把默认的“中国的服务器”改选为“主服务器”。
点击“关闭”然后会自动更新一些文件。

然后,点击任务栏“系统”-“系统管理”-“新立得软件包管理器”
在菜单栏里点击“编辑”-“搜索”-输入envyng-gtk并勾选它,会提示安装envyng-core,
勾选后点击“应用”即可自动下载安装(如果你的Ubuntu安装有KDE,还可以下载envyng-qt安装)。
在命令行的安装方法:点击任务栏““应用程序”-“附件”-“终端”,
输入下列命令:sudo apt-get install envyng-gtk
如果无法进入图形界面,也可以启动后在终端登录,用这个命令来安装envyng。

如果是64位的CPU系统,有可能安装envyng时会提示“找不到/usr/lib32/libGL.so.1”错误,
解决方法是:点击任务栏““应用程序”-“附件”-“终端”,输入下列命令:
sudo ln -s /usr/lib64 /usr/lib32
然后再进行安装envyng就能顺利安装完成了。



envyng装好后,可以在任务栏““应用程序”-“系统工具”里启动envyng,
启动后,现在左边的方框里,按你的显卡类型,选择“ATI”或者“NVDIA”,
右边建议选择默认的(Automatic Hardware Detection)自动检测硬件安装,
点击“应用”即可自动下载安装官方驱动了。



由于envyng也有不同的版本,envyng-gtk的1.1.1ubuntu3版就没有图形界面,
这时你可以用命令行的方法来启用envyng安装显卡驱动,
点击任务栏““应用程序”-“附件”-“终端”,输入下列命令: sudo envyng -t
然后会有个菜单出现,请按你的显卡需要而选择:
1- Install the NVIDIA driver 安装 NVIDIA 显卡驱动
2- Uninstall the NVIDIA driver 卸载 NVIDIA 显卡驱动
3- Install the ATI driver 安装 ATI 显卡驱动
4- Uninstall the ATI driver 卸载 ATI 显卡驱动
5- Restart the Xserver 重新启动 X 服务(即图形界面)
6- Restart your computer 重新启动你的计算机
7- Exit 退出

以 NVIDIA 显卡为例子,选择“1”回车后,会列出几个驱动程序版本号供你选择安装:
0. 177.80-0ubuntu2
1. 173.14.12-1-0ubuntu4
2. 96.43.05-0ubuntu10
3. 71.86.04-0ubuntu10
默认选择“0”然后回车就可以自动下载并安装最新版本的官方驱动,
安装完成后会提示你是否重新启动电脑,选择“0 Yes”重启或“1 No”不重启。
如果重启电脑后,这个版本的显卡驱动没有起作用,你可以还选择1、2、3…其他版本的驱动试试。
如果安装过程出错,如突然停电了什么的,你还可以用下面的命令恢复envyng安装前的状态:
sudo envyng --uninstall -all


页首
 用户资料  
 
11 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 15:09 

注册: 2009-01-26 8:43
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
(3)如果显卡安装后,重启电脑黑屏怎么办?
不要着急,简单任务,呵呵。
先按ctrl+alt+F1切换到终端下,让我们先查找出问题所在,登录终端,输入命令:
more /var/log/Xorg.0.log |grep "(EE)" 和 more /var/log/Xorg.0.log|grep "(WW)"
这两句命令的意思是,查看图形界面启动时的错误(或警告)信息.

如果输出的错误信息不多,只有一两行,就用笔抄在一张纸上。
如果输出的错误信息有一大串怎么办?抄得很累啊。
没事,用这个命令: more /var/log/Xorg.0.log |grep "(EE)" >123
这样就能把错误信息保存在123文件里了,
一会我们可以重新回到图形界面,根据错误信息的提示,上网找解决方法或求助。

(4)装了新显卡驱动,都黑屏了,怎么回图形界面?难道只能用回XP不成?
非也,非也。
如果你装好Ubuntu系统后,默认就已经能用图形了的话,现在也可以恢复到原状。
重启系统,在grub启动菜单里选择 (recovery mode)也就是第二项。
我的电脑的例子是:Ubuntu 8.04.1, kernel 2.6.24-19-generic (recoverymode)
然后你能看到一个菜单,选择“fix X”回车,然后再选择第一项正常启动。
呵呵,图形界面又回来了吧?
重新回到图形界面后,可以根据错误信息的提示,上网寻找解决方法或发帖求助。

什么?启动时没有菜单可选?
那是因为你在安装Ubuntu系统时,没有勾选安装“启动器”。
怎么办?安装grub不在本文的话题之内,否则篇幅就太大了,自己上网找找方法吧。

(5)如果一切顺利,显卡官方驱动就已经正确安装了。
以我的电脑Nvidia为例,图形界面启动时可以看到Nvidia标志,
可以在任务栏“系统”-“系统管理”里用“NVIDIA X Server Setting ”进行设置。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 18:55 

注册: 2009-03-02 21:35
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
安装显卡驱动最好用envyng这个软件,够方便。装完驱动之后,还不能立刻启用3D效果。还要装conpiz这个软件来帮你启动3D效果,把你要启用的特效勾上,然后按上相应的快捷键,就出现相应的3D效果 :em11


页首
 用户资料  
 
13 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 19:35 
头像

注册: 2009-02-25 21:25
帖子: 69
地址: 辽宁沈阳
送出感谢: 0 次
接收感谢: 0 次
longgegeno1 写道:
显卡驱动的问题困扰了我大半个月了,尝试了各种方法都貌似一个结果,失败,总是在手动编译完弹出“You may need to update your configuration to solve this.(EE)Failed to load module "type 1"(module does not exist,0)”。即使是在无数次的重做系统的情况下还是这个样子,小弟不懂了,对linux研究不深,被这个显卡的驱动给档在了门外,不知道是个什么心情,你可能会说那装受限驱动呀,对了,装了过后还是这么一个效果,不知道是电脑问题还是自己的才疏学浅,望而却步了。希望有志之士帮忙小弟解决 这个问题,重塑加入UBUNTU信心,谢谢了!!!

PS:小弟的电脑配置为lenovo Y530.T8400,2G内存,NVIDIA 9500M G。

Thanks

LZ不要扔了UBUNTU,这么多热心兄弟帮你,再说从中也能学到不少东西呢。
一起学习吧,本牛也是头小白。


_________________
一头老牛|一辆破车
豁牙露齿|辕短板烂
眼瞎腿瘸|轴细轮歪
皮瘦毛长|四面漏风
love ubuntu, love linux, love others, love all
http://forum.ubuntu.org.cn


页首
 用户资料  
 
14 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 20:01 
头像

注册: 2007-05-06 8:19
帖子: 7433
送出感谢: 0 次
接收感谢: 4
一定要拿得起放得下


页首
 用户资料  
 
15 楼 
 文章标题 : Re: UBUNTU,拿起你又想再次放下
帖子发表于 : 2009-03-04 20:19 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
偶燕过留言


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译