求助 :新立报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保

系统安装、升级讨论
回复
hot1232
帖子: 5
注册时间: 2009-03-08 8:47
送出感谢: 0
接收感谢: 0

求助 :新立报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保

#1

帖子 hot1232 » 2009-03-08 12:46

我 在 安装完软件 更新后在打开新立得后 就 出现一下 内容

Could not calculate the upgrade

A unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。'

该怎么解决?我的系统是8.10的,刚装完,装了eva和scim pinyin
等各位 大虾指导。。。。 :em06
hot1232
帖子: 5
注册时间: 2009-03-08 8:47
送出感谢: 0
接收感谢: 0

Re: 求助 :新立报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保

#2

帖子 hot1232 » 2009-04-24 19:28

sudo rm -f /var/lib/apt/lists/lock /*只是应为这个文件的存在,强制删除后,重启APT就好了,反正我的就这样弄好了
nemo_lian
帖子: 3
注册时间: 2010-08-22 0:49
送出感谢: 0
接收感谢: 0

Re: 求助 :新立报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包

#3

帖子 nemo_lian » 2010-10-12 23:51

我的在10.04升级到10.10无法计算升级时也这样:

An unresolvable problem occurred while calculating the upgrade:
E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

如果这些都不可用,请报告这个对于“update-manager“包的软件错误,并把目录 /var/log/dist-upgrade/ 下面的文件包含到错误报告里面。
xjjaizmy
帖子: 11
注册时间: 2009-07-07 22:36
送出感谢: 0
接收感谢: 0

Re: 求助 :新立报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包

#4

帖子 xjjaizmy » 2011-04-22 9:38

我也遇到同样到问题,10.04升10.10出现上面到问题。我把论坛上搜到到方法都做了一下:
1.sudo rm -f /var/lib/apt/lists/lock
2.搜索所有和 libdrm-nouveau1 有关的项,然后装上。
结果还是出现上面到问题。后来我换了一个源就好了。成功升级。
说明一下:我本来到源是台湾里到第一个源debian,升级不了。后来换成台湾到第二个源就ok了
头像
Jessicau
帖子: 330
注册时间: 2010-04-28 13:33
送出感谢: 0
接收感谢: 1 次

Re: 求助 :新立报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包

#5

帖子 Jessicau » 2011-07-27 15:45

我是通过换源解决的,换的sohu
回复

回到 “系统安装和升级”