装不了GTK请高手来看下

系统安装、升级讨论
回复
vaqeteart
帖子: 2
注册时间: 2009-03-02 17:32
送出感谢: 0
接收感谢: 0

装不了GTK请高手来看下

#1

帖子 vaqeteart » 2009-03-09 16:45

我用的是UBUNTU 8.04发行版,我想安装GTK编译环境,gcc能顺利安装,可gnome-core-devel装不起来,我已经最大限度地安装了它的依赖库,剩下的就无法安装了,以下是我安装和出错的具体信息:
$ sudo apt-get install gnome-core-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libaudiofile-dev (>= 0.2.6) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 1:2.22.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnome2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libeel2-dev (>= 2.20.0) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.22.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.20.3) 但是它将不会被安装
依赖: python-gnome2-desktop-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.18.2) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.20.0) 但是它将不会被安装
依赖: libgweather-dev (>= 2.22.2) 但是它将不会被安装
依赖: libsoup2.4-dev (>= 2.4.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.20.0) 但是它将不会被安装
依赖: libtotem-plparser-dev (>= 2.22.3) 但是它将不会被安装
依赖: python-gnome2-dev (>= 2.22.0) 但是它将不会被安装
依赖: python-gobject-dev (>= 2.14.2) 但是它将不会被安装
依赖: python-gtk2-dev (>= 2.12.1) 但是它将不会被安装
E: 无法安装的软件包
高手帮忙一下,请慎重回答。谢谢!!
头像
lerosua
论坛版主
帖子: 8455
注册时间: 2007-11-29 9:41
送出感谢: 0
接收感谢: 0
联系:

Re: 装不了GTK请高手来看下

#2

帖子 lerosua » 2009-03-09 17:26

代码: 全选

pkg-config gtk+-2.0 --cflags --libs
你执行上面命令有结果,那就是说你已经有gtk+编译环境了,你装的那个东西是gnome编译环境
头像
lerosua
论坛版主
帖子: 8455
注册时间: 2007-11-29 9:41
送出感谢: 0
接收感谢: 0
联系:

Re: 装不了GTK请高手来看下

#3

帖子 lerosua » 2009-03-09 17:27

你的软件装不上,有依赖问题,使用图形界面的新立得,它会比较好地解决依赖问题
回复

回到 “系统安装和升级”