当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-01 22:28 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我装的是两系统,先装XP后装ubnutu,ubnutu8。04装的是试用版。(因为是菜鸟,所以先试用了)
我装了QQ也装了EVA,但是都有一个共同点,就是输入不了中文。只能输入英文。。。。。我装系统好几天,就是中文不能用。在网上用过很多办法了。
我先是
$sudo apt-get install im-switch libapt-pkg-perl fcitx
$im-switch -s fcitx
都说是最新版本了
还是输入不了中文。

后来装了EVA
两用这个命令:
$sudo apt-get install scim qtimm
可以用中文输入了,但是只能是EVA可以中可以用中文输入,QQ却不能中用中文。
今天早上开机,发现fcitx这个中文输入法出来了,但是我用的是五笔,拼音不用会,而且有一个问题,就是不管我什么办,都只能用fctix或是英文输入了。(包括EVA上也一样)所以就把fcitx用命令给删了。
没有fcitx后,我发现我的EVA也不可以用系统原来带的五笔输入了。
这是什么回事啊。。。。第一次装ubnutu,为的是冲3D效果来的,但是后来为了工作,不用QQ不行啊。QQ不能用中文输入真的是一件大难事啊。。。。。
各位ubnutu前辈们,请抽出一点时间来帮帮我吧。
要不然我就得切回到XP去工作了。。。。好难过啊。。。


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-01 23:03 
头像

注册: 2006-10-10 9:40
帖子: 1122
送出感谢: 1
接收感谢: 0 次
QQ对话框右键 SCIM中的挨个试试


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-01 23:42 

注册: 2007-10-20 1:09
帖子: 50
地址: 中国
送出感谢: 0 次
接收感谢: 0 次
:em06 CTRL+空格?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 0:00 
头像

注册: 2009-03-31 20:23
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
貌似要加个 scim-bridge


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 0:03 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
前面两位大哥的办法都不行,那个scim-bridge怎么加法


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 0:56 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
这个问题有人能解决吗,不过我刚才弄了一下,我发现怎么中文输入EVA了,就是用FCITX。
做法是这样的。
$ sudo apt-get install fcitx
$ sudo apt-get install scim qtimm
$ sudo apt-get install scim-bridge
$ fcitx&
调出fcitx后,可以用ctrl+shift切换输入拼音,繁体,简体,五笔。。
这样EVA就可以用五毛中文输入了。
可惜啊,,,,QQ还是不能用FCITX。我也不明白为什么。
哪位大哥大姐们帮帮我啊。


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 9:14 
头像

注册: 2009-03-31 20:23
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
qinqiong 写道:
这个问题有人能解决吗,不过我刚才弄了一下,我发现怎么中文输入EVA了,就是用FCITX。
做法是这样的。
$ sudo apt-get install fcitx
$ sudo apt-get install scim qtimm
$ sudo apt-get install scim-bridge
$ fcitx&
调出fcitx后,可以用ctrl+shift切换输入拼音,繁体,简体,五笔。。
这样EVA就可以用五毛中文输入了。
可惜啊,,,,QQ还是不能用FCITX。我也不明白为什么。
哪位大哥大姐们帮帮我啊。

弱弱的问一句:这个FCITX智能化不?我还没有用过呢 想找个智能点的来输入 scim有点难缠


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 9:28 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
很智能啊。你可以自己按我上面写的在终端输入:$ sudu apt-get install fcitx得到FCITX。最后再弄一个$sudo apt-get install scim qtimm


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 10:04 
头像

注册: 2006-12-17 13:34
帖子: 1818
地址: 武汉
送出感谢: 1
接收感谢: 0 次
http://forum.ubuntu.org.cn/viewtopic.php?f=50&t=155281
话说在我这里没有这个问题的
代码:
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
export HISTCONTROL=ignoredups
# ... and ignore same sucessive entries.
export HISTCONTROL=ignoreboth

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
   # We have color support; assume it's compliant with Ecma-48
   # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
   # a case would tend to support setf rather than setaf.)
   color_prompt=yes
    else
   color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD/$HOME/~}\007"'
    ;;
*)
    ;;
esac

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

#if [ -f ~/.bash_aliases ]; then
#    . ~/.bash_aliases
#fi

# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ] && [ -x /usr/bin/dircolors ]; then
    eval "`dircolors -b`"
    alias ls='ls --color=auto'
    #alias dir='ls --color=auto --format=vertical'
    #alias vdir='ls --color=auto --format=long'

    #alias grep='grep --color=auto'
    #alias fgrep='fgrep --color=auto'
    #alias egrep='egrep --color=auto'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
fi
export XMODIFIERS="@im=fcitx"
export GTK_IM_MODULE=xim
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx

家目录下面建个新文件 .bashrc 把上面的东西复制进去 然后重启X看看


_________________
人生长恨水长东;
远近高低各不同.


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 11:32 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的代码,但是还是没有用。我的机子装的是64位的。大家看一样是不是跟这个有关啊。


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 11:44 
头像

注册: 2007-11-28 5:39
帖子: 358
送出感谢: 0 次
接收感谢: 0 次
建議你用32bit的.少很多問題.我也是用fcitx,樓主的問題都沒有遇到過.應該是32bit的關係.


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 12:37 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我只有64位的光盘啊,如果下载的话,要在硬盘上按装,我也没有刻录机,真的好难啊,而且我用的是双系统,如果我下载一个32位的版本,也不知道哪个32位的版本才可以不会删去我原本机子上的数据,就可以直接装。这些都好麻烦,我现在只有64位的光盘,大家讲一下,有别的办法解决吗。


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 13:11 

注册: 2008-10-01 19:49
帖子: 410
送出感谢: 0 次
接收感谢: 0 次
用QQ的话要装些QT库。好像是scim-qt。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 13:38 

注册: 2009-04-01 17:55
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
$sudo apt-get install scim-qtimm不就是装了qt了吗。
还是再装吗。
装QQ我是在官网下的DEB包,他们说是32位的啊,我的系统装的是64位的,所以装不了DEB包,我只能用最通用的解压就可以用的QQ。但是就是输入不了中文。


_________________
认为自己是菜鸟。。。。。但是做事不会菜鸟。。。


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 救命啊!菜鸟要死了!除了聊天工具不能用中文,别的都可以用中文输入,这是为什么。。。。
帖子发表于 : 2009-04-02 13:39 
头像

注册: 2007-06-13 15:57
帖子: 12567
地址: 在他乡
送出感谢: 50
接收感谢: 87
禁止聊天 :em05
你右键选择一下X输入法不就完了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译