硬盘安装9.04 grub 无引导标签??????

系统安装、升级讨论
回复
openatone
帖子: 160
注册时间: 2007-12-03 13:57
送出感谢: 0
接收感谢: 0

硬盘安装9.04 grub 无引导标签??????

#1

帖子 openatone » 2009-04-02 13:27

我的硬盘是三星250G硬盘,已经有三个XP分区,然后又分了/BOOT 200M EXT3, / 5G EXT3 ,/home 14G EXT4
硬盘安装完成9.04 bate 后到了GRUB 那里只显示引导其他 XP 和 内存测试的选项  ????没有引导系统的选项。
打开 MENU。1ST 文件 发现如下内容 ??

## ## End Default Options ##

title Ubuntu jaunty (development branch), memtest86+
uuid cbb50a8b-345e-41b4-9ad0-660b8ba5289e
kernel /memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
rootnoverify (hd0,0)
savedefault
makeactive
chainloader +1

打开GRUB 目录发现少了vmlinuz 开头的文件 ?????
如附件图所示,请教高手是什么问题??
原来以为是EXT4r的原因,只分着 / 和交换分区,后来按要求改成了 /boot / /home
而且把 /  分区也设置成EXT3都不行????
附件
grub.png
openatone
帖子: 160
注册时间: 2007-12-03 13:57
送出感谢: 0
接收感谢: 0

Re: 硬盘安装9.04 grub 无引导标签??????

#2

帖子 openatone » 2009-04-02 15:05

会不会是因为引导系统太靠后了??无法引导??柱面限制的问题??
openatone
帖子: 160
注册时间: 2007-12-03 13:57
送出感谢: 0
接收感谢: 0

Re: 硬盘安装9.04 grub 无引导标签??????

#3

帖子 openatone » 2009-04-07 0:10

没有人遇到我这样的问题吗??????????
头像
wangdu2002
帖子: 13284
注册时间: 2008-12-13 19:39
来自: 物华天宝人杰地灵
送出感谢: 1 次
接收感谢: 6 次

Re: 硬盘安装9.04 grub 无引导标签??????

#4

帖子 wangdu2002 » 2009-04-07 0:16

有可能是Bios137GB的限制。重新整下分区吧! :em04
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

Re: 硬盘安装9.04 grub 无引导标签??????

#5

帖子 hcym » 2009-04-07 0:22

要手动安装grub

看wiki,找分区的UUID
openatone
帖子: 160
注册时间: 2007-12-03 13:57
送出感谢: 0
接收感谢: 0

Re: 硬盘安装9.04 grub 无引导标签??????

#6

帖子 openatone » 2009-04-09 18:20

重新下载了DVD 版。然后安装时把BOOT分成 EXT2文件系统,安装成功,不知道是因为EXT2的原因,还是因为CD版本的问题?
回复

回到 “系统安装和升级”