当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-10 14:34 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
apt-get install -f 出现下列提示:

正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
libperl5.10: 依赖: perl-base (= 5.10.0-11.1ubuntu2) 但是 5.10.0-19 已经安装了
perl: 依赖: perl-base (= 5.10.0-11.1ubuntu2) 但是 5.10.0-19 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系

之前perl-base是手动升级的,过新了……

之前用的是学校的更新源,软件更新基本瘫痪,有错误
现在只保留官方更新,稍微好一点,但上面两个perl和libperl还是损坏状态

搜过类似的问题,都没有人回答
现在发帖求助,有人知道该怎么办么?

谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-10 14:48 
头像

注册: 2008-06-23 15:19
帖子: 3030
地址: 北欧某国
系统: ���������
送出感谢: 21
接收感谢: 6
更换一下软件源试试,选择一个统一的、比较全的软件源,然后再运行 apt=get install -f,也许有用。


_________________
http://noie.name 网站改版中。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 13:57 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
谢谢答复!

还有比主服务器更新的么?是什么?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 14:20 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
Maybe your software repository version doesn't match your OS. please check your sources.list. Or configure your repository via GUI tool.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 15:50 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
thank you for your answer
that's my source.list below
i couldn't find anything wrong


# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.


## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://cn.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu intrepid partner
# deb-src http://archive.canonical.com/ubuntu intrepid partner

# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu intrepid-security universe
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
# Line commented out by installer because it failed to verify:
# deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
# Line commented out by installer because it failed to verify:
# deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
# deb http://ftp.sjtu.edu.cn/ubuntu/ intrepid main multiverse restricted universe
# deb http://debian.ustc.edu.cn/ubuntu/ intrepid main multiverse restricted universe
# deb http://ubuntu.uestc.edu.cn/ubuntu/ intrepid main multiverse restricted universe
# deb ftp://ubuntu.realss.cn/ubuntu/ intrepid main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ intrepid universe main restricted
deb http://security.ubuntu.com/ubuntu/ intrepid-security universe main restricted
deb http://archive.ubuntu.com/ubuntu/ intrepid-updates universe main restricted
deb http://archive.ubuntu.com/ubuntu/ intrepid-proposed universe main restricted


but i noticed the line: "it failed to verify"
is there anything wrong with it?

or maybe i misunderstand your words?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 16:27 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
ok
i got it

选中perlbase,选择强制版本,downgrade到以前的版本即可


3Q all the same


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot], Sogou [Spider] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译