当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件更新错误
帖子发表于 : 2009-04-10 22:00 

注册: 2006-09-21 21:16
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
在软件更新过程中,出现程序崩溃,后一直无法装别的软件,错误提示基本上就是下面所列,呼唤高手出现,帮小弟解决这个大难,都大半年了

baiyj27@baiyj27-desktop:~$ sudo apt-get install gcc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
gcc 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 5 个软件未被升级。
有 11 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 python2.5 (2.5.1-0ubuntu1) ...

(update-desktop-database:6340): GLib-CRITICAL **: g_key_file_get_string_list: assertion `group_name != NULL' failed
Segmentation fault (core dumped)
dpkg:处理 python2.5 (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 python 的配置工作不能继续:
python 依赖于 python2.5 (>= 2.5.1);然而:
软件包 python2.5 还没有被配置。
dpkg:处理 python (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 python-central 的配置工作不能继续:
python-central 依赖于 python (>= 2.4.3-10);然而:
软件包 python 还没有被配置。
dpkg:处理 python-central (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 kdelibs-data (3.5.6-0ubuntu14) ...

(update-desktop-database:6354): GLib-CRITICAL **: g_key_file_get_string_list: assertion `group_name != NULL' failed
Segmentation fault (core dumped)
dpkg:处理 kdelibs-data (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 lsb-release 的配置工作不能继续:
lsb-release 依赖于 python;然而:
软件包 python 还没有被配置。
dpkg:处理 lsb-release (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 launchpad-integration 的配置工作不能继续:
launchpad-integration 依赖于 python-central (>= 0.5.8);然而:
软件包 python-central 还没有被配置。
launchpad-integration 依赖于 lsb-release;然而:
软件包 lsb-release 还没有被配置。
dpkg:处理 launchpad-integration (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 kdelibs4c2a 的配置工作不能继续:
kdelibs4c2a 依赖于 kdelibs-data (>> 4:3.5.6);然而:
软件包 kdelibs-data 还没有被配置。
kdelibs4c2a 依赖于 kdelibs-data (<< 4:3.5.7);然而:
软件包 kdelibs-data 还没有被配置。
kdelibs4c2a 依赖于 launchpad-integration;然而:
软件包 launchpad-integration 还没有被配置。
dpkg:处理 kdelibs4c2a (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 eva 的配置工作不能继续:
eva 依赖于 kdelibs4c2a (>= 4:3.5.5-1);然而:
软件包 kdelibs4c2a 还没有被配置。
dpkg:处理 eva (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 mplayer (1.0~rc1-0ubuntu9) ...

(update-desktop-database:6359): GLib-CRITICAL **: g_key_file_get_string_list: assertion `group_name != NULL' failed
Segmentation fault (core dumped)
dpkg:处理 mplayer (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 mplayer-fonts 的配置工作不能继续:
mplayer-fonts 依赖于 mplayer;然而:
软件包 mplayer 还没有被配置。
dpkg:处理 mplayer-fonts (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 mozilla-mplayer 的配置工作不能继续:
mozilla-mplayer 依赖于 mplayer (>= 1.0~pre5);然而:
软件包 mplayer 还没有被配置。
dpkg:处理 mozilla-mplayer (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
python2.5
python
python-central
kdelibs-data
lsb-release
launchpad-integration
kdelibs4c2a
eva
mplayer
mplayer-fonts
mozilla-mplayer
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 软件更新错误
帖子发表于 : 2009-04-10 22:03 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
好象是要装build-essentil的,Wiki有一串的GNU编译工具链要安装的包的一键命令的。 :em06


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译