当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 13:27 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
根据G到的下面内容安装:
在U盘上安装Ubuntu 8.04的方法
要求:
1、4GU盘

2、Ubuntu 8.04安装光盘

风险:
1、损坏U盘、丢失U盘数据

2、如果安装过程中错选硬盘而非U盘将会丢失硬盘数据

安装过程:
1、下载Ubuntu 8.04并刻录光盘

2、由Ubuntu 8.04光盘引导启动安装

3、按安装提示进行安装,在安装的第四步--“选择硬盘”时一定要选择“Guided - use entire disk”

4、继续安装,在安装的第七步--“准备安装”时点击“高级”,在选项卡里确认选择的是U盘,继续安装

5、重起。

---------------------
安装过程一切顺利,该注意的都注意了,接下来重启

启动菜单有显示U盘的8.04.1-2.6.24.19 和硬盘上的XP与8.04.2-2.6.29

但是启动U盘的系统显示:ERROR 15:FILE NOT FOUND

硬盘上的8.04.2也进不去,提示:ERROR 17:CONNOT MOUNT SELECTED PARTITION,拔掉U盘重启可以顺利进入硬盘上的系统。

这个该怎么处理呢?


最后由 躺在桌子上 编辑于 2009-04-14 13:48,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 13:32 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
估计要改一下menu.lst吧?你装的时候是sdb之类的,现在改成sda?看看一只眼的那个grub错误大全吧,Call 一只眼放狗 :em06


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 13:32 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
找下prayaya,专门的移动Ubuntu。 :em04
搜索下论坛也是个好办法,大把贴子(首先确认你的主板和U盘支持USB启动才行)。 :em06
你的步骤安装前,把内置硬盘断掉电源,只接U盘,就可以了。这样哥伦布会自动装到U盘上,并生成正常的启动文件。 :em01
hd0,0


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


最后由 wangdu2002 编辑于 2009-04-14 13:58,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 13:54 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
U盘上的MENU.LST

## ## End Default Options ##

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd2,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=c8819a1c-f92c-465d-8c29-aa6ae36526d4 ro quiet splash locale=zh_CN
initrd /boot/initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
root (hd2,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=c8819a1c-f92c-465d-8c29-aa6ae36526d4 ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.04.1, memtest86+
root (hd2,0)
kernel /boot/memtest86+.bin
quiet

****************************************

我把其中的root (hd2,0) 改成HD1 看看怎么样。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 14:01 
头像

注册: 2007-02-18 19:33
帖子: 2180
地址: lyric.im
系统: OSX
送出感谢: 0 次
接收感谢: 1
http://www.sxnsx.com/install-linux-to-a-u-disk/


_________________
既然你诚心诚意地问了
我就大慈大悲地告诉你
为了防止世界被破坏
为了维护世界的和平
贯彻爱与真实的罪恶
可爱而又迷人的反派角色
武藏,小次郎
我们是穿越银河的火箭队,白洞白色的明天在等着我们。就是这样!!喵~~


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 14:07 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
hd2 改成hd0看看 :em06


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 14:15 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
我把其中的root (hd2,0) 改成root (hd0,0)

现在可以正常启动了

但是直接进入ROOT用户,字符界面。

现在继续研究。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 将8.04装到U盘的问题
帖子发表于 : 2009-04-14 19:44 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
我把U盘重新安装了一下,上一次分区是用的使用整个硬盘,选择U盘,他自己分的,现在我手动分区,重装,顺利进入8.04图形界面,一切没有问题.

但是回家后问题来了,怎么设置都不能启动,我把BIOS的启动项都改成了USB设备,还是不行,一直启动XP.

后来开机时按F8,选择启动设备,选择U盘,然后屏幕上显示GRUB和一个闪烁的光标就不动了,

不会吧,我在办公室可以顺利从U盘启动的,说明GRUB应该没有问题啊,现在家里没有LINUX的机器,XP又不能看U盘里的文件,真是郁闷啊.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译