当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 19:47 

注册: 2009-04-24 19:39
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的8.10在线更新的9.04,中间好像没啥问题,两小时下载安装完要重启
然后问题就来了
登陆界面好久alt+F2说是waiting for root file system,等了一会就是出错了 好像是什么uuid***
怀疑是menu.lst的问题,用光盘启动进去检查了分区,也没有问题,怎么就找不到启动文件了呢?
有没有人有这样的问题啊?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 20:05 
头像

注册: 2009-04-23 13:27
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题,早上升级了一早上,中午报错,下午想上来说,结果论坛挂掉了,只有重新装。我重新装只花了20多分钟,但重新配却花了一下午,哎。。。新版本很多问题厄


_________________
--------------让我们都来Linux吧!---------------
****************I'm Linux****************


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 20:14 

注册: 2009-04-24 19:39
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
实在不想重新装啊
配置多难弄啊
有没有高手知道的,帮帮忙


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 20:48 

注册: 2008-11-30 21:57
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我用硬盘装9.04安装好后 :em11 ,重起几次想看看9.04的速度 :em11
结果就出现问题了,也是进入到BusyBox :em20
现在反而出现grub error 11的错误。下午想重装到现在都还没装成功 :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 22:02 
头像

注册: 2008-12-07 20:47
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我也一样。
之前是在AHCI模式的SATA硬盘上安装的8.10,没遇到什么状况。升级9.04之后第一次启动就和楼主一样的情况。
应该是找不到硬盘了,怀疑是AHCI驱动从内核中被拿走了,希望能折腾好,不想再重装了。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 22:18 
头像

注册: 2009-04-23 13:27
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
UUID错误进入busybox,这个问题还没看到正确的解决方法,迫不得已下午重装了,到现在为止配置还没有完全搞定


_________________
--------------让我们都来Linux吧!---------------
****************I'm Linux****************


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 22:26 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
:em06


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-24 22:42 

注册: 2009-04-24 19:20
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
:em20 同样问题,期待解答


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 11:04 

注册: 2008-08-09 10:03
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我也有这个问题。。。。唉。烦啊。。。。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 12:35 

注册: 2009-04-24 19:39
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
怎么还没有人告诉我啊 再等不到只能重装了~~~~~~~~~~ :em05 :em05 :em20


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 12:59 

注册: 2008-11-30 21:57
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
艾纽克斯 写道:
UUID错误进入busybox,这个问题还没看到正确的解决方法,迫不得已下午重装了,到现在为止配置还没有完全搞定



你说的问题 昨天下午我也遇过,好像可以用root =/dev/sdxx 解决


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 13:03 

注册: 2009-04-24 19:39
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
光盘启动 进入命令行
ls -l/dev/disk/by-uuid
显示uuid******/~~/sda*
这些都没有问题,跟menu.lst里的root=内容是一样的


最后由 atlasma 编辑于 2009-04-25 13:09,总共编辑了 1 次

页首
 用户资料  
 
13 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 13:06 

注册: 2008-08-09 10:03
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
atlasma 写道:
光盘启动 进入命令行
ls -l/dev/disk/by-uuid
显示uuid******/~~/sta*
这些都没有问题,跟menu.lst里的root=内容是一样的



那你还好了。我根本就不存在/dev/disk目录。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 13:07 

注册: 2008-08-09 10:03
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
ben0ubt 写道:
艾纽克斯 写道:
UUID错误进入busybox,这个问题还没看到正确的解决方法,迫不得已下午重装了,到现在为止配置还没有完全搞定



你说的问题 昨天下午我也遇过,好像可以用root =/dev/sdxx 解决




这个不知道行不行,但是麻烦在不知道是sd几,总不能一个一个试下去吧。。。。


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 升级9.04后无法启动,busybox?
帖子发表于 : 2009-04-25 13:40 
头像

注册: 2008-12-07 20:47
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
之前的新立得自动升级肯定是有问题的,它把原来8.10下的几个内核都删了,替换为一个2.6.27-11版本,而这个内核无法识别出我的硬盘。9.04的内核2.6.28-11并没有成功安装,grub菜单中也没有加入9.04的启动选项。

因为系统已经无法引导,只好用liveCD进入系统,之前新立得已经把9.04的源加入第三方源。就用chroot方法手动升级kernel到2.6.28-11,重启后grub中的菜单也出现了9.04。

具体的方法是,liveCd启动后, mount硬盘的根目录/dev/xxx
mount /dev/xxx /mnt
mount --bind /proc /mnt/proc
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys

然后sudo chroot /mnt /bin/bash
在新的命令提示符下,
apt-get update
apt-get install linux-image-2.6.28-11-generic

终于可以启动了,不过目前的状况是,无法出现X登录窗口,只能在terminal登录。

之前用另外一个方法似乎也可以:用liveCD启动,升级内核需要的文件从光盘拷贝到硬盘中,然后自己手工在grub增加这个选项。另外拷贝/boot, /cdrom/casper,/lib/modules/2.6.28-11-generic目录下的一些文件到硬盘上。结果是一样,还是无法显示X登录。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译