当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu9.04升级内核到2.6.30。解决nvidia180.44驱动编译问题
帖子发表于 : 2009-04-25 15:08 

注册: 2007-08-01 16:51
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
补充:升级可能会出现很多未知问题。慎用
1.下载内核安装
引用:
下载地址
http://kernel.ubuntu.com/~kernel-ppa/ma ... .6.30-rc3/
下载headers和image顺序安装。

2.安装时image时显示ndivia编译错误
引用:
但不影响内核升级。只是nvidia驱动的编译错误。这个时候不要重启,做ndivia的准备工作

3.nvidia准备
引用:
3.1.下载驱动
http://ru.download.nvidia.com/XFree86/L ... 4-pkg2.run
注,这个是64位系统的安装。32位的同学参照一下自行找一下。
3.2.打补丁。
代码:
# sh NVIDIA-Linux-x86_64-180.44-pkg2.run --extract-only
# cd NVIDIA-Linux-x86_64-180.44-pkg2/usr/src/nv/
# wget http://pavlinux.ru/nv/nvidia-x86_64-180.44-2.6.30-rc2.patch
# patch -p0 < nvidia-x86_64-180.44-2.6.30-rc2.patch
# cd ../../../

# ./nvidia-installer

最后一个命令是要在完全退出xserver的情况下才能安装。我不懂怎么退出。所以直接重启了。
4.安装
引用:
如果是直接重启的话,重启后就会提示驱动有问题
选择到后台模式
login以后,cd到刚才的目录
# ./nvidia-installer
然后看提示走就可以了
默认需要gcc4.2,但是我已经安装了4。3了。会警告,但是用4.3编译没有问题。

最后startx就ok啦
参考:
1.PATCH FOR 180.44 with kernel 2.6.30-rc2
http://www.nvnews.net/vbulletin/showthread.php?t=131597


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.04升级内核到2.6.30。解决nvidia180.44驱动编译问题
帖子发表于 : 2009-05-16 11:43 
头像

注册: 2008-07-23 19:06
帖子: 746
送出感谢: 0 次
接收感谢: 0 次
实践表明 185 和 2.6.30rc5 一样可用


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.04升级内核到2.6.30。解决nvidia180.44驱动编译问题
帖子发表于 : 2009-05-22 16:40 
头像

注册: 2008-10-14 21:54
帖子: 880
送出感谢: 0 次
接收感谢: 2
ftp://download.nvidia.com/XFree86/Linux-x86/180.60
下载180.60的显卡驱动。
装完2.6.30后进不去图形界面,
在命令行模式下,
sudo ./NVIDIA-Linux-x86-180.60-pkg1.run
装完就一切OK了。


_________________
地狱可以想象,天堂却无法描述。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译