当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-04-28 3:51 

注册: 2007-05-07 7:17
帖子: 136
送出感谢: 0 次
接收感谢: 7
ati最新的fglrx驱动9.4版本目前还不支持最新的2.6.29内核,所以安装的时候无法通过build阶段。
此方法适用于ati radeon系列显卡
目前的解决方式是修改源码,使其能够在最新的内核下编译通过,完成安装,

具体方式如下:

1, 首先你需要保证安装了对应的linux-header包,保证驱动可以找到对应头文件以完成编译。

2,在如下ati官方地址下载最新的ati fglrx 9.4驱动,
http://support.amd.com/us/gpudownload/l ... ng=English

3,下载我这里提供的patch文件
附件:
文件注释: patch
2.6.29.diff.tar [20 KiB]
被下载 183 次
, 下载后解压出里面的diff文件

4,输入命令 sudo /etc/init.d/gdm(kdm如果是kubuntu) stop关闭Xorg,

5, 输入命令sh ati-driver-installer-9-4-x86.x86_64.run, 来安装驱动, 该步骤最后会失败,但是会把需要的驱动模块源码拷贝到相应文件夹下。你可以在
/usr/share/ati/fglrx-install.log 查看安装错误信息,你应该会发现其中记录了kernel module无法build。

6, 把上面的patch文件拷贝到根目录下:
cd /
sudo cp /path_of_diff/2.6.29.diff /
然后执行 patch -p0 < 2.6.29.diff , 该操作会利用diff文件中记录的修改信息修改/lib/modules/fglrx/build_mod文件夹中的驱动源码文件,

7, 进入/lib/modules/fglrx/build_mod 文件夹, cd /lib/modules/fglrx/build_mod ,
然后执行其中的make.sh文件 , sudo sh make.sh,如果build 失败, 请检查自己人品.

8, 如果build成功, 恭喜你,就快成功了, 进入上一层文件夹, cd .. 也就是/lib/modules/fglrx
执行其中的make_install.sh 进行安装, sudo sh make_install.sh,然后重启吧。

9, 应该没有问题了,如果依然黑屏,无法进入到登录界面,那应该是xorg.conf文件有问题,可以重启进入recovery 模式,就是不会启动图形界面的那个模 式。然后输入命令 aticonfig --initiale,会自动生成正确的xorg.conf,

这里我也附上我自己的xorg.conf文件作为参考,
附件:
文件注释: xorg.conf
xorg.conf.tar [10 KiB]
被下载 109 次

如果需要,不要直接copy, 需要把对应自己硬件的参数自己修改。

10, 再重启,应该显卡已经完美驱动了。输入glxinfo, 可以通过direct yes信息看到3d已经打开。 输入glxgears命令可以看3d显示FPS数,我这里新内核和新驱动使显卡性能有30%的提高。

bonne chance et bon courage, aller!!!!!!!!!!!!!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-04-28 17:23 

注册: 2007-05-07 7:17
帖子: 136
送出感谢: 0 次
接收感谢: 7
如果build失败,可以尝试9.2版本的fglrx


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-04-28 18:09 
头像

注册: 2008-04-08 14:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
记号 收藏! :em11


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-08 9:38 

注册: 2009-05-08 9:30
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
为什么我的9.04是内核为2.6.28的呢 是不是要升级内核?(已经成功安装,按照ati的指导pdf)
还有一个问题就是:在系统》系统管理》硬件驱动 中查看并未激活,可是用glxinfo查看显示3D已经启动,运行感觉也很流畅。
若是激活了,会怎么样?怎么查看驱动的版本?
我是个菜鸟,希望能耐心指教……谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-08 12:29 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
wangjining 写道:
为什么我的9.04是内核为2.6.28的呢 是不是要升级内核?(已经成功安装,按照ati的指导pdf)
还有一个问题就是:在系统》系统管理》硬件驱动 中查看并未激活,可是用glxinfo查看显示3D已经启动,运行感觉也很流畅。
若是激活了,会怎么样?怎么查看驱动的版本?
我是个菜鸟,希望能耐心指教……谢谢!

2.6.28是正常的,楼主是自己升级到29的内核的
硬件驱动里的驱动和你自己安装的官方驱动是两码事,存一即可,不能同时装


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-10 12:06 
头像

注册: 2007-04-30 11:05
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
:em06
留个记号


_________________
人法地,地法天,天法道,道法自然


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-10 12:10 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
啊,全屏呢??!! lz,试试dmesg看看,有没有关于fglrx的error。 xorg.0.log 里面的ww


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-10 22:13 

注册: 2009-05-04 17:34
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我的是ATI 4650显卡,也出现这个问题,请问从哪里能下载到2.6.29.2的头文件?

那个PATCH成功的话提示什么?

弄了两天了,编绎还是通不过~~~


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-11 8:44 

注册: 2008-11-01 16:45
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
留个记号备用


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-11 10:20 

注册: 2009-05-04 10:29
帖子: 121
送出感谢: 0 次
接收感谢: 0 次
先作个记号


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-15 16:54 

注册: 2006-04-20 20:32
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
mark :em11


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-15 21:42 

注册: 2009-05-15 21:30
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
先藏着 吧~...


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-20 0:07 

注册: 2008-03-05 13:25
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
那么同样的方法可以在30内核下使用吗?


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-20 19:45 

注册: 2007-05-07 7:17
帖子: 136
送出感谢: 0 次
接收感谢: 7
30的不知道,没测试过,

patch打成功后会显示哪些地方被修改了


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 2.6.29内核(ubuntu9.04)安装ati官方最新fglrx驱动(catalyst)无法成功的解决方式
帖子发表于 : 2009-05-21 13:35 
头像

注册: 2008-11-01 20:43
帖子: 17322
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
按个驱动有那么难吗? :em20


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译