当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-02 17:52 

注册: 2007-02-07 19:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
我是昨天才安装好9.04的,第一次使用ubuntu,以前没有用过linux,对这个系统我连菜鸟也算不上;

在windows中我一直用3.6每夜版的firefox,到ubuntu我也想用3.6 ,无奈论坛搜索半天也没找到让我这个菜鸟能看明白的教程,只好自己摸索,现在看来基本达到我的要求了,自己很满意 认为完美,先上一幅图:
附件:
Screenshot.png
Screenshot.png [ 186 KiB | 被浏览 947 次 ]



1、下载安装
下载最新的每夜版:http://stage.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
下载对应到linux版本即可,然后解压,将解压后到文件夹放到你自己想放到地方
2、运行程序
右键点击左上角面板上到firefox,选择浏览,定位到刚才解压后到firefox文件夹下的firefox文件(如:/home/user/soft/firefox/firefox),然后关闭;
3、中文化
首先下载本附件到中文包:
附件:
文件注释: 中文语言包
[zh-CN.jar](2009-05-02 18-18-34).tar.gz [131.84 KiB]
被下载 64 次

解压后copy到firefox/chrome目录下,在ff浏览器的地址栏输入about:config,在过滤器中输入general.useragent.locale,并修改它的值为 zh-CN,重启浏览器后就是中文版

4、修改扩展使其兼容新版firefox
打开firefox后发现很多扩展不兼容,现在需要修改firefox扩展到版本使其兼容3.6(有更简单的办法,但是个人认为这样彻底),这步是重点:
打开扩展所在的文件夹,比如我的:/home/我的用户名/.mozilla/firefox/jnp2qn1w.default/extensions (其中jnp2qn1w是随机到8位字符会有所不同),此文件夹下每个文件夹对应1个扩展,打开,我们需要修改install.rdf文件。
修改步骤:
修改文件权限(把带琐文件的写入权限打开):右键-权限,自己修改。然后用文本编辑器(root权限)打开,找到
<em:maxVersion>字段,有些有多个这样到字段,我们只需要修改firefox下的即可,举例:
<em:maxVersion>3.0b4pre</em:maxVersion>将其中的版本号修改为>=3.6后保存退出就可以了
修改后<em:maxVersion>3.6b4pre</em:maxVersion>
附件:
Screenshot-1.png
Screenshot-1.png [ 115.22 KiB | 被浏览 929 次 ]


把所有到扩展都修改一遍,重启firefox后所有到扩展都能在3.6版下使用,有些扩展由于长期没有更新会有些小问题,比如鼠标手势不显示轨迹,但是绝大部分都能正常使用


最后由 lusijin 编辑于 2009-05-04 13:47,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-02 19:03 

注册: 2007-02-07 19:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
占楼,准备上传些好用的扩展


最后由 lusijin 编辑于 2009-05-04 13:39,总共编辑了 1 次

页首
 用户资料  
 
3 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-02 19:59 

注册: 2007-11-08 19:35
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
我在用3.0.10
:em01


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-03 22:34 

注册: 2007-02-07 19:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
没人顶贴,没动力上传扩展拉


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-03 22:35 
头像

注册: 2007-12-08 23:33
帖子: 4088
地址: SCUT-guangzhou
送出感谢: 0 次
接收感谢: 0 次
不稳定把


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-03 22:37 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
顶下,刺激下楼主的积极性,顺便提醒楼主,U论坛子全是人精,不见兔子不撒鹰的。 :em03


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-03 22:47 
头像

注册: 2007-05-06 21:17
帖子: 362
送出感谢: 0 次
接收感谢: 0 次
有空试试~ :em11


_________________
Know Thyself


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-04 13:09 

注册: 2008-06-21 13:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
我也想要啊。。。我觉得这个3。09太慢了。。。他妈的


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 1:14 
头像

注册: 2008-08-25 18:57
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
lusijin 写道:
<em:maxVersion>字段,有些有多个这样到字段,我们只需要修改firefox下的即可,举例:
<em:maxVersion>3.0b4pre</em:maxVersion>将其中的版本号修改为>=3.6后保存退出就可以了
修改后<em:maxVersion>3.6b4pre</em:maxVersion>
附件:
Screenshot-1.png

把所有到扩展都修改一遍,重启firefox后所有到扩展都能在3.6版下使用,有些扩展由于长期没有更新会有些小问题,比如鼠标手势不显示轨迹,但是绝大部分都能正常使用

linux love smart kid。不过楼主还是走了弯路,一个个扩展修改最大兼容版本号不累吗?在about:config 里加上一条布尔项extensions.checkCompatibility 值为false,就可以把firefox的扩展兼容性检查关掉,一劳永逸不好吗


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 2:11 

注册: 2008-07-28 22:16
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
苹果虫 写道:
lusijin 写道:
<em:maxVersion>字段,有些有多个这样到字段,我们只需要修改firefox下的即可,举例:
<em:maxVersion>3.0b4pre</em:maxVersion>将其中的版本号修改为>=3.6后保存退出就可以了
修改后<em:maxVersion>3.6b4pre</em:maxVersion>
附件:
Screenshot-1.png

把所有到扩展都修改一遍,重启firefox后所有到扩展都能在3.6版下使用,有些扩展由于长期没有更新会有些小问题,比如鼠标手势不显示轨迹,但是绝大部分都能正常使用

linux love smart kid。不过楼主还是走了弯路,一个个扩展修改最大兼容版本号不累吗?在about:config 里加上一条布尔项extensions.checkCompatibility 值为false,就可以把firefox的扩展兼容性检查关掉,一劳永逸不好吗

or, nightly tester tools
印象中改成false之后还是有点小问题,于是就装上了ntt, 太久了,忘了。。。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 8:47 

注册: 2007-11-12 10:37
帖子: 189
送出感谢: 0 次
接收感谢: 0 次
每夜版有啥好处啊?
楼主不妨说说。
俺 孤陋寡闻,没听说过。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 12:38 

注册: 2007-02-07 19:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
引用:
linux love smart kid。不过楼主还是走了弯路,一个个扩展修改最大兼容版本号不累吗?在about:config 里加上一条布尔项extensions.checkCompatibility 值为false,就可以把firefox的扩展兼容性检查关掉,一劳永逸不好吗


这个我还是知道的,我不是说了吗,修改版本号彻底


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 12:40 

注册: 2007-02-07 19:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
[quote="xiaomiao"]每夜版有啥好处啊?
楼主不妨说说。
俺 孤陋寡闻,没听说过。[/quote]

就是喜欢做小白鼠的人喜欢干的事情

每夜版就是每天都有更新,可以不停的升级。有些新特性
但也会有新问题,新bug,对ff不熟悉的还是用正式版好


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 12:41 
头像

注册: 2009-04-14 13:18
帖子: 707
送出感谢: 0 次
接收感谢: 0 次
:em11 LZ很强大,刚开始用Ubuntu就开始自己找解决方法了,不像论坛上的某些NC,连网络都配置不好还好意思骂Ubuntu呢……


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 菜鸟写的教程:将firefox升级到3.6a1夜版,所有扩展继续有效、中文版,支持自动更新
帖子发表于 : 2009-05-05 22:43 
头像

注册: 2008-08-25 18:57
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
楼主改扩展版本号的方法有两个缺点
1:扩展升级后会被覆盖,又要再作功一次
2:未改过兼容版本的扩展无法安装,想要安装又要先作功
我不知道楼主管理几个扩展,如果像我装了50个,60%的扩展不兼容,要浪费多少无用功?
还是NTT 或 直接关闭兼容检查省事,不过NTT也是扩展,也有不兼容的时候


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译