当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 笔记本安装Ubuntu9.04遭遇的grub问题
帖子发表于 : 2009-05-05 13:08 

注册: 2009-05-01 17:14
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
我的笔记本是 HP Compad Presario CQ40-123
预装 C:盘 正版vista操作系统、 Z:盘 用于恢复为出厂设置的 恢复盘

安装完 Ubuntu9.04后 选“现在重启”
出现的grub如下:

Ubuntu 9.04,memtest86+
other operating system:
Windows Vista (loader)
Windows Vista (loader)

选 Ubuntu 9.04,memtest86+ ,则进入 memtest86+ v2.11。
选 Windows Vista (loader) (注释:上面第一个Windows Vista (loader)),则可进入 C:盘的vista系统。
而 Windows Vista (loader) (注释:上面第二个Windows Vista (loader)),我没选过,我认为会进入 Z:盘出厂恢复。


而之前我在虚拟机中vista系统上安装Ubuntu9.04出现的grub(我认为正确的grub)如下:

Ubuntu 9.04,Kernel 2.6.28-11-generic
Ubuntu 9.04,Kernel 2.6.28-11-generic (recovery mode)
Ubuntu 9.04,memtest86+
other operating system:
Windows Vista (loader)

选 Ubuntu 9.04,Kernel 2.6.28-11-generic ,则进入 Ubuntu9.04。
而 Ubuntu 9.04,Kernel 2.6.28-11-generic (recovery mode),我没选过,应该是 Ubuntu9.04 恢复模式,
在 第一项Ubuntu 9.04,Kernel 2.6.28-11-generic 进入不了时使用。
Ubuntu 9.04,memtest86+同样应该是 内存测试 ,我没在虚拟机中选择过。
选 Windows Vista (loader),则进入 虚拟机中安装的 vista系统。


我的真实的物理机进入不了Ubuntu9.04为什么怎么解决请高手帮忙 回复详细一点


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 笔记本安装Ubuntu9.04遭遇的grub问题
帖子发表于 : 2009-05-05 15:11 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
好复杂,我认为那个恢复盘可以直接割掉...装windows,再装ubuntu
...那样就解决了...可能回答不令您满意,但这是我做过的...给您一个建议而已..顺便说下,windows7 RC今天出来...


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 笔记本安装Ubuntu9.04遭遇的grub问题
帖子发表于 : 2009-05-05 15:18 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
引用:
windows7 RC今天出来


一周前装上了.... :em04


_________________
Grub2 基础教程


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 笔记本安装Ubuntu9.04遭遇的grub问题
帖子发表于 : 2009-05-05 18:35 

注册: 2009-05-01 17:14
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
wowoto 写道:
好复杂,我认为那个恢复盘可以直接割掉...装windows,再装ubuntu
...那样就解决了...可能回答不令您满意,但这是我做过的...给您一个建议而已..顺便说下,windows7 RC今天出来...

你指的是 装xp,还是win7啊?我也想过,不过xp硬件兼容不好,比如:触摸板就不能驱动,等等...
你也是hp,还是别的品牌笔记本?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 笔记本安装Ubuntu9.04遭遇的grub问题
帖子发表于 : 2009-05-05 19:50 

注册: 2008-06-21 13:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
这个原因可能是因为有隐藏的系统备份分区造成的,你最好把你的menu。lst的内容发上来,分析一下就知道了。
从你发上来的资料来看,你的9。04应该在grub里没有指定内核和启动路径。
如果我可以帮到你,你就发邮件给我吧。linguohualove@gmail.com
本人不是高手,但玩各种系统也有多年经验了。有可能帮到,但不一定。请不要砖头。呵呵
我现在的松下CF-T2笔记本用UBUNTU 9。04 非常爽,用ext4格式真的快了不少。呵呵


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 笔记本安装Ubuntu9.04遭遇的grub问题
帖子发表于 : 2009-05-07 19:20 

注册: 2008-09-18 9:46
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
和LZ同病相怜啊~求助解决方法哦~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot], Sogou [Spider] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译