当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-09 16:15 

注册: 2009-03-04 13:01
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
请问如何升级内核?
找了半天也没有找到Ubuntu下升级内核的教程,如果哪位如果能否告知一二。
谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-09 16:57 
头像

注册: 2008-07-21 9:44
帖子: 2371
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
把9.04的源添加到自己的源列表,然后
代码:
sudo apt-get update

之后在新立得里应该能找到最新的内核(ubuntu下的最新),标记安装就行了吧。

ps:觉得没有特意升级内核的必要。


_________________

My blog


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-09 22:58 

注册: 2008-02-17 22:29
帖子: 682
地址: 江苏
送出感谢: 1
接收感谢: 0 次
可以自己编译内核。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-09 23:17 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
fhc2007 写道:
把9.04的源添加到自己的源列表,然后
代码:
sudo apt-get update

之后在新立得里应该能找到最新的内核(ubuntu下的最新),标记安装就行了吧。

ps:觉得没有特意升级内核的必要。

这么搞恐怕不行 :em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-10 8:02 

注册: 2009-03-04 13:01
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
恩,楼上说的甚是。
我用下面的方法弄。

viewtopic.php?f=50&t=191637


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-10 9:37 

注册: 2009-03-04 13:01
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
升级到2.6.29.1之后:
1. glxgears 从 780 左右变为200左右(intel 915 集成显卡)
2. 无线网卡找不到了(IPW2200)
3. 不知道其他硬件有没有正常驱动上...

郁闷,装9.04 得了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-11 14:10 
头像

注册: 2007-11-28 5:39
帖子: 358
送出感谢: 0 次
接收感谢: 0 次
hoarej 写道:
升级到2.6.29.1之后:
1. glxgears 从 780 左右变为200左右(intel 915 集成显卡)
2. 无线网卡找不到了(IPW2200)
3. 不知道其他硬件有没有正常驱动上...

郁闷,装9.04 得了。


Intel 915在9.04的表現更"郁闷"吖。內核2.6.29.1跟Intel集顯有點小問題,用2.6.29.2就好了。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-11 14:21 

注册: 2008-10-31 15:41
帖子: 143
送出感谢: 0 次
接收感谢: 0 次
我用了两天的时间,把内核升到2.6.29.3,编译四次。第一次编译没修改任何配置,能够启动,但是不识别声卡。而且出来的内核超大。建议找找金步国先生的文章。
我主要参考了:
1、金步国先生翻译的资料:内核编译配置选项:http://lamp.linux.gov.cn/Linux/kernel_options.html
2、http://forum.ubuntu.org.cn/viewtopic.php?f=97&t=110461
还有一篇帖子,找不到了。
可惜我没做笔记。


_________________
Ubuntu 12.04 Gnome 3


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 我现在用的是8.04 LTS,请问如何升级内核?
帖子发表于 : 2009-05-11 22:06 

注册: 2009-03-04 13:01
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
TO:bhsqtm
问个弱一点的问题:内核非要自己编译吗?
另外,我从http://kernel.ubuntu.com/~kernel-ppa/mainline/ 下载的内核,安装了之后,不管是2.6.29.1还是2.6.29.2,都无法找到IPW2200无线网卡,并Intel 915集显超级慢。

TO:ellon
我的Intel 915在9.04 下的glxgears分数怎么比8.04高呢?
(确实在9.04下,i915显卡有点不对劲,特别是在2D)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译