当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 分辨率提示超出范围 怎么办。。。
帖子发表于 : 2009-05-10 17:22 

注册: 2009-05-10 12:20
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
我也不知道怎么回事 。开始事800*600的分辨率 。后来重启了一下 ,开机登陆界面变成1440*900的了。心里一阵激动。。。结果进了桌面,显示器就出现超出范围了、、、什么也看不见了,怎么办呀?

我事新手


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 分辨率提示超出范围 怎么办。。。
帖子发表于 : 2009-05-10 17:40 

注册: 2009-05-10 12:20
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
:em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 分辨率提示超出范围 怎么办。。。
帖子发表于 : 2009-05-10 18:26 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
n卡还是a卡阿,能进显卡的配置工具里么?


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 分辨率提示超出范围 怎么办。。。
帖子发表于 : 2009-05-10 18:31 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
你要是还能看到看到桌面,那就用那个系统里的显卡配置工具调回去就可以了
要是直接黑屏了,那就得去终端修改xorg.conf文件了

按下
代码:
Alt+Ctrl+F1
,进入命令行。
备份 X 配置文件
代码:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

用 vim 打开 /etc/X11/xorg.conf:
代码:
sudo vim /etc/X11/xorg.conf

在Section “Screen”段中添加如下子段:
代码:
SubSection “Display”
Depth 24
Modes “1024×768″ #(这里填入你想要的分辨率)
EndSubSection

vim里,点个a,是插入到光标后字符
输入完了之后按shift+q
看到左下角除了:这个符号之后,输入x,意思是保存并退出,如果单独保存是:w
保存退出后执行:
代码:
sudo /etc/init.d/gdm restart

重新启动图形界面


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 分辨率提示超出范围 怎么办。。。
帖子发表于 : 2009-05-11 8:00 

注册: 2009-05-10 12:20
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
kurai, 我弄好了~谢谢你哈!
我的显卡是n 7025的板载显卡 驱动我下了.run格式的 但是我不会装


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 分辨率提示超出范围 怎么办。。。
帖子发表于 : 2009-05-11 11:03 
头像

注册: 2009-04-17 10:42
帖子: 764
送出感谢: 0 次
接收感谢: 1
装显卡驱动,需要先卸载你当前的显卡驱动,然后切换到命令行,关闭x界面,装新版驱动,然后再打开x界面,我给你个流程,你试试~~

不过我是笔记本的移动版n卡,最新驱动是180,你的如果不是移动版的,应该是185吧?
装驱动的过程,可能跟你不一样,你自己研究下把,大体流程是差不多的,比如卸载驱动,关闭x界面命令等
先去硬件驱动里把显卡驱动remove
再去新力得里把
nvidia-glx-180
nvidia-glx-180-dev
就是库里,最新版本带着180.44的都卸载(我是本本显卡,所以默认最新驱动是180.44)
有一个nvidia-180-modaliases
因为别的版本的像71,173一类的,默认都在,所以这个包我没卸载
卸载完了,
就可以进行装新驱动的步骤了

然后切换到命令行模式:

代码:
ctrl+alt+f2


登录之后:

代码:
sudo /etc/init.d/gdm stop


这就关掉了xwin,
然后运行下好的显卡驱动

代码:
sudo sh ~/NVIDIA-Linux-x86-180.51-pkg1.run

ps:~/NVIDIA-Linux-x86-180.51-pkg1.run 是你的新版驱动所放的目录位置,比如你放到/home/NVIDIA-Linux-x86-180.51-pkg1.run
那名令就是:sudo sh /home/NVIDIA-Linux-x86-180.51-pkg1.run

如果不让运行,就修改这个文件的执行权限。如果不会用命令修改,那就在刚才图形界面的时候,右键权限里把允许执行勾上。
安装过程第一步提示是否卸载旧驱动,选yes,第二步提示说该驱动和内核不配,上网搜新版本,选no,即使选了yes也下不到合适的,要不然还编译什么阿~~~
然后一步是提示the cc version check,意思就是编译需要gcc4.2下进行,而 9.04是4.3的,选no是忽略版本继续,所以选no,
之后会蹦出几个copy不成功的条目,但是看文件名好像都跟180.44有关,具体是啥意思,我没仔细研究,因为之后,使用上是正常的。
然后就顺利的编译成功了,最后会提示,是否运行xorg的自动配置程序,在下次开机的时候自动运行x,选yes,好了,系统跳回命令行,驱动装完了。
这一部分可能跟你的不一样~~~
装完驱动之后:
在命令行运行:

代码:
sudo /etc/init.d/gdm strat


就可以启动xwin,如果有个nvdia的logo一闪而过,那就说明驱动安装成功了。


_________________
恨不死的阿弥陀,历尽千重罪,炼就不死心,来吧,一起配置Ubuntu
Ubuntu9.04配置手记


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译