当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件升级出现的 dpkg:依赖关系问题
帖子发表于 : 2009-05-27 18:25 

注册: 2007-03-21 12:12
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
ming@story:/var/cache/apt/archives$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 5 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 php5-cgi (5.2.6-2ubuntu4.2) ...
dpkg:处理 php5-cgi (--configure)时出错:
子进程 post-installation script 返回了错误号 10
正在设置 php5-cli (5.2.6-2ubuntu4.2) ...
dpkg:处理 php5-cli (--configure)时出错:
子进程 post-installation script 返回了错误号 10
dpkg:依赖关系问题使得 php5-gd 的配置工作不能继续:
php5-gd 依赖于 phpapi-20060613+lfs;然而:
未曾安装软件包“phpapi-20060613+lfs”。
软件包 php5-cli 提供了 phpapi-20060613+lfs,但是它还没有配置好。
软件包 php5-cgi 提供了 phpapi-20060613+lfs,但是它还没有配置好。
dpkg:处理 php5-gd (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 php5-mcrypt 的配置工作不能继续:
php5-mcrypt 依赖于 phpapi-20060613+lfs;然而:
未曾安装软件包“phpapi-20060613+lfs”。
软件包 php5-cli 提供了 phpapi-20060613+lfs,但是它还没有配置好。
软件包 php5-cgi 提供了 phpapi-20060613+lfs,但是它还没有配置好。
dpkg:处理 php5-mcrypt (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 pNo apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
hp5-mysql 的配置工作不能继续:
php5-mysql 依赖于 phpapi-20060613+lfs;然而:
未曾安装软件包“phpapi-20060613+lfs”。
软件包 php5-cli 提供了 phpapi-20060613+lfs,但是它还没有配置好。
软件包 php5-cgi 提供了 phpapi-20060613+lfs,但是它还没有配置好。
dpkg:处理 php5-mysql (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
php5-cgi
php5-cli
php5-gd
php5-mcrypt
php5-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 软件升级出现的 dpkg:依赖关系问题
帖子发表于 : 2009-05-27 18:50 

注册: 2007-03-21 12:12
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
好了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 软件升级出现的 dpkg:依赖关系问题
帖子发表于 : 2009-11-02 15:20 

注册: 2009-07-16 15:29
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
怎么处理的啊??
有没有什么办法?请说明。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译