当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法升级
帖子发表于 : 2009-06-18 12:01 
头像

注册: 2009-01-23 17:02
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
引用:
E: 未知的類型 '<!--',位於在來源列表 /etc/apt/sources.list.d/winehq.list 中的第 1 行

由于上述原因,无法自动升级,请见附图。这个问题怎样解决呢?谢谢!


:em20


附件:
Screenshot.png
Screenshot.png [ 7.99 KiB | 被浏览 486 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 12:03 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
删掉 ......第 1 行


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 12:05 
头像

注册: 2009-01-23 17:02
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
hcym 写道:
删掉 ......第 1 行

进不去/etc/apt/sources.list.d/winehq.list 其实系统只有我在用,我就是管理员,但系统似乎认为我是客人用户。用哪个命令呢(完整式)?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 12:22 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
代码:
sudo gedit /etc/apt/sources.list.d/winehq.list

代码:
sudo nano /etc/apt/sources.list.d/winehq.list

代码:
sudo ...


_________________
Grub2 基础教程


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 12:34 
头像

注册: 2009-01-23 17:02
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
引用:
無法初始化套件資訊

初始套件資訊時發生不能解決的問題。

請匯報此錯誤於 "update-manager" 套件並附上以下的錯誤訊息:

'E:未知的類型 '正在查找主機',位於在來源列表 /etc/apt/sources.list.d/winehq.list 中的第 1 行, E:無法讀取來源列表。'

引用:
sudo gedit /etc/apt/sources.list.d/winehq.list
用它打开后,删掉第一行,仍然出现错误。


:em20


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 12:40 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
不知道这个源干什么用的。如果用不上直接删除:
代码:
sudo rm /etc/apt/sources.list.d/winehq.list

或者备份
代码:
sudo mv /etc/apt/sources.list.d/winehq.list /etc/apt/sources.list.d/winehq.list.old

要用了再改回来
代码:
sudo mv /etc/apt/sources.list.d/winehq.list.old /etc/apt/sources.list.d/winehq.list


_________________
Grub2 基础教程


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 12:43 
头像

注册: 2009-01-23 17:02
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
引用:
***@***:~$ sudo rm /etc/apt/sources.list.d/winehq.list
***@***:~$ 密码
bash: ***@: command not found
***@***:~$
引用:
rm: 無法建立目錄「/etc/apt/sources.list.d/winehq.list」: 沒有此一檔案或目錄

多谢回复,但我好郁闷。再看上面~


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 13:07 
头像

注册: 2009-01-23 17:02
帖子: 140
送出感谢: 0 次
接收感谢: 0 次
搞掂了 又可以更新了 新立德也行了 谢谢了


:em02


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 无法升级
帖子发表于 : 2009-06-18 13:08 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
:em05


_________________
Grub2 基础教程


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译