当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : deb包不能安装&更新错误(已解决)
帖子发表于 : 2009-06-29 20:18 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
为了彻底删除旧版的Opera,以管理员权限打开/usr(sudo gnome-open),以opera为关键词搜索,搜索结果全部删除并清空了回收站。
这下,所有的 .deb 包都不能安装了,系统也不能更新了。
本地的.deb 包打开几秒钟就没了,见鬼。

在新立得中安装一些文件有下面的提示:
pre-installation script 返回了错误号 1

求救!不想重装!
谢谢您!


_________________
Ubuntu14.10 + Firefox + Gimp


最后由 卞锦生 编辑于 2009-06-30 13:38,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: deb包不能安装&更新错误
帖子发表于 : 2009-06-29 20:19 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
新闻管有难了 :em04 有你这么删的吗?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: deb包不能安装&更新错误
帖子发表于 : 2009-06-29 20:53 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
:em06
所以UB限制root是极其明智的。

解决方法:
不知道UB的盘有没有像WIN那样的系统修复功能。
我用心爱的UB810盘启动LiveCD,用opera为关键词搜索/usr,搜出的东西复制到本地的对应位置。
一切恢复正常。
主要是python中的几个东西被删了。
:em11


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译