当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : fcitx怎么还是乱码???
帖子发表于 : 2009-07-19 13:32 
头像

注册: 2009-05-14 18:13
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
先是用sicm,遂觉得不好用,想尝试一下小企鹅输入法。
直接remove了sicm,装了fcitx,没出意外果真是方框出现~~~~~
遂照前辈经验编辑~/.fcitx/config,是不是因为我的是9.04的原因,找不到~/.fcitx/config,即使用其他帖子上的路径找到的config也是乱码形式打开的~~~虽然要编辑的就是最靠前的那行!!!
后来我直接打开/usr/share/fcitx/data?/config,但是默认的文本编辑器还是以乱码的形式打开了,无语~~~~~
我右键用OpenOffice打开,选了编码字符,终于看见真身了,哈哈~~~
遂修改时发现权限不够,我真不知道用sudo是怎么运行OpenOffice的~~~~
后来想用chmod命令修改读写权限,想问一下,我们自己的用户名登陆的是属于什么类型的账户?g组?o其他用户?a所有用户?
没管,我给了所有用户的读写权限~~后来还是不行!不能改。。。。。。
我用sudo直接修改,乱码也不管了,反正我是看到*了,fc-list了字体列表,直接换了一个顺眼的,重启·~··还是不行!!

这么一个问题困扰了我好久,试了n次不成功,教程都很简单的,怎么就操作了还是不行呢。运行相同的命令返回的怎么就不一样了~~~~求解!!!!!

另外为缓解没有中文输入法,接着install了ibus,可是没有启动项,加了两个自带的启动项,竟然一个是韩文一个是日文,还有一个是其它什么东西~~~

God save me!!!!!!


附解决方法:(我没成功......)http://forum.ubuntu.org.cn/viewtopic.php?f=8&t=184598


_________________
其实神也是人!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: fcitx怎么还是乱码???
帖子发表于 : 2009-07-19 14:06 
头像

注册: 2008-10-24 22:02
帖子: 5853
地址: 浙江
送出感谢: 0 次
接收感谢: 3
代码:
sudo apt-get install im-switch fcitx
sudo im-switch -s fcitx -z default

注销后 ctrl+空格 就出调出输入法 之后就有~/.fcitx/config

或者
安装右键中以管理员打开
代码:
 sudo apt-get install nautilus-gksu

用OpenOffice编辑


fcitx源代码及deb安装包 - 更新到r241 - 2009/07/19
viewtopic.php?f=8&t=192737


_________________
http://sb.google.com/ 提问前 请在右上角搜索一下
请不要跨省追捕!水表在门外。谢谢! 大家一起twitter


页首
 用户资料  
 
3 楼 
 文章标题 : Re: fcitx怎么还是乱码???
帖子发表于 : 2009-07-19 14:36 
头像

注册: 2007-06-13 15:57
帖子: 12565
地址: 在他乡
送出感谢: 50
接收感谢: 87
可能用gedit啊打开啊,用OO不嫌麻烦吗?
sudo gedit ~/.fcitx/config


页首
 用户资料  
 
4 楼 
 文章标题 : Re: fcitx怎么还是乱码???
帖子发表于 : 2009-08-05 13:07 

注册: 2008-08-18 16:44
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
daf3707 写道:
可能用gedit啊打开啊,用OO不嫌麻烦吗?
sudo gedit ~/.fcitx/config


大哥阿,你打开不是乱码么?说话要说清楚阿!你这样很不负责任的说


页首
 用户资料  
 
5 楼 
 文章标题 : Re: fcitx怎么还是乱码???
帖子发表于 : 2009-08-05 13:09 
头像

注册: 2008-02-17 23:47
帖子: 22109
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
代码:
sudo gedit

点击打开~/.fcitx/config,编码那里选gb2312


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
6 楼 
 文章标题 : Re: fcitx怎么还是乱码???
帖子发表于 : 2009-08-06 0:23 

注册: 2009-08-06 0:03
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
这个乱码问题要这么解决:
运行gconf-editor,在左边的树中选择apps->gedit-2->preferences->encodings
修改auto_detected的值,增加GB2312,并将它上移至顶上。如果不可以,重启你的X,退出后再进入,应该就可以了。

然后第一行会有个
显示字体=*
这里的*其实是会匹配当前系统中的首个中文的,但是因为有问题,所以没匹配上,就用缺省的方块来替代了。

安装字体的方法,最简单的就是将Windows下的字体拷过来。
然后那里的*号可以换成simsun(也就是宋体)。然后重启X,退出后再进入,即可。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: fcitx怎么还是乱码???
帖子发表于 : 2009-08-15 0:22 

注册: 2008-12-03 11:00
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
2个问题需要你解决
1.gedit的乱码自己去wiki查找新手指南.有的,在中文支持那里.
2.fcitx的乱码是因为配置文件的原因.

遂照前辈经验编辑~/.fcitx/config,是不是因为我的是9.04的原因,找不到~/.fcitx/config,即使用其他帖子上的路径找到的config也是乱码形式打开的~~~虽然要编辑的就是最靠前的那行!!!
后来我直接打开/usr/share/fcitx/data/config

/usr/share/fcitx/data/config这个配置文件是fcitx的默认配置,不要修改它.

~/.fcitx/config这个自己修改下,要是没有就把/usr/share/fcitx/data/config复制一份过去.之所以会乱码是因为字体的原因,建议使用文权意.或者是windows下的一些字体.
字体的安装自行wiki.配置自己看fcitx的帮助,不会的问我


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译