当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 谁帮我翻译视频会议系统的资料下!谢谢!
帖子发表于 : 2009-08-07 15:50 

注册: 2008-11-16 10:27
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
原文地址:http://www.crium.univ-metz.fr/docs/system/dimdim/
代码:
How to install dimdim on debian / ubuntu

still in progress ....

dimdim 4.5 comes with a very poor documentation to man an install on debian and ubuntu

You can download source from sourceforge

and unzip  Dimdim_v4.5_SourceCode.zip

in v4.1/Product/Build/Scripts/SF_RPM_Script/ we find a Dimdim_SF_32_v4.5_build.xml file to build an rpm package

so we need some debian package to build this rpm

apt-get install sun-java6-jdk rpm

# we will use python package from legacy debian testing repository
# rather than build each one
apt-get install python-cherrypy3 python-flup  python-pycurl

# same think for openoffice
apt-get install python-uno



Troubles :
now demjson is missing ...

I can't build FastCGI reflector so I comment Reflector code in Dimdim_SF_32_v4.5_build.xml with xml tags < !-- -- >

Rpm package is build in /usr/src/redhat so we need

ln -s /usr/src/rpm/  /usr/src/redhat


$ cd v4.1/Product/Build/Scripts/SF_RPM_Script
$ ant -f Dimdim_SF_32_v4.5_build.xml build
....
$ ll /usr/src/redhat/RPMS/i386/
$ -rw-r--r-- 1 root root 87722581 mar 30 12:10 dimdim-4.5-1.i386.rpm



First step : we have a rpm package !! ... only usable on CentOS ...

Let's use alien to modify this package for debian / ubuntu.


apt-get install alien devscripts


alien  /usr/src/rpm/RPMS/i386/dimdim-4.5-1.i386.rpm  --scripts -g


 -g create a dimdim-4.5 directory with traditional debian/ directory to build a debian package and original source package in usr/
Scripts contains in rpm specs format are translate in debian/preinst debian/postinst
We can change this scripts to build an usable (maybe clean) package for debian with

dpkg-buildpackage -rfakeroot
and install with

 dpkg -i ../dimdim_4.5-2_i386.deb

The prinstall script is absolutly ugly, it detectes only CentOS, search dependencies with "find / ", search open ports with netstat. We can easily remove all his content.
We will use later some clean dependencie management with usual debian/control .

Next step :
 debian install 

màj - 22 / 6 / 2009 par agostini Courriel Imprimer Haut de page Retour Éditer


_________________
坚持走一个ubuntu系统,多个虚拟xp路线,不动摇!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 谁帮我翻译视频会议系统的资料下!谢谢!
帖子发表于 : 2009-08-07 15:55 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
安装步骤都看不懂,装上也不会用吧。。。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 谁帮我翻译视频会议系统的资料下!谢谢!
帖子发表于 : 2009-08-07 16:19 

注册: 2008-11-16 10:27
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
装上可以汉化,有汉化包。我现在是装不上!


_________________
坚持走一个ubuntu系统,多个虚拟xp路线,不动摇!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 谁帮我翻译视频会议系统的资料下!谢谢!
帖子发表于 : 2009-08-07 16:31 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
汉化包。。。 :em20

使用 任何一个 终端 程序

如果出现Permission denied提示,就加sudo

How to install dimdim on debian / ubuntu
still in progress ....

dimdim 4.5 comes with a very poor documentation to man an install on debian and ubuntu

You can download source from sourceforge

and unzip Dimdim_v4.5_SourceCode.zip

in v4.1/Product/Build/Scripts/SF_RPM_Script/ we find a Dimdim_SF_32_v4.5_build.xml file to build an rpm package

so we need some debian package to build this rpm

代码:
sudo apt-get install sun-java6-jdk rpm


# we will use python package from legacy debian testing repository
# rather than build each one
代码:
sudo apt-get install python-cherrypy3 python-flup  python-pycurl


# same think for openoffice
代码:
sudo apt-get install python-uno




Troubles :
now demjson is missing ...

I can't build FastCGI reflector so I comment Reflector code in Dimdim_SF_32_v4.5_build.xml with xml tags < !-- -- >

Rpm package is build in /usr/src/redhat so we need

代码:
ln -s /usr/src/rpm/  /usr/src/redhat



$ cd v4.1/Product/Build/Scripts/SF_RPM_Script
$ ant -f Dimdim_SF_32_v4.5_build.xml build
....
$ ll /usr/src/redhat/RPMS/i386/
$ -rw-r--r-- 1 root root 87722581 mar 30 12:10 dimdim-4.5-1.i386.rpm



First step : we have a rpm package !! ... only usable on CentOS ...

Let's use alien to modify this package for debian / ubuntu.


代码:
sudo apt-get install alien devscripts



代码:
alien  /usr/src/rpm/RPMS/i386/dimdim-4.5-1.i386.rpm  --scripts -g



-g create a dimdim-4.5 directory with traditional debian/ directory to build a debian package and original source package in usr/
Scripts contains in rpm specs format are translate in debian/preinst debian/postinst
We can change this scripts to build an usable (maybe clean) package for debian with

代码:
dpkg-buildpackage -rfakeroot

and install with

代码:
dpkg -i ../dimdim_4.5-2_i386.deb


The prinstall script is absolutly ugly, it detectes only CentOS, search dependencies with "find / ", search open ports with netstat. We can easily remove all his content.
We will use later some clean dependencie management with usual debian/control .

Next step :
debian install


人家没写完呢。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 谁帮我翻译视频会议系统的资料下!谢谢!
帖子发表于 : 2009-08-07 18:36 

注册: 2008-11-16 10:27
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
luojie-dune,
非常感谢。我看了下,他写完了。


_________________
坚持走一个ubuntu系统,多个虚拟xp路线,不动摇!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 谁帮我翻译视频会议系统的资料下!谢谢!
帖子发表于 : 2009-08-07 19:15 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
这个软件的支持看样子很成问题———没有人维护。。。最好不要用了。。。公司内部用吧,使用Ekiga吧。。。标准协议的话都通用。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译