当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-09 18:44 

注册: 2009-07-17 10:04
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
:em20 nvidia mx400 显卡,受限驱动已经改过,就是nvidia settings 最大只能识别到640x480 我的显示器是山寨的,朋友组装的,windows下1024x768没有问题,xorg.conf修改启动是报错,让我用低配置启动,而且不能用device 0 然后从device 1启动,快崩溃了 :em20


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-09 22:32 
头像

注册: 2008-07-28 10:02
帖子: 765
送出感谢: 1
接收感谢: 0 次
或许,以下内容可以暂时帮你解决一下显示问题。
viewtopic.php?f=77&t=217097&start=30


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-10 21:51 

注册: 2009-07-17 10:04
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
czjl, 按照你的办法只能调到800x600,1024x768黑屏,还有别的办法吗?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-10 21:52 

注册: 2009-07-17 10:04
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
czjl, 按照你的办法只能调到800x600,1024x768黑屏,还有别的办法吗?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-10 22:16 
头像

注册: 2008-09-20 14:27
帖子: 631
送出感谢: 1
接收感谢: 0 次
我的显卡和你的一样,显示器是三星的,把我的xorg.conf给你参考一下。



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Jun 25 18:57:07 PDT 2009

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
# generated from default
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Device"
Identifier "Device0"
VendorName "NVIDIA Corporation"
Driver "nvidia"
Option "NoLogo" "True"
EndSection


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-11 12:01 
头像

注册: 2008-07-28 10:02
帖子: 765
送出感谢: 1
接收感谢: 0 次
可以先按照5楼的改一下(有专用驱动的),如果还不行,就彻底删除专用驱动,然后按照我推荐的方法修改xorg.conf试试。
注意备份原有xorg.conf! :em11


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-12 2:54 

注册: 2005-09-27 10:32
帖子: 702
送出感谢: 0 次
接收感谢: 0 次
我建议换显示器试试。

我觉得不是显卡驱动的问题。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 9.04下显示器只能显示到640x480,求解
帖子发表于 : 2009-08-12 20:27 

注册: 2009-07-17 10:04
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 83.0
VertRefresh 50.0 - 75.0
Option "DPMS"
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Virtual 1024 768
Modes "1024x768@60"
EndSubSection
EndSection

改成以上配置,貌似可以了,现在是我们孩子进不去摩尔庄园了,估计是浏览器的问题,看来我还得继续努力,谢谢各位的支持,我会努力的 :em11


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译