当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装最新mysql版本mysql-5.1.38,执行mysql_install_db 出错
帖子发表于 : 2009-09-11 0:32 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
昨天刚下了最新mysql版本mysql-5.1.38,安装进行到 bin/mysql_install_db --user=mysql又出错了,错误如下:
Installing MySQL system tables...
090911 0:10:46 [ERROR] /opt/web/mysql/libexec/mysqld: unknown option '--skip-bdb'
090911 0:10:46 [ERROR] Aborting

090911 0:10:46 [Warning] Forcing shutdown of 3 plugins
090911 0:10:46 [Note] /opt/web/mysql/libexec/mysqld: Shutdown complete
这个错误和安装mysql-5.1.28不太一样,后者是unknown option '--skip-federated',只要将/etc/my.cnf文件中的skip-federated注释掉即可,
我又照样去修改/etc/my.cnf,但找不到--skip-bdb,
然后我又重新安装,在,/configure 时加入了一项--with-plugins=all,但最后还是出同样的错误!!令人抓狂阿!
我感觉还是修改/etc/my.cnf,但不知如何修改,请高手指教!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装最新mysql版本mysql-5.1.38,执行mysql_install_db 出错
帖子发表于 : 2009-09-11 10:25 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
没有兄弟帮小弟解决一下吗?好郁闷阿


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装最新mysql版本mysql-5.1.38,执行mysql_install_db 出错
帖子发表于 : 2009-09-11 12:25 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
我又安装以前成功过的版本mysql-5.1.30,出现mysql/libexec/mysqld: unknown option '--skip-federated',修改my.cnf后,又出现了同样的错误
/mysql/libexec/mysqld: unknown option '--skip-bdb'
我已经彻底失败了,高手快来拯救一下吧!!!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装最新mysql版本mysql-5.1.38,执行mysql_install_db 出错
帖子发表于 : 2009-09-11 12:27 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
这难道是系统升级的原因吗? :em20


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译